Last Comment Bug 553412 - (IndexedDB) Implement Indexed Database API
(IndexedDB)
: Implement Indexed Database API
Status: RESOLVED FIXED
[evang-wanted]
: dev-doc-complete, meta
Product: Core
Classification: Components
Component: DOM: Core & HTML (show other bugs)
: Trunk
: All All
: -- normal with 8 votes (vote)
: mozilla2.0
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
Mentors:
https://wiki.mozilla.org/Firefox/Proj...
Depends on: async-IndexedDB 553420 573176 574507 574740 574801 574811 575399 576406 579882 584319 585471 594478 594583 595307 AsyncIDB 729076 762199 891555
Blocks: 569993 587797
  Show dependency treegraph
 
Reported: 2010-03-18 15:08 PDT by Shawn Wilsher :sdwilsh
Modified: 2014-12-25 13:18 PST (History)
48 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-


Attachments

Description Shawn Wilsher :sdwilsh 2010-03-18 15:08:49 PDT

    
Comment 1 Damon Sicore (:damons) 2010-06-21 16:39:17 PDT
Not blocking the first beta.
Comment 2 Shawn Wilsher :sdwilsh 2010-06-22 10:17:05 PDT
This shouldn't block beta 2 either since we haven't even started working on it.  Block the final perhaps?
Comment 3 Shawn Wilsher :sdwilsh 2010-06-22 10:46:34 PDT
(In reply to comment #2)
> This shouldn't block beta 2 either since we haven't even started working on it.
>  Block the final perhaps?
er..to be clearer, I mean that we haven't started on the sync version of this API at all.  The async version is just about ready to land, and that bug is blocking b1.
Comment 4 Christopher Blizzard (:blizzard) 2010-06-24 21:23:20 PDT
Nice, early async landed - what's left?
Comment 5 Shawn Wilsher :sdwilsh 2010-06-24 22:42:37 PDT
(In reply to comment #4)
> Nice, early async landed - what's left?
Everything on worker threads, plus recent spec changes (and changes to come).
Comment 6 Mike Beltzner [:beltzner, not reading bugmail] 2010-06-30 00:00:59 PDT
Final for now, might want to pull it back in to be more aggressive. We can likely do that on some of the other bugs, though.
Comment 7 Michał Giełda 2010-07-11 01:10:08 PDT
So the sync (worker) API will only land in the November final release? It's been very hard to find the answer to this question on the web, on MDC there is more documentation on the sync API than there is on the async one, which makes it even more confusing...
Comment 8 Christopher Blizzard (:blizzard) 2010-07-12 15:53:16 PDT
Right now the async api is the one that's in the tree.  I think there's work underway on the sync api as well, but we'll know more over the next few weeks/months.
Comment 9 Shawn Wilsher :sdwilsh 2010-08-02 14:14:10 PDT
While I'm still helping on IndexedDB, I'm not working on it full time anymore.  Reassigning to bent to better reflect reality.
Comment 10 guido@tapia.com.au 2010-12-02 14:40:33 PST
In FF4b7 createObjectStore no longer works.  It fails with the following error:
uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIIDBDatabase.createObjectStore]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: http://localhost/test.js :: anonymous :: line 83" data: no]

This code has been working since FF4b4 I believe. 

Sample Code:
db.createObjectStore('TestTable', 'ID'); 
// Where db is the event.result of the 
// window.moz_indexedDB.open('dbname', 'dbname') 
// command

Guido Tapia
Comment 11 Johnny Stenback (:jst, jst@mozilla.com) 2010-12-09 15:25:26 PST
Not blocking on the tracker bug.
Comment 12 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-08-22 13:09:25 PDT
I think we can call this done.
Comment 13 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-08-23 04:59:50 PDT
We don't support sync Indexed DB yet.
Comment 14 Shawn Goertzen 2012-01-19 10:22:58 PST
Chrome is allowing access to the async api from web workers.  Is there any chance of getting that functionality in Firefox as well?  Might be easier to just open the async api up to web workers compared to creating a new sync API.

http://code.google.com/p/chromium/issues/detail?can=2&start=0&num=100&q=&colspec=ID%20Pri%20Mstone%20ReleaseBlock%20Area%20Feature%20Status%20Owner%20Summary&groupby=&sort=&id=64054
Comment 15 Kyle Huey [:khuey] (khuey@mozilla.com) 2012-01-19 12:56:10 PST
Adding the sync API and adding the async API are roughly equally difficult at the moment, because adding anything to workers is quite difficult.  It's on our radar though, and once the worker DOM bindings are sorted out IndexedDB is one of the first things on the list.
Comment 16 Jonas Sicking (:sicking) PTO Until July 5th 2012-03-14 13:35:29 PDT
I don't think there's a point to keeping this bug open just because we don't support IDB in workers (sync or async alike). We have separate bugs for those efforts, having a separate tracking bug doesn't buy us anything.

If anything we should have a IndexedDB bugzilla component. I'll see what it takes to get that going.
Comment 17 Florian Scholz [:fscholz] (MDN) 2012-03-24 11:17:49 PDT
(In reply to Jonas Sicking (:sicking) from comment #16)
> I don't think there's a point to keeping this bug open just because we don't
> support IDB in workers (sync or async alike). We have separate bugs for
> those efforts, having a separate tracking bug doesn't buy us anything.

Same for documentation. There is https://developer.mozilla.org/en/IndexedDB and sub pages now.
We can add dev-doc-needed to separate bugs then as well.
Comment 18 Brunus 2013-06-04 23:20:19 PDT
IndexedDB does not work on version 21 of firefox.

Not just for "workers"

The demos ON YOUR OWN SITE do not work.
They either tell me that I need a newer version of firefox or that firefox does not support well ... anything.

They tell me to see:
https://developer.mozilla.org/en/IndexedDB/IDBFactory#Browser_compatibility

Also, THERE IS NO INDEXEDDB DEMO, ON ANY SITE, THAT WORKS WITH MY BROWSER.  
I cannot update anything.
What happened to IndexedDB.  I even followed the w3 code example.
An explanation would be nice.
Comment 19 Shawn Goertzen 2013-06-05 03:58:40 PDT
Brunus,

I just updated to Firefox 21 and my test site that uses IndexedDB is still working fine.  Give it a try, and if you are still having issues you may want uninstall/reinstall your browser:  http://www.shawngoertzen.com/wp-content/Html5Site/

(In reply to Brunus from comment #18)
> IndexedDB does not work on version 21 of firefox.
> 
> Not just for "workers"
> 
> The demos ON YOUR OWN SITE do not work.
> They either tell me that I need a newer version of firefox or that firefox
> does not support well ... anything.
> 
> They tell me to see:
> https://developer.mozilla.org/en/IndexedDB/IDBFactory#Browser_compatibility
> 
> Also, THERE IS NO INDEXEDDB DEMO, ON ANY SITE, THAT WORKS WITH MY BROWSER.  
> I cannot update anything.
> What happened to IndexedDB.  I even followed the w3 code example.
> An explanation would be nice.
Comment 20 Brunus 2013-06-05 15:47:10 PDT
Thank you for taking the time to reply.

No.  The example that you set up does not work in my browser.
And ... No.  My browser does not need to be "reinstalled".
I would love to say that the reason it is not working is that I
am limited in my ability as a programmer but this is simply not true.

NOT ONE EXAMPLE OF IndexedDB HAS WORKED IN MY FIREFOX BROWSER SO FAR.

I do not expect you to reply.

Note You need to log in before you can comment on or make changes to this bug.