Closed Bug 1000191 Opened 7 years ago Closed 7 years ago

[NFC] |NfcPeer.sendNDEF| fails on emulator

Categories

(Firefox OS Graveyard :: NFC, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed)

RESOLVED FIXED
2.0 S1 (9may)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: tzimmermann, Assigned: allstars.chh)

References

Details

(Whiteboard: [p=1])

Attachments

(1 file)

NFC is enabled, but |NfcPeer.sendNDEF| fails because |NFC._enabled| is false. I can reproduce this with the test case that is attached to bug 980851.
Yoshi, this started happening after rebasing on bugs 970263 and 970251. Could you take a look?
Flags: needinfo?(allstars.chh)
I can out-comment the test near Nfc.js:579 to make NfcPeer.sendNDEF work.
Assignee: nobody → allstars.chh
Flags: needinfo?(allstars.chh)
blocking-b2g: --- → 2.0+
Summary: [NFC] |NfcPeer.sendNDEF| fails → [NFC] |NfcPeer.sendNDEF| fails on emulator
Attached patch PatchSplinter Review
Didn't have a test case because we still need to fix Bug 987596 first.
(In reply to Yoshi Huang[:allstars.chh] from comment #3)
> Created attachment 8411659 [details] [diff] [review]
> Patch
> 
> Didn't have a test case because we still need to fix Bug 987596 first.

Thanks Yoshi. I'll test this locally.
Comment on attachment 8411659 [details] [diff] [review]
Patch

Review of attachment 8411659 [details] [diff] [review]:
-----------------------------------------------------------------

Works.
Attachment #8411659 - Flags: feedback+
Attachment #8411659 - Flags: review?(dlee) → review+
https://hg.mozilla.org/mozilla-central/rev/1778e4c2abd7
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S1 (9may)
Whiteboard: [p=1]
You need to log in before you can comment on or make changes to this bug.