Closed Bug 1001261 (emulator_wifi) Opened 6 years ago Closed 5 years ago

B2G WiFi emulation on emulator-kk

Categories

(Firefox OS Graveyard :: Emulator, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(tracking-b2g:+, b2g-v2.1 fixed, b2g-v2.1S fixed, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
2.2 S11 (1may)
tracking-b2g +
Tracking Status
b2g-v2.1 --- fixed
b2g-v2.1S --- fixed
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: vicamo, Assigned: seinlin)

References

Details

(Whiteboard: [ft:ril])

Attachments

(5 files)

+++ This bug was initially created as a clone of Bug #991025 +++

It seems WiFi emulation on emulator-jb, kk can't be done with trivial merge or cherry-pick.  Filed this bug to track necessary steps.
Too bad... I can take a look at this bug.
On JB, we don't have "mount_all" command issued in either init.rc or init.goldfish.rc, so "nonencrypted" action is never fired, neither does class "late_start".
Whiteboard: [ft:ril]
blocking-b2g: --- → backlog
Blocks: emulator-kk
tracking-b2g: --- → +
Summary: B2G WiFi emulation on emulator-jb,kk → B2G WiFi emulation on emulator-jb, kk, l
Alias: emulator_wifi
blocking-b2g: backlog → ---
We are going to need this to make everything work related to emulator testing...
Change the bug title, as we don't really care emulator-jb...
Summary: B2G WiFi emulation on emulator-jb, kk, l → B2G WiFi emulation on emulator-kk, l
Henry will help to support this bug.
Assignee: nobody → hchang
Summary: B2G WiFi emulation on emulator-kk, l → B2G WiFi emulation on emulator-kk
Henry, could you review this patch? There are also some other related patches, I'll attach in later comment. Thanks!
Attachment #8596619 - Flags: review?(hchang)
Assignee: hchang → kli
Attachment #8596622 - Flags: review?(hchang)
Depends on: 1157806
Comment on attachment 8596624 [details] [review]
Update emulator-kl/l to use b2g forked wpa_supplicant.

This manifest shouldn't be merged, before bug 1157806 is resolved fixed.
Attachment #8596620 - Flags: review?(hchang) → review+
Comment on attachment 8596622 [details] [review]
Add wpa_supplicant and hostapd to init.goldfish.rc.

Sorry that I forgot to mention the need of [1]. It lets wpa_supplicant to be able to update config.

[1] https://github.com/mozilla-b2g/device_generic_goldfish/commit/3cae7eee1f7f00ba1eb53c733a8779f345055c6e
Attachment #8596622 - Flags: review?(hchang)
Attachment #8596624 - Flags: review?(hchang) → review+
Attachment #8596619 - Flags: review?(hchang) → review+
Comment on attachment 8596622 [details] [review]
Add wpa_supplicant and hostapd to init.goldfish.rc.

Henry, I updated the PR, could you have a look?
Attachment #8596622 - Flags: review?(hchang)
Attachment #8596622 - Flags: review?(hchang) → review+
Comment on attachment 8596624 [details] [review]
Update emulator-kl/l to use b2g forked wpa_supplicant.

This is a fix in b2g-manifest. Do not have any change in gecko/gaia.

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): n/a
User impact if declined: can't use wifi on emulator-kk
Testing completed: verify on master
Risk to taking this patch (and alternatives if risky): low, update manifest to use wpa_supplicant with our fixed
String or UUID changes made by this patch: none
Attachment #8596624 - Flags: approval-mozilla-b2g37?
Attachment #8596624 - Flags: approval-mozilla-b2g34?
Comment on attachment 8596624 [details] [review]
Update emulator-kl/l to use b2g forked wpa_supplicant.

Approving for emulator support.
Attachment #8596624 - Flags: approval-mozilla-b2g37?
Attachment #8596624 - Flags: approval-mozilla-b2g37+
Attachment #8596624 - Flags: approval-mozilla-b2g34?
Attachment #8596624 - Flags: approval-mozilla-b2g34+
No longer blocks: emulator-l_taskcluster
You need to log in before you can comment on or make changes to this bug.