Closed Bug 1003789 Opened 6 years ago Closed 6 years ago

[VR][Messaging] Contact's photo doesn't appear in the message inbox

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+, b2g-v2.0 affected)

RESOLVED DUPLICATE of bug 994553
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- affected

People

(Reporter: lolimartinezcr, Unassigned)

References

Details

(Keywords: regression)

Attachments

(2 files)

Attached image 2014-04-30-07-13-49.png
Tested
1.5
Hamachi
Gecko: 13b2542
Gaia: 08ea844

Reproducible: not 100%

NOTE:Noemi and me can reproduce it in two scenarios (but similar), although we thinks root cause is same

Scenario 1:
pre-requisites
* contact B created (name, surname, phone number)

STRs:
* receive a message from contact B
* Tap contacts app and add a photo to contact B. The photo is properly shown in contacts app
* Tap "home" button
* Tap messaging app

ACTUAL RESULT:
* The photo is not shown (See "2014-04-30-07-13-49.png" screenshot). It is necessary to kill messaging app and launch it again in order to properly see the photo (see "2014-04-30-07-14-04.png" screenshot)

EXPECTED RESULT:
* The photo is properly shown

Scenario 2:
Pre-requisites: Empty list contacts.

STRs:
1. Tap messages aplication.
2. Write messages to phone number A
3. Send message
4. Tap "home" button
5. Tap contact aplication.
6. Tap "New contact" and create contact with name, surname, phone A and photo
7. Tap "home button
8. Tap message aplication

ACTUAL RESULT:
* The photo is not shown.

EXPECTED RESULT:
* The photo is properly shown
Attached image 2014-04-30-07-14-04.png
blocking-b2g: --- → 2.0?
Summary: [VR][Messaging] Contact's photo not appear in list message → [VR][Messaging] Contact's photo doesn't appear in the message inbox
Blocks: 951676
Blocks: sms-visual-refresh
No longer blocks: 951676
Does this reproduce on 1.4?
Keywords: qawanted
Could not reproduce on a Buri running 1.4. 

Following STR1, the image appeared correctly after step #3.
Following the STR2, the image appeared correctly after step #8.

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140502000201
Gaia: 7b2b82d72cbdd1c7e0f4542cb3390802e65f473e
Gecko: 50be03cea340
Version: 30.0
Firmware Version: V1.2-device.cfg
Julien, the scenarios commented here have to do more with the logic of the app than with styles (BB).
Could you please have a look?
Thanks!
Flags: needinfo?(felash)
blocking-b2g: 2.0? → 2.0+
Yes, I already investigated because there is actually bug 994553 about this issue.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(felash)
Resolution: --- → DUPLICATE
Duplicate of bug: 994553
You need to log in before you can comment on or make changes to this bug.