bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Shift Page-Up in content area (not editor) doesn't work to select the next page of text.

VERIFIED DUPLICATE of bug 151481

Status

()

Core
Selection
--
minor
VERIFIED DUPLICATE of bug 151481
17 years ago
16 years ago

People

(Reporter: Jon Califf, Assigned: mjudge)

Tracking

Trunk
mozilla1.1alpha
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: EDITORBASE-, URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.4) Gecko/20010917
BuildID:    2001091712

Shift Page-Up doesn't work to select the next page of text. The cursor just
stays where it is.

Reproducible: Always
Steps to Reproduce:
1. Find any text box.
2. Make sure there is more than a page of text, so there are scroll bars on the
side.
3. With your cursor near the top of the text, hold down shift and hit Page-Down
to select the next page of text.


Actual Results:  The cursor stays right where it was.

Expected Results:  It should have slected the next page worth of text.
Duplicate of "PgUp/PgDn in editor don't move caret (platform differences)"

*** This bug has been marked as a duplicate of 4302 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

17 years ago
I may not have understood the other bug wrong, but I think that you're mistaken
in calling it a duplicate. It's "broken" the same way outside of a text box as
well. When you're viewing a page you can hold down shift to select text and
scroll with the up-down keys. You can also scroll up and down using
Pg-Up/Pg-Down, but if you are selecting text text with shift and scrolling up or
down using Pg-Up/Pg-Down nothing happens.
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
Those are two separate things.... shift-pgup/pgdown in a textarea is covered by
bug 4302.  What you want is a binding for shift-pgup/pgdown in <browser>. 
resummarizing accordingly, and over to selection.
Assignee: pchen → mjudge
Status: UNCONFIRMED → NEW
Component: XP Apps → Selection
Ever confirmed: true
QA Contact: sairuh → tpreston
Summary: Shift Page-Up doesn't work to select the next page of text. → Shift Page-Up in content area (not editor) doesn't work to select the next page of text.

Comment 5

17 years ago
dup of bug 70154?
(Reporter)

Comment 6

17 years ago
I don't know what I was thinking when I changed it from dupe of 4302 back to
new. This is the same issue as seen in 4302.

*** This bug has been marked as a duplicate of 4302 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 7

17 years ago
I swear I must have been on crack last night. I'm so sorry. It was way too late
to be working on this. Different bug.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 8

17 years ago
Now that I review this bug, I'm not completely sure that it is valid at all.
Internet Explorer does not use any keyboard shortcuts at all to select text in
<browser>. 

However, to really FIX it, I suppose one would either have to remove the
Shift-Up/Dn functionality in <browser> OR change it to select text when you do
Shift-Pg-Up/Dn as well as Shift-Up/Dn to remain consistent within Mozilla.
Please note that the Macintosh platform Shift-Pg-Up/Dn should not do anything,
since PgUp/Dn are not supposed to move the caret (see bug 4302, I believe it
applies to this).

I would like to see Shift-Pg-Up/Dn select the next/previous screen of text in
the Windows and Linux versions of the browser so that it remains consistent. I
like keyboard shortcuts to select text, even if Internet Explorer does not
behave this way. Most other Windows applications do.

Sorry to add even more confusion to this bug. I'll be more careful in the future
to make sure that I know what I'm talking about before I make changes and post
new bugs.
(Assignee)

Comment 9

17 years ago
this is the same as an editor base that says page-up on windows doesnt move 
caret. fix that one and this is fixed.
Status: REOPENED → ASSIGNED
Whiteboard: EDITORBASE

Comment 10

17 years ago
Might be a dupe.  Don't know the other bug number. marking 1.0
Target Milestone: --- → mozilla1.0

Comment 11

17 years ago
Linux, marking EDITORBASE-, retargeting to mozilla1.1
Whiteboard: EDITORBASE → EDITORBASE-
Target Milestone: mozilla1.0 → mozilla1.1

*** This bug has been marked as a duplicate of 151481 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 13

16 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.