Closed Bug 1008225 Opened 5 years ago Closed 3 years ago

Remove fog / frost effect behind the menu bar on Windows 8

Categories

(Firefox :: Theme, defect, P4)

All
Windows 8
defect
Points:
8

Tracking

()

VERIFIED FIXED
Firefox 51
Tracking Status
firefox50 --- verified
firefox51 --- verified

People

(Reporter: dao, Assigned: dao)

References

Details

(Whiteboard: [outreachy-12])

Attachments

(1 file)

From bug 1007229:

That fog was intended for aero glass. It made sense to keep it on Windows 8 as long as we couldn't adjust the text color depending on the frame color, but now not so much. It feels super alien on Windows 8.
Flags: firefox-backlog+
Blocks: 1022547
Whiteboard: p=3 [qa+]
Points: --- → 3
Flags: qe-verify+
Whiteboard: p=3 [qa+]
Duplicate of this bug: 1235320
Blocks: fx-qx
Blocks: 1248735
No longer blocks: fx-qx
Was this fixed by bug 1184651?
Flags: needinfo?(dao)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)
> Was this fixed by bug 1184651?

Nah, there's still a lighter frostness behind the menu bar on its own on win8. It's gone in win10, but not win8.
Flags: needinfo?(dao)
(In reply to :Gijs Kruitbosch from comment #3)
> (In reply to Jared Wein [:jaws] (please needinfo? me) from comment #2)
> > Was this fixed by bug 1184651?
> 
> Nah, there's still a lighter frostness behind the menu bar on its own on
> win8. It's gone in win10, but not win8.

But then bug 1235320 isn't a duplicate :/
No longer blocks: 1248735
Assignee: dao → nobody
Mentor: jaws
Status: ASSIGNED → NEW
Whiteboard: [outreachy-12]
Jared, you have a plan for how to approach this? You're sure this is a good candidate for a mentored bug?
Flags: needinfo?(jaws)
I was planning to make this one of the penultimate bugs of the Outreach internship, but hesitated on changing the Points column since you had already put in "3" and I assumed you knew of a clear path forward based on that score. I was ready to put an 8 or 13 on it.

I was hoping that by the end of the internship, the intern will have enough experience to be willing to investigate what is necessary and not need as much hand-holding.
Flags: needinfo?(jaws)
Points: 3 → 8
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Attachment #8778561 - Flags: review?(florian)
Mentor: jaws
Comment on attachment 8778561 [details] [diff] [review]
move Aero Glass-specific rules from -moz-windows-compositor section to -moz-windows-glass section

Review of attachment 8778561 [details] [diff] [review]:
-----------------------------------------------------------------

Looks reasonable. I don't have access to test machines with the various versions of Windows, so my r+ here is more a sanity check by code inspection than a full review. That's probably enough though :).
Attachment #8778561 - Flags: review?(florian) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/a1727a7c7f2f
move Aero Glass-specific rules from -moz-windows-compositor section to -moz-windows-glass section. r=florian
https://hg.mozilla.org/mozilla-central/rev/a1727a7c7f2f
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this bug with Nightly 32.0a1 (2014-05-09) on Windows 8.1 , 64 bit!
This Bug's fix is verified on Latest Nightly 51.0a1.

Build ID : 20160810030202
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160810]
(In reply to azmina721 from comment #11)
> I have reproduced this bug with Nightly 32.0a1 (2014-05-09) on Windows 8.1 ,
> 64 bit!
> This Bug's fix is verified on Latest Nightly 51.0a1.
> 
> Build ID : 20160810030202
> User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101
> Firefox/51.0
> 
> [bugday-20160810]

Thanks!
Status: RESOLVED → VERIFIED
Verified fixed on Windows 8.1 x64 using latest DevEdition 50.0a2, build ID 20160914004005.
Flags: qe-verify+
QA Contact: cornel.ionce
You need to log in before you can comment on or make changes to this bug.