Closed Bug 1235320 Opened 4 years ago Closed 4 years ago

Remove the text-shadow from menu bar items without Aero glass

Categories

(Firefox :: Theme, defect, P4)

All
Windows 10
defect
Points:
2

Tracking

()

VERIFIED FIXED
Firefox 48
Tracking Status
firefox48 --- fixed

People

(Reporter: phlsa, Assigned: ktbee, Mentored)

References

(Blocks 1 open bug)

Details

(Whiteboard: [windows10][qx][outreachy-12])

Attachments

(1 file)

The items in the menu bar on Windows have a text shadow applied to them. This is a legacy style from Windows 7 that looks out of place and is no longer needed on Windows 10, so let's remove it.
Do you mean the glass/fog effect, or something else? See also bug 1008225.
Flags: needinfo?(philipp)
I think I mean the same thing: putting this rule into a media query that excludes Windows 10 and 8:
https://dxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser-aero.css#333
Flags: needinfo?(philipp)
No longer blocks: fx-qx
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1008225
Blocks: 1248735
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Priority: -- → P4
IMHO this is a duplicate of bug 1198538.
(In reply to Adolfo Jayme from comment #4)
> IMHO this is a duplicate of bug 1198538.

That bug is about the highlight colors used in menus generally, which is different from the menubar having text shadow.
Katie, would you like to work on this next? See comment #2 for an approach to try.
Mentor: jaws
Status: REOPENED → NEW
Flags: needinfo?(kbroida)
Whiteboard: [windows10][qx] → [windows10][qx][outreachy-12]
Thanks Jared, I've written this patch using a media query based on comment 2. I didn't include windows-xp in the query because I wasn't sure that the more recent versions of Firefox still support it (and I didn't see it accounted for anywhere else in browser-aero.css). If we need it however, I can add it in.
Flags: needinfo?(kbroida)
Attachment #8740244 - Flags: review?(jaws)
Assignee: nobody → kbroida
Status: NEW → ASSIGNED
Comment on attachment 8740244 [details] [diff] [review]
Removes menu bar text shadow

Review of attachment 8740244 [details] [diff] [review]:
-----------------------------------------------------------------

browser-aero.css is only included when the operating system is *not* Windows XP, which is why you didn't see XP referenced in browser-aero.css.

We actually have a large number of users still on Windows XP, so we'll want to keep supporting those users. However, this rule wasn't previously applied to Windows XP, so we shouldn't worry about adding it there now. This patch looks good, nice job!
Attachment #8740244 - Flags: review?(jaws) → review+
https://hg.mozilla.org/mozilla-central/rev/a79bc2230647
Status: ASSIGNED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 48
Drive-by comment: This seems like a case where `@media (-moz-windows-glass)` is what was wanted as the shadow was due to glass IIRC (see also bug ). We should avoid `-moz-os-version` when we can do proper feature detection.

You can review the screenshots of the change that landed at https://screenshots.mattn.ca/compare/?oldProject=mozilla-central&oldRev=49d7fb650c9dde7cf6e4b2c7aa578a4a11e83f83&newProject=mozilla-central&newRev=564b225d553547fe4aa9a1039278f695c9507db9 and looking at the Windows 8 section. This change only affected all configurations showing the menubar (allToolbars) and with no lightweight theme (noLWT) which seems expected.

For clarity (since it was mentioned in comment 1) this only affected the text shadow, not the white rectangular frosting.
Hardware: x86 → All
Summary: Remove the text-shadow from menu bar items on Windows 10 → Remove the text-shadow from menu bar items without Aero glass
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.