Closed Bug 1022547 Opened 5 years ago Closed 3 years ago

Menu bar unreadable in High Contrast mode

Categories

(Firefox :: Theme, defect, P1)

30 Branch
x86_64
Windows 8.1
defect
Points:
3

Tracking

()

VERIFIED FIXED
Firefox 51
Tracking Status
firefox49 --- wontfix
firefox50 --- verified
firefox51 --- verified

People

(Reporter: Unfocused, Assigned: dao)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(3 files)

Attached image Screenshot
The main menu is basically unreadable in High Contrast mode, due to:
* Glass blur/text shadow effect
* Lack of contrast from color of text

See attached screenshot.
Flags: firefox-backlog?
Flags: firefox-backlog? → firefox-backlog+
Note: The submenus are fine.
Depends on: 1008225
Points: --- → 3
Keywords: access
Priority: -- → P1
Whiteboard: p=3
Summary: Main menu unreadable in High Contrast mode → Menu bar unreadable in High Contrast mode
Duplicate of this bug: 1292997
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Attachment #8780847 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8780847 [details] [diff] [review]
move rule for menu text color since it's wrong on Windows 8 and later where all themes use the compositor

r=me
Attachment #8780847 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/e34ed28ec449
move rule for menu text color since it's wrong on Windows 8 and later where all themes use the compositor. r=gijs
https://hg.mozilla.org/mozilla-central/rev/e34ed28ec449
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this bug with Nightly 32.0a1 (2014-06-09) on Windows 8.1 , 64 bit! 

This Bug's fix is verified on Latest Nightly 51.0a1 .

Build ID : 20160816030459
User Agent : Mozilla/5.0 (Windows NT 6.3; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160817]
Thanks!
Status: RESOLVED → VERIFIED
Duplicate of this bug: 1298645
Windows 10 doesn't even have the odd glow effect, so it's pure black-on-black. 

I tried to use the patch in a user style in Firefox 48, but it didn't work, so I hard-coded the color. https://userstyles.org/styles/132146/menu-bar-on-high-contrast-windows-64-bit-firefox

Any chance of uplift for this bug?
Per comment #10, feels like this could be uplifted to 50 relatively painlessly. It's too late for 49. Dão, would you agree?
Flags: needinfo?(dao+bmo)
Attached patch patch for upliftSplinter Review
Approval Request Comment

This is bug 1008225's and this bug's patch combined. Fixing bug 1008225 is a prerequisite for this one.

[Feature/regressing bug #]: high-contrast mode support
[User impact if declined]: unreadable menu bar
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: low. just moving around some CSS, baked on Nightly for almost a month
[String/UUID change made/needed]: none
Flags: needinfo?(dao+bmo)
Attachment #8789308 - Flags: approval-mozilla-aurora?
Comment on attachment 8789308 [details] [diff] [review]
patch for uplift

Fix was verified on Nightly, CSS only, low risk, Aurora50+
Attachment #8789308 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Duplicate of this bug: 1301616
I have reproduced this bug with Firefox nightly 32.0a1 (2014-06-09) on Windows 10, 64 Bit.

The Bug's fix is now verified on latest nightly 52.0a1 (2016-09-29).

Build ID 	20160929030426
User Agent     Mozilla/5.0 (Windows NT 10.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

[testday-30092016]
QA Whiteboard: [good first verify]
On my platform it works just fine. im running firefox version 50.0 beta 7

On windows 7 - 64 bits
You need to log in before you can comment on or make changes to this bug.