Closed Bug 101025 Opened 19 years ago Closed 19 years ago

double-clicking turbo icon focuses download progress window

Categories

(Core Graveyard :: QuickLaunch (AKA turbo mode), defect)

x86
Windows 98
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.8

People

(Reporter: jruderman, Assigned: law)

References

Details

Steps to reproduce:
1. Using Mozilla, start downloading a new nightly build.
2. Close all browser windows.
3. Double-click on the quick launch icon in the system tray.

Result: The download progress window gets focus.
Expected: A new browser window opens.

See also:
bug 99856 double-clicking turbo icon unmaximizes an open browser window
bug 91129 double clicking turbo icon with no open windows only opens browser 
            (with pref to also open mail)
QA Contact: sairuh → tpreston
-> new quick launch component
Assignee: pchen → law
Component: XP Apps → QuickLaunch (AKA turbo mode)
QA Contact: tpreston → gbush
*** Bug 104151 has been marked as a duplicate of this bug. ***
This is working the way it was intended.  Double-clicking the systray icon 
raises the last-used Mozilla window.  It only opens a Nav window if there is 
no "last used" window.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → INVALID
verified
Status: RESOLVED → VERIFIED
Wow, you're right, it will focus a mail window if that's all I have open.  I 
don't like that, though.  I think double-clicking the icon should always create 
a new navigator window.  Focusing a download window is confusing (note that 
this bug was reported twice), and the double-click behavior can't be useful 
unless it's consistent.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
Target Milestone: --- → mozilla0.9.8
I've attached a patch to bug 88123 that fixes this bug, also.
fixed (via patch for bug 88123)
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → FIXED
verified with mozilla build 2002012203
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.