Closed Bug 1010628 Opened 6 years ago Closed 5 years ago

Implement de-duping/merging multiple link providers for Directory Tiles

Categories

(Firefox :: New Tab Page, defect)

defect
Not set
Points:
8

Tracking

()

VERIFIED FIXED
Firefox 34
Iteration:
34.2

People

(Reporter: jboriss, Assigned: dao)

References

Details

(Whiteboard: fixed by bug 990322)

This bug is the implementation followup of bug 988447.  It should implement a few of the more basic de-duping strategies outlined in that bug.

Acceptance criteria:

1. Exact duplicates of directory tiles and browsed-to tiles should not exist.  In other words, if a page that is a direct duplicate of a visible Directory Tile gains a high enough frecency score to be shown, it will not be shown, but the Directory Tile will suffice as that site's representation.

2. For non-exact matches, both of natural sites with Directory Tile and natural sites with each other, redirects and similar URLs will be identified and de-duped.  For instance, ebay.com = www.ebay.com = http://wwww.ebay.com/loggedin=refererfirefox = etc.  If the page navigated to is the same to users, they should not produce duplicates in new tab.  This will be particularly important on sites with logins, such as Gmail.  Currently, we should the whole URL string instead of title for some logged out pages ( http://cl.ly/image/211a3X143o1T and http://cl.ly/image/0r1j21070Y13 ), when what we should be showing is simply Gmail.  

#2 will likely involve some discussion between eng and ux on how to recognize and how to de-dup given technical constraints.  That discussion can happen in this bug.
Flags: firefox-backlog+
Depends on: 988447
Whiteboard: p=0
Whiteboard: p=0 → p=0 [qa?]
Component: Tabbed Browser → New Tab Page
Blocks: 1030832
Whiteboard: p=0 [qa?] → [tiles] p=0 [qa?]
Depends on: 1030892
Decision from bug 1030892 doesn't require history tiles to be deduped.
No longer blocks: 1030832
This bug isn't needed to implement enhanced tiles as multiple history items for the same site are still allowed.
(In reply to Ed Lee :Mardak from comment #2)
> This bug isn't needed to implement enhanced tiles as multiple history items
> for the same site are still allowed.

So, does that mean that this bug should be wontfix'd in your opinion, or just that it is not required in order to ship enhanced tiles?

Also, are there any interactions between this bug and the work in bug 990322?
Flags: needinfo?(edilee)
(In reply to Philipp Sackl [:phlsa] from comment #3)
> So, does that mean that this bug should be wontfix'd in your opinion, or
> just that it is not required in order to ship enhanced tiles?
clarkbw can make the final decision for enhanced and directory tiles. I believe the functionality is desired but not high priority as most users won't be seeing an exact history page with the directory links.

> Also, are there any interactions between this bug and the work in bug 990322?
Bug 990322 seems to be the general case of only showing one tile for a given eTLD+1 (which could mean history + directory or more likely history + history).
Flags: needinfo?(edilee)
(In reply to Ed Lee :Mardak from comment #4)
> (In reply to Philipp Sackl [:phlsa] from comment #3)
> > So, does that mean that this bug should be wontfix'd in your opinion, or
> > just that it is not required in order to ship enhanced tiles?
> clarkbw can make the final decision for enhanced and directory tiles. I
> believe the functionality is desired but not high priority as most users
> won't be seeing an exact history page with the directory links.

Not required to ship Enhanced Tiles.  However I think this is desired, I'd like to see us come out with a solution we're ready to use.  I'm fairly certain that we'll be pushing for to be fixed this after we land the first version of Enhanced Tiles.

> > Also, are there any interactions between this bug and the work in bug 990322?
> Bug 990322 seems to be the general case of only showing one tile for a given
> eTLD+1 (which could mean history + directory or more likely history +
> history).

I wouldn't mind exploring this, it seems to work in a lot of cases.
Whiteboard: [tiles] p=0 [qa?] → [tiles]
Points: --- → 8
QA Whiteboard: [qa+]
Depends on: 990322
Whiteboard: [tiles] → fixed by bug 990322
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Iteration: --- → 34.2
QA Contact: cornel.ionce
Assignee: nobody → dao
Target Milestone: --- → Firefox 34
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:34.0) Gecko/20100101 Firefox/34.0
Mozilla/5.0 (X11; Linux i686; rv:34.0) Gecko/20100101 Firefox/34.0

There were no dupes displayed during testing this using latest Nightly, build ID: 20140818030205 on Windows 7 64bit, Mac OS X 10.9 and Ubuntu 12.04 32bit.
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
You need to log in before you can comment on or make changes to this bug.