Closed Bug 101069 Opened 21 years ago Closed 20 years ago

offline: mac+solaris only: imap delete model not played back when you go online

Categories

(SeaMonkey :: MailNews: Backend, defect, P2)

PowerPC
Mac System 9.x
defect

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.9

People

(Reporter: grylchan, Assigned: Bienvenu)

Details

Attachments

(1 file)

Using commercial build
 2001-09-19-08-0.9.4/ mac 9.1

Spun off from bug 96631.
Mac only as windows/linux builds don't exhibit same behavior.

I don't know why, but when you set the trash mode to 'mark as deleted'
go offline, delete a message (downloaded/nondownload), a red x
appears but when you go back online it appears as a brand
new mesg instead of keeping the red x mark. 

Was using standard imap mail account. Tried other macs/builds
and see same problem.

steps
1. login into imap mail account
2. set trash mode to mark as deleted.
3. go offline
4. delete few messages
5. go back online
6. may need to click 'get mesg' button.

result: messages with red x, come back as brand new messages (bold, 
        green dot), instead of the red x in each message.
Keywords: nsbeta1
Keywords: nsbeta1nsbeta1+
Priority: -- → P2
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla0.9.9
Blocks: 122274
Keywords: nsbeta1+nsbeta1-
Target Milestone: mozilla0.9.9 → mozilla1.2
No longer blocks: 122274
marking as dupe of bug 97310

*** This bug has been marked as a duplicate of 97310 ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
reopening - actually, this bug is different than the other one - I'll mark the
other one fixed, and leave this one open for the fix we're going to check in for
this.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I believe this was also affecting solaris.
Summary: offline: mac only: imap delete model not played back when you go online → offline: mac+solaris only: imap delete model not played back when you go online
Status: REOPENED → ASSIGNED
Target Milestone: mozilla1.2 → mozilla0.9.9
fixed.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
removed the item for this bug from the release notes for 0.9.9 and beyond,
because the bug is fixed now. Let me know if you think the item should be 
re-added.
Using commercial trunk
2002032208 on Mac 9.2.2 & 10.1.3

Verified with trash mode 'Mark as deleted' and offline, that
deleted mesgs (either downloaded/non-downloaded) keep the
red 'x' when going back online and that when you go back online
you can compact that folder and those mesgs will dissapear.

marking as verified.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.