Closed Bug 96631 Opened 23 years ago Closed 23 years ago

offline delete with imap delete model not played back when you go online

Categories

(SeaMonkey :: MailNews: Backend, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
mozilla0.9.5

People

(Reporter: Bienvenu, Assigned: Bienvenu)

References

Details

(Whiteboard: pdt+)

Attachments

(1 file)

If you are using the imap delete model, and you delete a message while offline,
the message is not deleted when you go back online, at least as near as I could
tell.
Confirmed using 2001082403 - win nt 4.0.

It works fine if you do:
  -go offline
  -delete a mesg (either downloaded/non-downloaded)
  -go back online
  -mesg(s) are still in trash can

Won't work:
  -go offline
  -delete a mesg (either downloaded/non-downloaded)
  -undo
  -repeat the delete
  -go back online
  -click on another folder and then go back to original folder
   where you deleted mesg from
  -mesg will be there.
this is only when using the imap delete model (sorry for the incorrect summary
mentioning undo - undo doesn't work either, but that's probably related). So
97310 is really a dup of this bug.
Summary: Undo of offline delete with imap delete model not played back when you go online → offline delete with imap delete model not played back when you go online
thanks David. will mark the other bug a dupe of this
*** Bug 97310 has been marked as a duplicate of this bug. ***
nominating for branch - some offline users might be using imap delete model (or
delete immediately). Haven't looked into what the problem is yet, though.
Status: NEW → ASSIGNED
Keywords: nsbranch
Blocks: 99230
Attached patch proposed fixSplinter Review
Navin, can I get a r= for this? The fix is to carry forward the imap deleted
flag like all the other flags we were already carrying forward. I've also fixed
the tabs in this routine, but the -uw diff doesn't show that.
this is another offline polish bug we need for eMojo. The risk is low. 
Keywords: nsbranchnsbranch+
Target Milestone: --- → mozilla0.9.5
r=naving
Comment on attachment 49213 [details] [diff] [review]
proposed fix

sr=sspitzer
Attachment #49213 - Flags: superreview+
Blocks: 99508
*** Bug 97415 has been marked as a duplicate of this bug. ***
fix checked into trunk only.
Gary, would you please test and verify?  If no regressions exist please check
into the branch.
Whiteboard: pdt+
PDT+ per PDT meeting today. Gary has signed off to do the QA on the branch.
Using commercial 
2001-09-14-09-trunk nt 4.0
2001-09-14-08-trunk linux 2.2, mac 9.1

I'm still seeing problems.

I tested all 3 trash modes, deleting while online/offline,
and deleting nondownloaded/downloaded mesgs.

Everything works fine except for these test cases:
Test1
  -trash mode: Remove Immediately and deleting any type of
               mesg (down/non-down.) in either inbox or another folder.
               Happens on all 3 os's..
      my steps:
         1. Download few mesgs in your inbox and another folder.
         2. set mode to 'remove immediately'
         3. go offline
         4. Test inbox first
             a. delete a down./non-down. mesg 
             b. dissapears from inbox
             c. go back online
             d. 2 mesgs should appear
                -if they don't try clicking get mesg button to see if they
                 reappear
                -click on another folder, than click on inbox should see them
               expected result: not to see the deleted mesgs
         5. Test another folder now
            a. repeat steps from step 4 above except replace inbox
               with other folder. same results happen
Test2
 -trash mode: Mark as Deleted and deleting any type of
               mesg (down/non-down.) in either inbox or another folder.

              This ONLY Happens in MAC builds. Windows and Linux
              works fine.
  steps:
         1. Download few mesgs in your inbox and another folder.
         2. set mode to 'mark as deleted'
         3. go offline
         4. Test inbox first
             a. delete a down./non-down. mesg 
             b. red x appears
             c. go back online
             d. 2 mesgs should loose their red x and be 'brand new mesgs'
                in bold and with green dot highlighted.
                -if they don't try clicking get mesg button to see if they
                 don't have red x.
                -click on another folder, than click on inbox & should see them
                 with out red x
               expected result: to see the messages with red x
         5. Test another folder now
            a. repeat steps from step 4 above except replace inbox
               with the other folder. same results happen

I have NO idea why Mac behavior for Mark as Deleted differs from win/linux.

David I did not reopen my 'remove immediately' bug 97310 since we agreed
that it would be dupe of this bug.

And I have no idea if my other bug 99696 is related to this fix or not.


HAs this been checked in yet?
Checking into the branch for bienvenu.
Status: ASSIGNED → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
I reopened bug 97310 (that's test case 1, right?) since it doesn't appear to be
a complete dup (though this bug would have to be fixed for 97310 to be fixed,
I'm sure). Bug 99696 is not related. I don't know why there would be a mac-only
problem with test case 2.
Yes David you reopened correct bug for 'remove immediately'.

Commercial branch builds
 2001-09-19-05-0.9.4/ win nt 4.0
 2001-09-19-04-0.9.4/ linux 2.2
 2001-09-19-08-0.9.4/ mac 9.1
 2001-09-19-04-0.9.4/  mac 10.0.4

Imap Delete model (mark as deleted) works in Windows and Linux.

Still seeing the problem in mac. Tried 2 different 9.1 computers
and tried a 3rd computer with os 10.0.4 and I see the same problem.

When you delete a mesg, while offline, when you go back online
the mesg comes back as brand new and red x is gone. (might have
to do a 'get mesg' to bring the mesg back).

Should I reopen this bug? Call in the mac troops? :-)



if you re-open it, make sure it's marked Mac only in the summary and remove the
status whiteboard and keywords so they can be re-evaluated.
mac only bug is bug 101069.

You guys rock!  Thanks for fixing this.
Since already verified on branch (wind. and linux only), and I
opened a brand new bug for mac only, going to add vtrunk
to keyword section.
Keywords: vtrunk
Status: RESOLVED → VERIFIED
Keywords: vtrunk
commercial trunk
2001-10-08-09-trunk NT 4.0
2001-10-08-08-trunk linux 2.2

Verified imap delete model (mark as deleted) works
while offline. Messages that are deleted (downloaded/non-downloaded)
while offline, still are marked as deleted when going back online.

Mac trunk build (10-8) still exhibits the same problem as
described in bug 10106.

removing keyword vtrunk.

marking as verified.


removing link to this fixed bug from mozilla 0.9.6 release notes
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.