HTML <select> element missing right border with some fonts

RESOLVED DUPLICATE of bug 545685

Status

()

defect
RESOLVED DUPLICATE of bug 545685
5 years ago
3 years ago

People

(Reporter: kresimir.virovic, Unassigned)

Tracking

({testcase})

29 Branch
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

5 years ago
Posted image firefox---bug.jpg
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

this worked fine before firefox updated to verion 29.0.1

@font-face
{    
font-family: 'MyriadProRegular';
src: url('fonts/MyriadPro-Regular.eot');
src: local('MyriadProRegular'), url('fonts/MyriadPro-Regular.woff') format('woff'), url('fonts/MyriadPro-Regular.ttf') format('truetype');
}


Actual results:

In HTML select element, when it is opened, <option> list right border missing.


Expected results:

Opened <option> list should have all borders visible
Reporter

Comment 1

5 years ago
UPDATE:
Problem is with some font-sizes

I've try Arial font-size 16, same thing
Reporter

Updated

5 years ago
Summary: HTML <select> element missing right border when non-system fonts used in css → HTML <select> element missing right border

Comment 2

5 years ago
Can you provide a link to a testcase (either on jsbin/jsfiddle/codepen/... or on your own website) ?
Flags: needinfo?(kresimir.virovic)
Summary: HTML <select> element missing right border → HTML <select> element missing right border with some fonts

Updated

5 years ago
Component: Untriaged → General
Keywords: testcase
Product: Firefox → Core
Reporter

Comment 3

5 years ago
file default.css line 58
try changing font size from 15 to 16 and backward
Flags: needinfo?(kresimir.virovic)
Whiteboard: DUPEME
Component: General → Layout: Form Controls
Duplicate of this bug: 1153821
Probably the same underlying issue as in bug 994923 / bug 924068 / bug 545685.
Depends on: 994923
This still reproduces on Nightly with e10s disabled, but not with it enabled. That said, I can reproduce this bug with the attached testcase as far back as Firefox 4, so this doesn't seem like a recent regression. I'm going to dupe this to bug 545685.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
Duplicate of bug: 545685
You need to log in before you can comment on or make changes to this bug.