Status

()

defect
RESOLVED DUPLICATE of bug 545685
6 years ago
3 years ago

People

(Reporter: aprjanka, Unassigned)

Tracking

({regression})

22 Branch
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:24.0) Gecko/20100101 Firefox/24.0 (Beta/Release)
Build ID: 20130910160258

Steps to reproduce:

Applied css width in em to a select element.

http://jsfiddle.net/qLQaq/




Actual results:

The dropdown right border is missing.


Expected results:

The dropdown should have borders on all side.

Comment 1

6 years ago
Posted image border.jpg
Not on my side,the right border is visible.

Updated

6 years ago
Component: Untriaged → Layout: Form Controls
Product: Firefox → Core
(Reporter)

Comment 2

6 years ago
(In reply to Loic from comment #1)
> Created attachment 814153 [details]
> border.jpg
> 
> Not on my side,the right border is visible.

I've found it depends on the browser window size.
1024x768 no border
1025x768 has border
1026x768 no border
(Reporter)

Comment 3

6 years ago
Posted image 1024x768.PNG
(Reporter)

Comment 4

6 years ago
Posted image 1025x768.PNG
(Reporter)

Comment 5

6 years ago
Posted image 1026x768.PNG

Comment 6

6 years ago
It's due to:
Jonathan Kew — bug 844604 - default to auto devPixelsPerPx setting on windows. r=jimm
I gthink.
Blocks: 844604
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Version: 24 Branch → 22 Branch
(Reporter)

Comment 7

6 years ago
(In reply to Loic from comment #6)
> It's due to:
> Jonathan Kew — bug 844604 - default to auto devPixelsPerPx setting on
> windows. r=jimm
> I gthink.

devPixelsPerPx is default for me (-1)
I'm on low res displays (19'' 1280x1024), dpi is 100% in windows (default).

Comment 8

6 years ago
Can you test by changing the Windows DPI value by 125% e.g. On my machine (1920x1080), the DPI is medium (125%).
(Reporter)

Comment 9

6 years ago
With DPI 125% the border is ok.

Comment 10

6 years ago
Anyway even with DPI at 125%, I'm able to see this bug.
Example on this page: http://i.imgur.com/8TDenih.png

Comment 11

6 years ago
Similar example - Fx on fullscreen, 1600x900 - right border not visible. Resized to smaller window border becomes visible.

http://jsfiddle.net/mcXkj/1/

Comment 12

5 years ago
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
devPixelsPerPx: default (-1)
Resolution: 1920 x 1200

I've seen the same odd window-size select-box right-side-border bug for a while now. It appears for me in aprjanka@gmail.com's example and Artur Muszynski's example (and also appears if I change the css font-size from "em" to "px").

Updated

3 years ago
See Also: → 429302

Comment 14

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20160105164030

Looks like I found a simple test case:
https://jsfiddle.net/yecb5pqa/1/

To get this bug the following conditions must be met:
1. You need container (<body> is enough) with odd width (ex. 101).
2. Inside it another container with width that has decimal part (ex. 91.35) and margin set to "0 auto"
3. <select> inside second container with width set to 100% 

Some time bug shows as thicker right border instead of no border.

Comment 15

3 years ago
Still an issue in Firefox 44.0.2

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20160210153822


Confirmed with jsfiddle mentioned above.

Updated

3 years ago
Duplicate of this bug: 1139853

Updated

3 years ago
Blocks: 1230801
Duplicate of this bug: 1258651

Comment 18

3 years ago
(In reply to Loic from comment #1)
> Created attachment 814153 [details]
> border.jpg
> 
> Not on my side,the right border is visible.

I noticed the issue comes when we have the scroll-bar visible. With full window size, it doesn't appear. When we have the scroll-bar, the right border of the combo is missing.

Comment 19

3 years ago
+1

I've been able to replicate this only when width is set to 100% (or other high percentages). Using precise pixel values "solves" the issue.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545685

Updated

3 years ago
No longer blocks: 1230801
You need to log in before you can comment on or make changes to this bug.