Popups of select-elements in Dropbox's Settings-section does not render the right border correctly with HWA on.

RESOLVED DUPLICATE of bug 545685

Status

()

defect
P4
minor
RESOLVED DUPLICATE of bug 545685
5 years ago
3 years ago

People

(Reporter: elbart, Unassigned)

Tracking

({platform-parity, polish, testcase})

Trunk
x86_64
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 2 obsolete attachments)

Reporter

Description

5 years ago
Posted image Dropbox.png
Firefox 24ESR and latest Nightly

Popups of select-elements in Dropbox's Settings-section have graphical issues on their right sides. Either the line is too thick or not shown at all.

Does not happen when HWA is off.
A standalone testcase would help.
Severity: normal → minor
Keywords: testcase-wanted
Priority: -- → P4
Summary: Popups of select-elements in Dropbox's Settings-section have graphical issues → Popups of select-elements in Dropbox's Settings-section does not render the right border correctly with HWA on.
Reporter

Comment 2

5 years ago
I tried to make a test-case, but for some reason even when saving the whole page with Firefox and opening the local copy, the problem is gone.

Then I tried to disable CSS-rules from within the inspector (<div class="half-column right-column">) on https://www.dropbox.com/account#profile , and the problem goes away when either one of the following is disabled:
1. width in .half-column
2. font-family in "Inherited from body"
3. font-size in "Inherited from body"

Disabling 2. and 3. for the select has the same effect.

Setting the width-value to an integer value also fixes the problem.
By default it's set to 48%, which translates to 475.2px for me. Setting it to 475px and away goes the thick line.

I hope this helps.
Reporter

Comment 3

5 years ago
Posted file 994923_testcase.html (obsolete) —
Testcase made from https://www.dropbox.com/account#profile
I hope it's small enough.

---

(In reply to Elbart from comment #2)
> I tried to make a test-case, but for some reason even when saving the whole
> page with Firefox and opening the local copy, the problem is gone.

Mystery solved: It's because of bug 580860 and the local copy not having the "OpenSans" woff-files, so Firefox defaults to the system's Segue, which doesn't cause the problem.
Reporter

Comment 4

5 years ago
1.) I forgot that fonts from other domains are blocked on a HTTPS-site, sorry. Please unblock the page, otherwise the problem doesn't happen.

2.) The border-issues of the popups only happen for me when the window has certain widths.
I noted where I changed the value so the problem would be visible without needing to play with the window-sizes.

- Right border of the popup is too thick
Attachment #8405322 - Attachment is obsolete: true
Reporter

Comment 5

5 years ago
Posted file 994923_testcase_delete.html (obsolete) —
- Right border of the popup is missing
Reporter

Comment 6

5 years ago
Sorry, forgot to remove a unneeded rule.
Attachment #8405526 - Attachment is obsolete: true
Reporter

Comment 7

5 years ago
I found the regression-ranges for both rendering-problems.

Considering each testcase has a different regression-range, should I open a new bug for one and change this bug to cover the other testcase?
Flags: needinfo?(matspal)
(In reply to Elbart from comment #7)
> I found the regression-ranges for both rendering-problems.

Nice, thanks for helping out.

> Considering each testcase has a different regression-range, should I open a
> new bug for one and change this bug to cover the other testcase?

I don't think that's necessary at this point.  I suspect it might be the same
underlying problem anyway.  We can spawn off a new bug later if needed.
Flags: needinfo?(matspal)
Reporter

Comment 9

5 years ago
Ok, thanks.

Range for testcase "account" and HWA:

Last good revision: f47972d05473 (2010-09-01)
First bad revision: dc2939f2640d (2010-09-02)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=f47972d05473&tochange=dc2939f2640d


Range for testcase "delete" and HWA:

Last good revision: baa6cc2f72e4 (2010-11-20)
First bad revision: be4b69a4babf (2010-11-21)
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=baa6cc2f72e4&tochange=be4b69a4babf
I can reproduce the thick border with the "account" test (which I also see in the Importance
dropdown on this Bugzilla page, BTW).  I couldn't reproduce the other problem.

It seems to depend on which font you have set in Preferences.  The bug occurred for me with
"DejaVu Sans / 16" (Nightly 2014-04-14 on Win7), but not with some other fonts I tried.
(I suspect it's just that different fonts results in the dropdown having different widths.)

In the first range above, harfbuzz (font related) was enabled on Windows by default.
It might have changed the font metrics slightly.  Does the problem go away if you set
the preference gfx.font_rendering.harfbuzz.level to zero in the 2010-09-02 build?
(in about:config)
Status: UNCONFIRMED → NEW
Ever confirmed: true
... You probably need to restart Firefox for that preference change to take effect.
Reporter

Comment 12

5 years ago
(In reply to Mats Palmgren (:mats) from comment #10)
> Does the problem go away
> if you set
> the preference gfx.font_rendering.harfbuzz.level to zero in the 2010-09-02
> build?
> (in about:config)

Yes.

Doing the same for "delete" by changing the default value of 2 in 2010-11-21 to 0 also works.

The default font is set to Firefox's default (Times New Roman 16, iirc).

==========

On a (maybe related) sidenote:
Can you reproduce similar problems this with current Nightly and HWA disabled:

On the attached testcase, open the select-element and let the cursor hover over the opened popup.
Then press Ctrl+'+' once. The right border should disappear.
Pressing the combination a couple times more, and the border should go from gone to one line to gone and finally to thick (because of the zooming-factor, I guess).

It's more obvious when using Ctrl+MousewheelUp/Down.
The zooming can be done with the popup closed, too.

Screencap: 
http://i.imgur.com/CvuxHsj.gif
http://elbart.bplaced.net/bugzilla/994923_select.mp4

Regression-range:

good 2007-10-25
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007/10/2007-10-25-04-trunk/firefox-3.0a9pre.en-US.win32.zip

bad 2007-10-26
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2007/10/2007-10-26-05-trunk/firefox-3.0a9pre.en-US.win32.zip
Reporter

Comment 13

5 years ago
Posted image ditech.png
Another site with that bug:
http://www.ditech.at/shop/liste.php?wg=FPB

Click on "Suche verfeinern / Filter einblenden" and then the "Sortierung:"-dropdownmenu.

Depending on the width of the window, the right border of the dropdown will be missing or not.
Reporter

Comment 14

5 years ago
Posted image fdroid.png
Next up:
https://f-droid.org/repository/browse/
Flags: needinfo?(mats)
I can reproduce the problem at https://f-droid.org/repository/browse/
in Nightly on Linux64 (no hwa).
Flags: needinfo?(mats)
Blocks: 1010703
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 545685
You need to log in before you can comment on or make changes to this bug.