Change the name for the Loop button for Firefox Beta 34

VERIFIED FIXED in Firefox 34

Status

defect
P1
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: standard8, Assigned: mikedeboer)

Tracking

unspecified
mozilla35
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-moztrap -
qe-verify -

Firefox Tracking Flags

(firefox34+ fixed, firefox35+ fixed, firefox36 verified)

Details

(Whiteboard: [mozilla33 carry over][hold for Beta][loop-uplift])

User Story

This gets shown in the Customize UI and in the App/Hamburger menu.

Currently the name is "Invite someone to talk", but it needs to be changed to "Hello" before we ship.

Attachments

(3 attachments, 3 obsolete attachments)

This gets shown in the Customize UI and in the App/Hamburger menu.

Currently the name is blank, but it needs to be decided on before we ship.
Assignee: nobody → alainez
Presumably, this is in part a UX question, and may or may not want to be directly related to the project name.  Adding :darrin to the CC for his input.
Priority: -- → P3
Whiteboard: p=?
Target Milestone: --- → mozilla32
Whiteboard: p=? → [p=0]
We'd like this very soon, but we don't need it for Fx 32.
Target Milestone: mozilla32 → mozilla33
Priority: P3 → P1
Just a thought, this doesn't necessarily have to be a 'product' name, just something short & descriptive enough that users will understand it when they see it in the application menu, or the main customise screen.
Right, something like "Make a call"/"Video calling"/"Video phone"/"Internet phone"/"Internet calling"/"Interactive messaging"  would work. Similarly, we debated having a proper noun for the new Firefox menu but ended up going with "Open menu" for the tooltip.
Thanks for the hint, poking back at RT/Darrin for comment/decision.
Flags: needinfo?(rtestard)
Flags: needinfo?(dhenein)
Arcadio, any views?
Flags: needinfo?(rtestard) → needinfo?(alainez)
Flags: needinfo?(dhenein)
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1017756
Shell, I disagree that this is a duplicate - this is for the button name in the Firefox customizations which may or may not be the same as the branded name (as suggested in comment 4).

This bug also needs to implement it once the decision is made. We're still waiting input from Arcadio.
Status: RESOLVED → REOPENED
Flags: needinfo?(sescalante)
Resolution: DUPLICATE → ---
Arcadio, the decision has been made now so please advise on the exact button name to be used and when is the earliest we can land this.
Romain, 

The app icon should read Firefox Hello. I heard there's a device where I can see the treatment, I'm going to try to find that. 

In the meantime, can we attach a mock-up to this bug for review?

Thanks. 
arcadio
Flags: needinfo?(alainez)
Posted image Customise Menu
(In reply to alainez from comment #10)
> The app icon should read Firefox Hello. I heard there's a device where I can
> see the treatment, I'm going to try to find that. 
> 
> In the meantime, can we attach a mock-up to this bug for review?

Arcadio, I'm confused, do you really mean the app icon? This bug is discussing the icon name within the application menu within Firefox Desktop.

Here's the screenshot of one place it would be shown (also in the customize toolbars screens).

See also comment 4 for more info.
Flags: needinfo?(alainez)
Bug was to implement the name once decided.  Will update tomorrow when the name should be validated.
Flags: needinfo?(sescalante)
Whiteboard: [p=0] → --do_not_change-- [mozilla33 carry over]
Target Milestone: mozilla33 → mozilla34
Whiteboard: --do_not_change-- [mozilla33 carry over] → [mozilla33 carry over]
for this bug - we want to use these icons instead of the phone place holder: https://people.mozilla.org/~dhenein/labs/loop-mvp-spec/#toolbar

if there's an image where the name appears below the icon - it should say Hello - similar to other icons in that area which use the application name (not FireFox Hello)
Flags: needinfo?(alainez)
(In reply to sescalante from comment #13)
> for this bug - we want to use these icons instead of the phone place holder:
> https://people.mozilla.org/~dhenein/labs/loop-mvp-spec/#toolbar
> 
> if there's an image where the name appears below the icon - it should say
> Hello - similar to other icons in that area which use the application name
> (not FireFox Hello)

As per discussions with Arcadio, we should not use the "Hello" name until we land on Beta.
Please carry on using "Invite someone to talk" until we get to Beta.
Assignee: alainez → nobody
Mark -- We know the name, but we don't want to use it until Beta.  Should we do this work at the end of the Fx35 time frame and uplift it into the first Beta 34?
Flags: needinfo?(standard8)
Summary: Decide on the name for the Loop button → Change the name for the Loop button for Beta
Whiteboard: [mozilla33 carry over] → [mozilla33 carry over][hold for Beta]
Making this a P2 to separate it from the other P1 work that we want to do during the Nightly cycle.
Priority: P1 → P2
Will the name still be "Firefox Hello" or "Hello" in builds with non-English locales? I am assuming so, but I just wanted to make sure the decision was explicit, and also so we can let localizers know not to change this string.
Flags: needinfo?(mreavy)
(In reply to [Away for most of July] (please needinfo? me) Jared Wein [:jaws] from comment #17)
> Will the name still be "Firefox Hello" or "Hello" in builds with non-English
> locales? I am assuming so, but I just wanted to make sure the decision was
> explicit, and also so we can let localizers know not to change this string.

I'm not 100% sure, so let's check with Arcadio in Marketing.

Arcadio -- Can you answer Jared's question: Will the name still be "Firefox Hello" or "Hello" in builds with non-English locales?  Thanks.
Flags: needinfo?(mreavy) → needinfo?(alainez)
Priority: P2 → P3
(In reply to Maire Reavy [:mreavy] (Plz needinfo me) from comment #15)
> Mark -- We know the name, but we don't want to use it until Beta.  Should we
> do this work at the end of the Fx35 time frame and uplift it into the first
> Beta 34?

We should do the work to prepare for the name change in 34. This means having new strings ready, and having a placeholder for "Hello" in the meantime.

I don't think any of the existing strings are affected by it.

However, I would point out that I don't think comment 11 has been answered, and that still leaves the question of:

For Firefox Desktop, in the Application menu, for the current phone icon (to be replaced in a separate bug), do we want that text to be "Hello", "Firefox Hello" or something like "Make a call"/"Video calling"/"Video phone"/"Internet phone"/"Internet calling"/"Interactive messaging" as previously suggested.

See comment 3 and 4 for more information.
Flags: needinfo?(standard8)
> However, I would point out that I don't think comment 11 has been answered,
> and that still leaves the question of:
> 
> For Firefox Desktop, in the Application menu, for the current phone icon (to
> be replaced in a separate bug), do we want that text to be "Hello", "Firefox
> Hello" or something like "Make a call"/"Video calling"/"Video
> phone"/"Internet phone"/"Internet calling"/"Interactive messaging" as
> previously suggested.
> 
> See comment 3 and 4 for more information.

I answered it in comment 14: 
"As per discussions with Arcadio, we should not use the "Hello" name until we land on Beta.
Please carry on using "Invite someone to talk" until we get to Beta."
Flags: needinfo?(alainez)
Romain, are you addressing comment 18? The answer must be that we will use "Hello" in all locales because we cannot lift a string to Beta that needs to be translated.
Flags: needinfo?(rtestard)
Flags: needinfo?(alainez)
:jaws that would seem to assume that we want to localize the name itself at all.  Do we?
That was my question in comment 17.
Flags: needinfo?(dmose)
Indeed it was; I'll wait on that to be answered.  :-)
Flags: needinfo?(dmose)
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #17)
> Will the name still be "Firefox Hello" or "Hello" in builds with non-English
> locales? I am assuming so, but I just wanted to make sure the decision was
> explicit, and also so we can let localizers know not to change this string.

I am pretty sure this is "Firefox Hello" for all locales. Arcadio, can you confirm?
Flags: needinfo?(rtestard)
Hi. 

Yes. It's Firefox Hello in all locales. 

Thank you!!

arcadio
Flags: needinfo?(alainez)
Priority: P3 → P1
Whiteboard: [mozilla33 carry over][hold for Beta] → [mozilla33 carry over][hold for Beta][loop-uplift]
Target Milestone: mozilla34 → mozilla35
Blocks: 1076709
Arcadio - just hitting you up for objections to just "Hello" on the hamburger menu.  logic is since they are in the menu - likely don't need to see "Firefox Hello".
User Story: (updated)
Flags: needinfo?(alainez)
(Commenting on User Story)
> This gets shown in the Customize UI and in the App/Hamburger menu.
> 
> Currently the name is blank, but it needs to be changed to "Hello" before we
> ship.

The name isn't currently blank, its "Invite someone to talk". This also gets shown on hover.
User Story: (updated)
Summary: Change the name for the Loop button for Beta → Change the name for the Loop button for Firefox Beta 34
backlog: --- → Fx34+
Blocks: 1077093
Assignee: nobody → mdeboer
Status: REOPENED → ASSIGNED
Iteration: --- → 36.1
Points: --- → 1
Flags: qe-verify+
Flags: needinfo?(mmucci)
Flags: firefox-backlog+
Added to IT 36.1
Flags: needinfo?(mmucci)
Hi if the question is should the name of the Icon in the hamburger icon be just: Hello

I'm good with this since the it's already in Firefox.
Flags: needinfo?(alainez)
Comment on attachment 8505568 [details] [diff] [review]
Patch v1 for fx-team: change the label of the Loop button to Hello

Review of attachment 8505568 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/locales/en-US/chrome/browser/customizableui/customizableWidgets.properties
@@ -96,5 @@
>  # LOCALIZATION NOTE(quit-button.tooltiptext.mac): %1$S is the brand name (e.g. Firefox),
>  # %2$S is the keyboard shortcut
>  quit-button.tooltiptext.mac = Quit %1$S (%2$S)
>  
> -loop-call-button2.label = Start a conversation

For 36 I think you should still use a string as I don't think we hard-code strings normally. There should be a localization note stating that it's a product name and changes need approval. For branches with string freeze I think this patch is fine.
Attachment #8505568 - Flags: review?(MattN+bmo)
Attachment #8505568 - Attachment is obsolete: true
Attachment #8505612 - Flags: review?(MattN+bmo)
Comment on attachment 8505612 [details] [diff] [review]
Patch v2 for fx-team: change the label of the Loop button to Hello

Review of attachment 8505612 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with loop-call-button3.label

::: browser/locales/en-US/chrome/browser/customizableui/customizableWidgets.properties
@@ +98,5 @@
>  quit-button.tooltiptext.mac = Quit %1$S (%2$S)
>  
> +# LOCALIZATION NOTE(loop-call-button2.label2): This is a brand name, request
> +# approval before you change it.
> +loop-call-button2.label2 = Hello

ITYM loop-call-button3.label (update the comment too)
Attachment #8505612 - Flags: review?(MattN+bmo) → review+
Ideally this would use clientShortname2 from loop.properties but that include "Firefox" and arguably should have been the long version with the "short" version being just "Hello".
(In reply to Matthew N. [:MattN] (behind on reviews - focused on Loop) from comment #34)
> ITYM loop-call-button3.label (update the comment too)

Hrm. Inconsistent string versioning FTW.
Comments addressed, carrying over r=MattN.

Setting checkin-needed for this patch, because the tree is closed atm.
Attachment #8505612 - Attachment is obsolete: true
Attachment #8505623 - Flags: review+
Keywords: checkin-needed
Keywords: leave-open
Comment on attachment 8506069 [details] [diff] [review]
Patch v1 for aurora/beta: change the label of the Loop button to Hello

Review of attachment 8506069 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with customizableWidgets.properties reverted

::: browser/locales/en-US/chrome/browser/customizableui/customizableWidgets.properties
@@ -99,5 @@
>  
>  panic-button.label = Forget
>  panic-button.tooltiptext = Forget about some browsing history
>  
> -loop-call-button.label = Invite someone to talk

Don't delete the string for Aurora/Beta. Leave it unused. Deleting strings is still a problem for string freeze last I checked. By leaving it we won't break string freeze.
Attachment #8506069 - Flags: review?(MattN+bmo) → review+
Updated patch ready for landing. Carrying over r=MattN.
Attachment #8506069 - Attachment is obsolete: true
Attachment #8506379 - Flags: review+
Fixed on m-c
Status: ASSIGNED → RESOLVED
Closed: 5 years ago5 years ago
Resolution: --- → FIXED
Comment on attachment 8506379 [details] [diff] [review]
Patch v2 for aurora/beta: change the label of the Loop button to Hello

Review of attachment 8506379 [details] [diff] [review]:
-----------------------------------------------------------------

::: browser/components/customizableui/CustomizableWidgets.jsm
@@ +907,5 @@
>    CustomizableWidgets.push({
>      id: "loop-call-button",
>      type: "custom",
>      // XXX Bug 1013989 will provide a label for the button
> +    label: "Hello",

The above comment should be deleted.
Pauly -- Can you test this with tomorrow's Nightly?  We want to get this into Beta2.

It's just the name change.  If you drag the Hello button from the toolbar in Nightly to the customize menu, you should see it has "Hello" under the icon.  Thanks.
Flags: needinfo?(paul.silaghi)
[Tracking Requested - why for this release]:

This changes the icon name under the icon to "Hello"
Comment on attachment 8506379 [details] [diff] [review]
Patch v2 for aurora/beta: change the label of the Loop button to Hello

Approval Request Comment
[Feature/regressing bug #]: "Hello" name
[User impact if declined]: Name of icon will not appear below icon
[Describe test coverage new/current, TBPL]:landed on m-c, manually tested
[Risks and why]: Without this the "Hello" icon in the palette won't have the official name
[String/UUID change made/needed]: No strings
Attachment #8506379 - Flags: approval-mozilla-beta?
Attachment #8506379 - Flags: approval-mozilla-aurora?
The icon is now called 'Hello'.
Verified fixed FF 36.0a1 (2014-10-17) Win 7, Ubuntu 14.04, OS X 10.9.5
Status: RESOLVED → VERIFIED
Flags: needinfo?(paul.silaghi)
The entity mentioned in the localization note does not match the entity. I looks outdated. So it's not clear if localizers need to ask approval before changing it or not.

# LOCALIZATION NOTE(loop-call-button2.label2): This is a brand name, request
# approval before you change it.
loop-call-button3.label = Hello
Eduardo, you're right! I forgot to update the comment :(

Fixed: https://hg.mozilla.org/integration/fx-team/rev/75c3e79b9c7c
Comment on attachment 8506379 [details] [diff] [review]
Patch v2 for aurora/beta: change the label of the Loop button to Hello

Thank you for not breaking string freeze. Beta+ and Aurora+
Attachment #8506379 - Flags: approval-mozilla-beta?
Attachment #8506379 - Flags: approval-mozilla-beta+
Attachment #8506379 - Flags: approval-mozilla-aurora?
Attachment #8506379 - Flags: approval-mozilla-aurora+
(In reply to Eduardo Trápani from comment #49)
> The entity mentioned in the localization note does not match the entity. I
> looks outdated. So it's not clear if localizers need to ask approval before
> changing it or not.
> 
> # LOCALIZATION NOTE(loop-call-button2.label2): This is a brand name, request
> # approval before you change it.
> loop-call-button3.label = Hello

FYI, this was being handled by bug 1084092.
Tested and good on tbpl Aurora build
I'm deprioritizing further QE testing of this bug as it's been verified in Nightly and is a low risk change.
Flags: qe-verify+ → qe-verify-
Flags: in-moztrap-
You need to log in before you can comment on or make changes to this bug.