Closed Bug 1014335 Opened 6 years ago Closed 4 years ago

Make "Pull to Refresh" in Synced Tabs and Home Panels feel excellent.

Categories

(Firefox for Android :: Awesomescreen, defect, P5)

All
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1183588
Tracking Status
fennec + ---

People

(Reporter: nalexander, Unassigned)

References

Details

Having used pull-to-refresh in the Remote Tabs panel for a while... it's lame.  The laser show is just awful.  It doesn't feel "pull-y" enough, since there's only a weird laser-line indicating that you're pulling at all.  The laser-line gets stuck.

I suggest we go with a refresh icon (down arrow?) like the Plus and Private Plus icons we have in the other trays, and we use the spinning Sync icon (Bug 998700) to indicate action.
ibarlow: antlam: what do y'all think?
Flags: needinfo?(ibarlow)
Flags: needinfo?(alam)
Aaron filed something similar.
Flags: needinfo?(aaron.train)
I'm in agreement, while the pull-to-refresh is platform convention, due to it the tray indicator being off-centre, it does look slightly odd.
I filed a bug bug 1005072. The interaction still seems to be a work-in-progress as far as I can tell, and I agree it doesn't look or function like any other pull-to-refresh that other Android iOS applications have.
Flags: needinfo?(aaron.train)
Nick, I definitely agree. The current laser show isn't the best and we can do better.

Me and Ian were actually experimenting with some better loading animations while we were in London. Will keep you guys posted as mock ups/experiments start surfacing in the form of something more visual.
Flags: needinfo?(alam)
Further to that comment ^

A button for this interaction was not something that we were actually thinking about but will definitely bring that up with Ian.
Yeah, I'm with Nick and Anthony here. The pull to refresh stuff really slid by with not *nearly* enough design review. That's on me. Too many plates in the air, etc. 

At any rate, last week Anthony and I started looking at how to improve the feel of the interaction since I think we can all agree it needs love. 

Let's not throw the baby out with the bathwater though. A button control *somewhere* in the UI may make sense as well, but I think it's too soon to make the call as to whether we should replace this interaction completely with a button. 

We can track the work in this bug, but I'm changing the title if you don't mind, Nick.
Flags: needinfo?(ibarlow)
Summary: Expose "Sync now" icon instead of pull-to-refresh Remote Tabs → Make "Pull to Refresh" in Synced Tabs and Home Panels feel excellent.
Also somewhat related because it's going to take up similar screen real estate (but probably not exactly the same) - bug 1014631.
(In reply to Ian Barlow (:ibarlow) from comment #7)

> Let's not throw the baby out with the bathwater though. A button control
> *somewhere* in the UI may make sense as well, but I think it's too soon to
> make the call as to whether we should replace this interaction completely
> with a button. 

Thank you for giving the pull-to-refresh gesture more focus. Personally, I'd like to not add more UI (button) unless we really need to.
(In reply to Anthony Lam (:antlam) from comment #5)
> Nick, I definitely agree. The current laser show isn't the best and we can
> do better.

I don't know if this was the motivation for the light show, but I just want to note that Google applications (e.g. Gmail) seem to have a laser show with Google colors. However, the show starts only after the list is actually pulled downwards, which we don't do, and what I think pulls the animation together. Perhaps lasers of more than one color helps too.
(In reply to Michael Comella (:mcomella) from comment #10)
> Perhaps lasers of more than one color helps too.

http://i.imgur.com/jLUAQuo.gif
In bug 1010986, I'm disabling pull-to-refresh in home panels for Fx31 because of a drawing issue. As much as I don't think we should block re-enabling it on a better experience, I think we should prioritize this, since people seem to have some strong complaints about it.

needinfo to ibarlow to think about how we want to solve this.
tracking-fennec: --- → ?
Flags: needinfo?(ibarlow)
tracking-fennec: ? → +
Depends on: 1021123
I filed bug 1021123 about disabling this in the remote tabs tray. 

In bug 1010986, I have a patch to disable this in the home panels, but I really only want to land that if we can't fix that drawing regression. Would we want to hold off on shipping the home panel refresh API because of this polish issue? I would argue that the home panel APIs are currently considered more experimental, so it's okay if they're not 100% polished. Also, if we disable this API, we will hide potential bugs (like bug 1010986) that we would find once we decide to re-enable it.
Blocks: 970707
No longer depends on: 1021123
re-needinfo-ing this over to Anthony, as he has been thinking about progress indicators in other parts of fennec as well.
Flags: needinfo?(ibarlow) → needinfo?(alam)
^Indeed, I've got some metaphors and mockups right now but trying to hone in on a metaphor for these motions and interactions that we can carry throughout the entire product. Right now, my main focus is to add both a humanizing and whimsical factor to our animations.

Stay tuned!
filter on [mass-p5]
Priority: -- → P5
This feels like it's at least partially resolved as a part of bug 1183588
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(alam)
Resolution: --- → DUPLICATE
Duplicate of bug: 1183588
You need to log in before you can comment on or make changes to this bug.