Closed Bug 1014966 Opened 6 years ago Closed 6 years ago

[Vertical Homescreen] Scrolling does not pause during divider creation

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect, major)

ARM
Gonk (Firefox OS)
defect
Not set
major

Tracking

(b2g-v2.0 fixed)

VERIFIED FIXED
2.0 S2 (23may)
Tracking Status
b2g-v2.0 --- fixed

People

(Reporter: jlorenzo, Assigned: crdlc)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

Build Information
Gaia      ef66efa34ed8a559c8998bde688fae88eb943a7a
Gecko     https://hg.mozilla.org/mozilla-central/rev/b40296602083
BuildID   20140522040230
Version   32.0a1
ro.build.version.incremental=94
ro.build.date=Tue May 20 09:29:20 CST 2014

Step to reproduce
Enter Edit Mode
Drag a random icon to the bottom of the screen
Continue dragging after exceeding the first divider reserved space

Actual results
You can scroll indefinitely.

Expected results
As per UX specs: When the user reaches the bottom of a row, a space will appear to allow the user to add the icon to the bottom of the row, any quick scrolling will pause.
Summary: [Vertical Homescreen][Flame] Scrolling until having no more visible icons is possible during divider creation → [Vertical Homescreen] Scrolling does not pause during divider creation
Assignee: nobody → crdlc
Status: NEW → ASSIGNED
Whiteboard: [systemsfe]
Target Milestone: --- → 2.0 S2 (23may)
Attached file Github pull request
Thanks for the review
Attachment #8427656 - Flags: review?(kgrandon)
Duplicate of this bug: 1015360
Comment on attachment 8427656 [details]
Github pull request

Thanks. It would be good to have some test for this, but I'm not sure how easy an integration test would be. I wonder if we can cover this with a unit test? Perhaps either mocking some scrolling if needed, or maybe it could just work.
Attachment #8427656 - Flags: review?(kgrandon) → review+
Landed: https://github.com/mozilla-b2g/gaia/commit/560b40a757baac5f296711d299a2e178fdc3f924
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Blocks: 1015336
No longer blocks: vertical-homescreen
Status: RESOLVED → VERIFIED
See Also: → 1019070
Mass modify - set status-b2g-v2.0 fixed for fixed bugs under vertical homescreen dependency tree.
You need to log in before you can comment on or make changes to this bug.