Standalone UI for link clickers needs ringback visual and audio notification

RESOLVED DUPLICATE of bug 1065203

Status

defect
P1
normal
RESOLVED DUPLICATE of bug 1065203
5 years ago
5 years ago

People

(Reporter: RT, Unassigned)

Tracking

unspecified
mozilla35
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: p=2 [standalone-uplift])

User Story

As a WebRTC browser URL clicker but not on Firefox, I get notified that the other party is informed of an incoming call.

Current UX:

https://people.mozilla.org/~dhenein/labs/loop-mvp-spec/#call-outgoing

State transition on outgoing info: Calling -> Ringing

Rough Impl:

Depends on bug 1000237 & its bugs.

* When alerting is received from the server, change the "Connecting" view to display "Ringing".
* Once "streamCreated" is received from both the publisher and the session, send "media-up" to the websocket.

Attachments

(1 attachment)

"Call ringing" is an indication that the other party is being notified of an incoming call.
User Story: (updated)
Depends on: 1015087
This isn't ringing; it's ringback: http://en.wikipedia.org/wiki/Ringback_tone
Summary: Standalone UI for link clickers needs "call ringing" visual and audio notification → Standalone UI for link clickers needs ringback visual and audio notification
User Story: (updated)
Assignee: nobody → dhenein
Status: NEW → ASSIGNED
Whiteboard: p=3 s=33.3 [qa-]
UI: https://people.mozilla.org/~dhenein/labs/loop-link-spec/#connecting
Assignee: dhenein → nobody
Whiteboard: p=3 s=33.3 [qa-] → p=?
Whiteboard: p=? → p=2
Depends on: 1039224
Target Milestone: mozilla33 → mozilla34
Posted audio Ringback Tone.mp3
Initial sound file which may change later.
Please note that as per discussion with Arcadio yesterday we should not be using the "Firefox Hello" brand for now (likely we'll use it when we get to beta). For Nightly and Aurora we should replace "Hello" by "WebRTC" wherever "Hello" appears in the UX and also use the Firefox logo instead of the speech bubble for now.
Blocks: 1039224
No longer depends on: 1039224
Duplicate of this bug: 1000237
Depends on: 1000237
Status: ASSIGNED → NEW
User Story: (updated)
Blocks: 1034041
Whiteboard: p=2 → p=2 [loop-uplift]
Target Milestone: mozilla34 → mozilla35
See Also: → 1015077
This is a standalone bug (no uplift required).
Whiteboard: p=2 [loop-uplift] → p=2
Whiteboard: p=2 → p=2 [standalone-uplift]
backlog: --- → Fx35+
backlog: Fx35+ → Fx36+
No longer blocks: 1039224
No longer blocks: 1034041
This is being implemented in bug 1065203
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1065203
You need to log in before you can comment on or make changes to this bug.