Desktop client needs ringback visual and audio notification for outgoing calls

RESOLVED DUPLICATE of bug 1065201

Status

enhancement
P1
normal
RESOLVED DUPLICATE of bug 1065201
5 years ago
5 years ago

People

(Reporter: RT, Assigned: tomasz)

Tracking

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +
qe-verify -

Firefox Tracking Flags

(firefox35 fixed)

Details

(Whiteboard: 1020449 [loop-outcall1], )

User Story

As a FF browser user (signed in or not) calling a reachable user, I get audio notification that the other party is informed of an incoming call.

Attachments

(1 attachment)

"Call ringing" is an indication that the other party is being notified of an incoming call.
User Story: (updated)
Depends on: 1015087
Priority: P1 → P3
This is required when clicking a call-back link on Firefox or when initiating a direct call from the desktop UI.
Priority: P3 → P1
Target Milestone: mozilla33 → mozilla34
This isn't ringing; it's ringback: http://en.wikipedia.org/wiki/Ringback_tone
Summary: Desktop client needs "call ringing" visual and audio notification → Desktop client needs ringback visual and audio notification
Assignee: nobody → dhenein
Status: NEW → ASSIGNED
Summary: Desktop client needs ringback visual and audio notification → [UX] Desktop client needs ringback visual and audio notification
Whiteboard: [ux] p=3 s=33.2 [qa-]
Target Milestone: mozilla34 → 33 Sprint 2- 7/7
Whiteboard: [ux] p=3 s=33.2 [qa-] → [ux] p=3 s=33.3 [qa-]
Whiteboard: [ux] p=3 s=33.3 [qa-]
Posted audio Ringback Tone.mp3
Initial sound file which may change later.
Target Milestone: 33 Sprint 2- 7/7 → mozilla34
Whiteboard: 1020449
Target Milestone: mozilla34 → mozilla35
Comparing https://people.mozilla.org/~dhenein/labs/loop-mvp-spec/#call-outgoing with current aurora 33 results in several differences:
1. background photo
2. name
3. avatar
4. loading circle,
5. 'ringing...' text
6. cancel button
7. minimize, show in separate window, close buttons
Are those all handled in this bug ?
Flags: needinfo?(rtestard)
This hasn't been implemented yet at all yet - the outgoing call scenario on the mvp spec is for direct calling only, which only comes when we have contacts.

I'm not sure which screen you're looking at in particular on Aurora, but I suspect it is covered by different bugs.
Status: ASSIGNED → NEW
Flags: needinfo?(rtestard)
(In reply to Paul Silaghi, QA [:pauly] from comment #5)
> Comparing
> https://people.mozilla.org/~dhenein/labs/loop-mvp-spec/#call-outgoing with
Agreed, I don't think we got to the point where we could do a break-down. The breakdown should come under https://bugzilla.mozilla.org/show_bug.cgi?id=1046580 but the current "UX matching exercise" is about account-less mode (without conytacts or direct calling) as I understand it.
Blocks: 1066017
No longer blocks: 1000788
Severity: normal → enhancement
User Story: (updated)
Summary: [UX] Desktop client needs ringback visual and audio notification → Desktop client needs ringback visual and audio notification for outgoing calls
Whiteboard: 1020449 → 1020449 [loop-outcall1]
Flags: qe-verify?
Flags: firefox-backlog+
backlog: --- → Fx36+
backlog: Fx36+ → Fx35+
Assignee: nobody → tkolodziejski
Status: NEW → ASSIGNED
Iteration: --- → 36.1
Hi Tomasz, can you assign a point value and mark the bug for QE verification.
Flags: needinfo?(tkolodziejski)
This work probably wants to be based on the work in bug 1065203. Note that the sound files are listed in bug 1065201 - the one attached here might be out of date.
Depends on: 1065203
This got blocked. Depending on the API developed in the other bug (will it magically work for the desktop client?) it may be 3 or 5 points. Maybe I'll assign the points later.

Also feel free <whoever knowing loop better than me> to assign the point value if you have better understanding of the difficulties here.
Flags: needinfo?(tkolodziejski)
Thanks Tomasz.  I'll mark it blocked for IT 36.1

(In reply to Tomasz Kołodziejski [:tomasz] from comment #10)
> This got blocked. Depending on the API developed in the other bug (will it
> magically work for the desktop client?) it may be 3 or 5 points. Maybe I'll
> assign the points later.
> 
> Also feel free <whoever knowing loop better than me> to assign the point
> value if you have better understanding of the difficulties here.
Target Milestone: mozilla35 → ---
Hi Romain,

Is this the right sound here?  Or did that change?  I believe i lost the right sound file between 34 and 35 for this action - which still happens in 35.
Flags: needinfo?(rtestard)
No it's not.
My understanding was that all sounds had to be treated under a single bug hence i created the following:
Desktop client for Fx34: https://bugzilla.mozilla.org/show_bug.cgi?id=1065201
Clicker UI sounds for Fx34: https://bugzilla.mozilla.org/show_bug.cgi?id=1065203

These bugs could not make it in Fx34.

Fx35 sounds change slightly. For Fx35 desktop client sounds I created the following:
https://bugzilla.mozilla.org/show_bug.cgi?id=1088650

I recommend closing this bug as well as bug 1065201 and bug 1065203 to avoid confusion.
Flags: needinfo?(rtestard)
I just chatted with RT about comment 13. Although bug 1088650 handles the new sounds, there's no change in the direct calling sounds.

I therefore recommend that we keep bug 1065201 and bug 1065203 for direct call implementation and use 1088650 for the rooms work.

Closing this one as a dupe of bug 1065201 as that's where we'll be doing the work.
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1065201
Iteration: 36.1 → ---
Flags: qe-verify? → qe-verify-
You need to log in before you can comment on or make changes to this bug.