Cannot choose some double-byte chars folder name to create user profile

RESOLVED DUPLICATE of bug 112031

Status

()

Core
Internationalization
P2
critical
RESOLVED DUPLICATE of bug 112031
17 years ago
16 years ago

People

(Reporter: Rui Xu, Assigned: Roy Yokoyama)

Tracking

(Depends on: 1 bug, {intl})

Trunk
mozilla1.2beta
x86
Windows 2000
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Build: 2001-09-25

Steps:
1. Pre-create a new directory, name it with the double-byte characters in 
attached files (the characters are entered using Phonetic and Korean (Hangul) 
IME). 
2. Start Profile Manager, click [Create Profile] button, then click [Next] 
button.
3. Change new profile name as the double-byte character in attachment.
4. Click [Choose Folder] button to bring up Browse for Folder dialog.
5. Select the directory created in step 1.

Actual: 
1. The double-byte folder name is garbled.
2. Cannot display double-byte profile name.
3. Click [Finish] button, cannot create new user profile.
(Reporter)

Comment 1

17 years ago
Created attachment 50726 [details]
bug 10573
(Reporter)

Updated

17 years ago
Keywords: intl
QA Contact: andreasb → ruixu
(Reporter)

Updated

17 years ago
Blocks: 101606
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Priority: -- → P2
Target Milestone: --- → mozilla0.9.5
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Updated

17 years ago
Blocks: 104500
(Assignee)

Comment 2

17 years ago
Calling of the Unicode API explicitly didn't help. 
(eg. ::SHBrowseForFolderW() instead of ::SHBrowseForFolder() in 
nsFilePicker.cpp)
Returned folder name is '????' which was converted to the
Windows system locale despite we call WAPIs.  
Moving the milestone to moz 1.0 and we revisit this once
we have compile mozilla as an Unicode app.
Target Milestone: mozilla0.9.6 → mozilla1.0
(Reporter)

Updated

17 years ago
Keywords: nsbeta1

Comment 3

17 years ago
nsbeta1-
 works for default OS locale
Keywords: nsbeta1 → nsbeta1-
(Reporter)

Comment 4

17 years ago
This bug also happened with CHT chars on CHT WinNT/Win2K, and KOR chars on KOR 
WinNT/Win2K.
(Assignee)

Updated

17 years ago
Keywords: mozilla1.0
(Reporter)

Comment 5

17 years ago
There is the same problem with default OS locale, e.g. TC or KO.
->nsbeta1
Keywords: nsbeta1- → nsbeta1

Updated

17 years ago
Summary: Cannot choice some double-byte chars folder name to create user profile → Cannot choose some double-byte chars folder name to create user profile

Comment 6

17 years ago
nsbeta1- . for simplified chinese, if we switch the locale encoding from GB2312
to GB18030 then we probably can fix that problem. I will open another bug for that. 
Keywords: nsbeta1 → nsbeta1-
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla1.0.1

Comment 7

17 years ago
problem on SCH OS can be addressed by bug 126744 and problem with korean
characters on KO os can be addressed by bug 126752

Comment 8

16 years ago
Frank, this bug should have been fixed, is that right?
Assignee: yokoyama → ftang
Status: ASSIGNED → NEW
(Reporter)

Comment 9

16 years ago
It is still reproducible with current RC builds.

Comment 10

16 years ago
roy is addressing this issue
Assignee: ftang → yokoyama
(Assignee)

Updated

16 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0.1 → mozilla1.2beta
(Assignee)

Comment 11

16 years ago
Marking as duplicate and depend on 112031   
Please verify once 112031 gets fixed.

*** This bug has been marked as a duplicate of 112031 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Depends on: 112031
Resolution: --- → DUPLICATE
(Reporter)

Updated

16 years ago
QA Contact: ruixu → ylong
You need to log in before you can comment on or make changes to this bug.