Closed Bug 1016003 Opened 6 years ago Closed 5 years ago

[NFC-Payment-RIL-Vendor-Support] RIL/Baseband need to support APDU exchange via logical channel communcation on Flame.

Categories

(Firefox OS Graveyard :: Vendcom, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

RESOLVED FIXED
blocking-b2g 2.2+
Tracking Status
b2g-v2.2 --- fixed
b2g-master --- fixed

People

(Reporter: ming.yin, Assigned: vchang)

References

Details

(Keywords: feature, Whiteboard: [ucid:NFC15, FT:RIL] [CAF])

Attachments

(2 files)

286.93 KB, application/x-pdf-compressed
Details
334.85 KB, application/x-pdf-compressed
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807
Attached file RIL_Addendum_A.pdf
In order to support UICC card emulation,  two things need to be extended at RIL stack implementation on real device. 

1. Baseband processor shall support a list of AT commands as defined by 3GPP TS 27.007 specification; 

AT Command Extension at baseband: (please find details in attached PDF files with the name of "RIL*.pdf")
AT+CSIM  (Access to SIM)
AT+CCHO  (Open Logical Channel)
AT+CCHC  (Close Logical Channel)
AT+CGLA  (Generic UICC Logical Channel Access)


2. The RIL library shall provide following functionality to support logical channels so that certified Gaia applications can communicate with a specific Java Card Applet installed on the SIM card and identified by its AID.  

- to open a logical channel;
- to exchange APDU command/response;
- to close a logical channel;
Blocks: 979158, 921320
Keywords: feature
OS: All → Gonk (Firefox OS)
Hardware: All → ARM
Whiteboard: [ucid:NFC15, FT:RIL]
Summary: [NFC-Payment-Vendor-Support] RIL/Baseband need to support APDU exchange via logical channel communcation on Flame. → [NFC-Payment-RIL-Vendor-Support] RIL/Baseband need to support APDU exchange via logical channel communcation on Flame.
Hi Anshul,
Are this being worked (or done already) by CAF?
Flags: needinfo?(anshulj)
Whiteboard: [ucid:NFC15, FT:RIL] → [ucid:NFC15, FT:RIL] [CAF]
Wesley, the support for this is added in FFOS 2.2 (moz Central) and the corresponding information is shared with the partners on how to get the code.
Flags: needinfo?(anshulj)
Thanks.
Status: UNCONFIRMED → ASSIGNED
blocking-b2g: --- → backlog
feature-b2g: --- → 2.2+
Ever confirmed: true
Blocks: 879861
Component: RIL → Vendcom
Status: ASSIGNED → NEW
Hi Vincent,
Since we have the vendor image and can run the testing app on top, I wonder if we can RESOLVED FIXED this bug.
Flags: needinfo?(vchang)
Hi Wesley, test app works fine on top of 2.1 tree with Sid's patches. I would like to verify if it also works on our m-c. That will make development and test process easier. I'll update my result later. 

BTW, it seems that QC ril can't work based on m-c because of bug 1072152 and bug 1091307.
Flags: needinfo?(vchang)
Depends on: 1091307
Assigned to Vincent.
Seems the remaining effort is verifying on m-c. Please resolved fixed once that's done.
Assignee: nobody → vchang
AFAIK, we should get new release from partner(T2M, I guess), and the new release will be based on 2.2 branch. Since Ril interface is frozen in 2.2. I think we should be able to use this release on mozilla-central. Wesley, do you know if we can we 2.2 T2M Flame?
Flags: needinfo?(wehuang)
Hi Vincent,

Sorry for late. As T2M is moving focus to L-porting for Flame now, there is no plan for 2.2 release from T2M (this will need addition SOW/contract as well). Also per checking result w/ platform partner there is also no FxOS 2.2 release plan from them. (which is another pre-condition for T2M to make a 2.2 Flame delivery)
Flags: needinfo?(wehuang)
this isn't blocking feature impl. but it will block verification of this new feature.
blocking-b2g: backlog → 2.2+
feature-b2g: 2.2+ → ---
I would like to close this bug because, 
1. This is supported in FFOS 2.1 and the corresponding information is shared with the partners on how to get the code.
2. AOSP supports exchange APDU in Lollipop. We can verify SE APIs on Nexus 5 L because Bug 1113054 is landed.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.