crash with buggy ATI driver when displaying some font.name.* preferences in about:config

RESOLVED DUPLICATE of bug 101055

Status

SeaMonkey
Preferences
--
critical
RESOLVED DUPLICATE of bug 101055
17 years ago
14 years ago

People

(Reporter: djk, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

({crash, stackwanted})

Trunk
x86
Windows 98
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.4+) Gecko/20010925
BuildID:    2001092503

When I scroll the about:config list of preferences, the browser crashes when:
Scrolling down past font.name.cursive.x-baltic (index 162 on my machine) 
OR
Scrolling up past font.name.serif.zh-TW1 (index 230 on my machine)

The crash only occurrs when something attempts to be displayed.
I can scroll quickly past that range, and the crash doesn't happen.


Reproducible: Always
Steps to Reproduce:
1) type about:config in the url bar
2) scroll down (I did it with the mouse)
3) try to display some preference directly below font.name.cursive.x-baltic


Actual Results:  crash

Expected Results:  show the preferences without crashing


No talkback data, because talkback doesn't seem to catch the crash.

Here's two cut and pastes from the crash dialog:

MOZILLA caused a general protection fault
in module GDI.EXE at 0014:00000791.
Registers:
EAX=01010000 CS=05d7 EIP=00000791 EFLGS=00000246
EBX=00000000 SS=60af ESP=0000ab14 EBP=0000ab6a
ECX=00000002 DS=5997 ESI=00000622 FS=0000
EDX=00000000 ES=5456 EDI=00000ca0 GS=06af
Bytes at CS:EIP:
66 ab 8b 46 d2 83 e0 07 88 46 b5 8b 76 c2 8b c6 
Stack dump:
000008b0 00020000 000006af 000000ff 000000d3 00010c00 00080620 00010000 00000001
00000000 00000000 00010c9c 0000083e 06206001 54560000 00000c9a 


MOZILLA caused a general protection fault
in module GDI.EXE at 0014:00000791.
Registers:
EAX=01010000 CS=05d7 EIP=00000791 EFLGS=00000246
EBX=00000000 SS=676f ESP=0000ab14 EBP=0000ab6a
ECX=00000002 DS=5997 ESI=00000622 FS=0000
EDX=00000000 ES=3576 EDI=00000ca0 GS=06af
Bytes at CS:EIP:
66 ab 8b 46 d2 83 e0 07 88 46 b5 8b 76 c2 8b c6 
Stack dump:
000008b0 00030000 000006af 000000ff 000000d3 00010c00 00080620 00010000 00000001
00000000 00000000 00010c9c 0000083e 06206001 35760000 00000c9a
could this be related to bug 101510, or is it completely different? methinks the
latter...
Keywords: crash
btw, how are you scrolling? by dragging the scrollbar widget [holding down mouse
button and dragging], by using the arrow keys, by using the spacebar/pgDn/pgUp?
(Reporter)

Comment 3

17 years ago
Using build 2001092803 with Modern, I cannot reproduce bug 101510, yet can still
reproduce this one.
Too bad they weren't the same bug.

Mozilla crashes if I scroll any way:
1) grab scrollbar thumb/drag
2) click scrollbar arrows
2) click scrollbar region for pgup/pgdn
4) keyboard pgup/pgdn
5) keyboard arrows

I created a new profile (uses Classic).  It crashs also.

Comment 4

17 years ago
-> chipc
Assignee: sgehani → chipc
Reporter: Please try a talkback-enabled build:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip

Then, if you get a crash, please post the Talkback ID here.
(Reporter)

Comment 6

17 years ago
Alex:  I'm using the build /pub/mozilla/nightly/2001-09-30-11-trunk
/mozilla-win32-talkback.zip


I reproduce the crash, but talkback does not appear.  If there's something I can
do to force it to appear, please let me know.

Updated

17 years ago
Keywords: stackwanted
(Reporter)

Comment 7

17 years ago
I managed to figure out how to use Dr. Watson.

I'll attach the (text) log of the crash; hope it helps.
(Reporter)

Comment 8

17 years ago
Created attachment 51863 [details]
Dr. Watson text log
djk: As the error cited is "gdi.exe", my hunch is that your crash is video-card
related, as opposed to Mozilla related (especially since Talkback isn't being
triggered).

Try upgrading to the very latest version of your video card driver.

If that doesn't help, try going to Display Properties ->
Settings -> Advanced -> Troubleshooting. Then, turn down "Hardware acceleration"
a notch or two. (You may need to reboot after changing that setting, I'm not sure)

Comment 10

17 years ago
djk: Running with the previous comment's hunch, could you let us know what video
card and version of the driver you're using??  Perhaps someone out there with
your configuration can reproduce this.
(Reporter)

Comment 11

17 years ago
I'm using an ATI RageII+ (Mach64) with 2MB RAM.

Driver version is 4.02, according to the display properties.

I am downloading new drivers from ATI right now.
(Reporter)

Comment 12

17 years ago
Still crashes using driver version 5.21-C9N-WEB. :-(
Keywords: qawanted
still cannot repro this on my winnt box, adding qawanted.

Updated

17 years ago
Blocks: 104992

Comment 14

17 years ago
***spam***

This bug has been marked as a dependency of bug 104992, which is a tracking bug
for a possible ATI videocard issue.
No longer blocks: 104992

Updated

17 years ago
Blocks: 104992
(Reporter)

Comment 15

17 years ago
I changed the video card to a ATI Mach64 Rage Pro with default Win98 drivers,
and still got the crash.

I turned down the "Hardware acceleration" by 1 notch and can no longer reproduce
the crash.

Updated

17 years ago
No longer blocks: 104992
Unable to reproduce using steps given in testcase.  

Mozilla/5.0 (Windows; U; Win98; en-US; rv:0.9.5+) Gecko/20011019

Updated

17 years ago
Blocks: 104992

Comment 17

17 years ago
Used an ATI box, crash. Swap VC's on a test boxt, then it's WFM. Marking new,
and saying that it has to be ATI related. Good job linking it to the meta bug,
saves me work finding it. :)
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 18

17 years ago
I can re-reproduce it with build 2001103103. :-(

"Hardware acceleration" is in the same setting as when I said I couldn't repro
the crash (on 10/16).

I know that at least color-coding and sorting have been added to abouf:config
since then.

I'll keep testing and trying to find ways around this bug.
taking about:config bugs from chipc.
Assignee: chipc → sspitzer
Summary: crash when displaying some font.name.* preferences → crash when displaying some font.name.* preferences in about:config

Comment 20

16 years ago
Unable to reproduce on Win2000 with CVS build(June 26'2002).
(Reporter)

Comment 21

16 years ago
I turned down my Windows "Hardware acceleration" to "butt-ugly-unsmooth
scrolling" (2nd notch from the left) and couldn't crash.

I'm positive there's an ATI driver issue, because that setting also cures a
rendering defect with scaled images in Mozilla.
(Reporter)

Comment 22

16 years ago
I upgraded my video driver with the file wme-j5-30-1-b02.exe from ATI's website.

I then turned the Windows "Hardware acceleration" back to the maximum, and still
got the crash.  The scrolling on normal pages was smooth again, however.

I kept the new driver, and turned the Windows "Hardware acceleration" back down
to the second notch from the left.

No crashes, and scrolling is still smooth!  Woohoo!

BTW, the following lines were added by Windows to the [display] section of my
system.ini file:
Mmio=0
SwCursor=1

Comment 23

16 years ago
djk, do you now get a Talkback window when crashing (Netscape Feedback Agent) ? 
If so, please post Talkback ID for this 
crash "mozilla/bin/components/talkback.exe"

Comment 24

15 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7b) Gecko/20040316

Not seeing this crash on XP with ATI Radeon 9600 Pro and the following driver
info from dxdiag.


---------------
Display Devices
---------------
        Card name: RADEON 9600 SERIES 
     Manufacturer: ATI Technologies Inc.
        Chip type: RADEON 9600 Series AGP (0x4150)
         DAC type: Internal DAC(500MHz)
       Device Key: Enum\PCI\VEN_1002&DEV_4150&SUBSYS_00021002&REV_00
   Display Memory: 128.0 MB
     Current Mode: 1024 x 768 (32 bit) (75Hz)
          Monitor: NEC MultiSync 70
  Monitor Max Res: 1280,1024
      Driver Name: ati2dvag.dll
   Driver Version: 6.14.0010.6430 (English)
      DDI Version: 9 (or higher)
Driver Attributes: Final Retail
 Driver Date/Size: 2/24/2004 21:47:26, 398336 bytes
      WHQL Logo'd: Yes
  WHQL Date Stamp: n/a
              VDD: n/a
         Mini VDD: ati2mtag.sys
    Mini VDD Date: 2/24/2004 21:47:04, 679424 bytes
Device Identifier: {D7B71EE2-0210-11CF-AC6A-0820A1C2CB35}
        Vendor ID: 0x1002
        Device ID: 0x4150
        SubSys ID: 0x00021002
      Revision ID: 0x0000
      Revision ID: 0x0000
      Video Accel: ModeMPEG2_C ModeMPEG2_D 
 Deinterlace Caps: {07654321-3046-4FF0-AECC-D58CB5F035FC}:
Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,2)
Caps=DeinterlaceTech_PixelAdaptive 
                   {6E8329FF-B642-418B-BCF0-BCB6591E255F}:
Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,1)
Caps=DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}:
Format(In/Out)=(YUY2,YUY2) Frames(Prev/Fwd/Back)=(0,0,0)
Caps=DeinterlaceTech_BOBVerticalStretch 
                   {07654321-3046-4FF0-AECC-D58CB5F035FC}:
Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,2)
Caps=DeinterlaceTech_PixelAdaptive 
                   {6E8329FF-B642-418B-BCF0-BCB6591E255F}:
Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,1)
Caps=DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}:
Format(In/Out)=(UYVY,UYVY) Frames(Prev/Fwd/Back)=(0,0,0)
Caps=DeinterlaceTech_BOBVerticalStretch 
                   {07654321-3046-4FF0-AECC-D58CB5F035FC}:
Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,2)
Caps=DeinterlaceTech_PixelAdaptive 
                   {6E8329FF-B642-418B-BCF0-BCB6591E255F}:
Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,1)
Caps=DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}:
Format(In/Out)=(YV12,0x32315659) Frames(Prev/Fwd/Back)=(0,0,0)
Caps=DeinterlaceTech_BOBVerticalStretch 
                   {07654321-3046-4FF0-AECC-D58CB5F035FC}:
Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,2)
Caps=DeinterlaceTech_PixelAdaptive 
                   {6E8329FF-B642-418B-BCF0-BCB6591E255F}:
Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,1)
Caps=DeinterlaceTech_PixelAdaptive 
                   {335AA36E-7884-43A4-9C91-7F87FAF3E37E}:
Format(In/Out)=(NV12,0x3231564e) Frames(Prev/Fwd/Back)=(0,0,0)
Caps=DeinterlaceTech_BOBVerticalStretch 
         Registry: OK
     DDraw Status: Enabled
       D3D Status: Enabled
       AGP Status: Enabled
DDraw Test Result: Not run
 D3D7 Test Result: Not run
 D3D8 Test Result: Not run
 D3D9 Test Result: Not run

Comment 25

15 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7b) Gecko/20040316
though  i must add this bug was reported on Windows 98 and the 2 cases here that
are WFm are both NT based :)
(Reporter)

Comment 26

15 years ago
This bug blocks bug 104992, which is specifically about older ATI cards, and
mostly about Windows 98 (as the comments in that bug indicate).  I would think
that the newer Radeon series on newer Windows OS's would not have the same issues.

As my comment 22 indicates, I have found a WORKAROUND for this bug; now the only
problem is a 'stutter' when showing the same font.name* prefs that used to
crash.  FWIW, I think I remember seeing the same 'stutter' on another computer
with XP and a mobile Radeon, but no crash.
Product: Browser → Seamonkey

Comment 27

14 years ago
Removing qawanted as it's pretty ATI driver is at fault here.
So if this is a driver bug, why is this bug report still open?
Keywords: qawanted
Whiteboard: INVALID

Comment 28

14 years ago
actually, this is a dupe

*** This bug has been marked as a duplicate of 101055 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: crash when displaying some font.name.* preferences in about:config → crash with buggy ATI driver when displaying some font.name.* preferences in about:config
Whiteboard: INVALID

Comment 29

14 years ago
How can this bug (OS=WIN98) possibly be a dupe of 101055 (OS=MAC)?

It appears to be driver related, so probably should be WONTFIX, but definitely
not DUPE.

Comment 30

14 years ago
well, the release notes refer to bug 101055 (in the Windows section no less) and
some of the comments in that bug refer to problems with windows.
http://www.mozilla.org/releases/mozilla1.8b1/installation.html#win

Anyway, if it's not a dupe it's definitely INVALID.  anything but open.
You need to log in before you can comment on or make changes to this bug.