Last Comment Bug 101055 - Scrolling vertically crashes system w/ ATI video card
: Scrolling vertically crashes system w/ ATI video card
Status: RESOLVED WONTFIX
: crash, dataloss, relnote
Product: SeaMonkey
Classification: Client Software
Component: General (show other bugs)
: Trunk
: PowerPC Mac System 9.x
: P1 critical with 11 votes (vote)
: Future
Assigned To: dcone (gone)
: Chris Petersen
Mentors:
: 101749 116129 163881 165081 168625 (view as bug list)
Depends on:
Blocks: 120893 163881 165081
  Show dependency treegraph
 
Reported: 2001-09-21 16:50 PDT by John F. Mayer
Modified: 2011-04-11 20:57 PDT (History)
36 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
MacsBug log for the crash (build 2002020713) (35.83 KB, text/plain)
2002-02-27 14:27 PST, Simon Fraser
no flags Details
Quality Feedback Agent Details for Vertical Scrolling bug on Mac (243.52 KB, text/html)
2002-11-29 05:28 PST, Stephan Heffner
no flags Details

Description John F. Mayer 2001-09-21 16:50:08 PDT
Scrolling vertically, whether with scroll bar or mouse wheel, crashes entire system. Inevitable if use Mozilla for extended period. Had same problem with previous build and with Netscape 6.1; do not have it with other browsers (I am using Opera to post this). 

Necessity to reboot discourages repeated efforts to duplicate this bug.
Comment 1 Greg K. 2001-09-21 18:34:22 PDT
Reporter, provide the Build ID of the Mozilla build you're using to reproduce
this bug. Also, attempt to reproduce it using Mozilla 0.9.4 with TalkBalk
enabled to produce a crash report, and provide the TalkBack incident ID(s) hereon.

Thank you.
Comment 2 John F. Mayer 2001-09-22 13:41:38 PDT
>------- Additional Comments From greg@tcp.com 2001-09-21 18:34 -------
>Reporter, provide the Build ID of the Mozilla build you're using to reproduce
>this bug. Also, attempt to reproduce it using Mozilla 0.9.4 with TalkBalk
>enabled to produce a crash report, and provide the TalkBack incident ID(s) >hereon.

Build is 2001091311 (Would have sworn I typed that into one of these fields). Same bug in previous build, # of which I don't recall. Netscape 6.1 also causes system crash when scrolling, but not so reliably (you'll note, no doubt, that I am posting this via Opera). It is 0.9.4. with TalkBack enabled. Since the bug crashes my entire system, however, requiring a reboot, I doubt the TalkBack feature will be of much help. A perhaps related bug just manifested itself when I attempted to modify text I had typed into this field; froze requiring force quit and relaunch (but not reboot).

>Thank you.

You're welcome.


Comment 3 Greg K. 2001-09-28 23:08:33 PDT
Reporter, have you tried reproducing this after booting using the "Mac OS 9 (All)" 
extension set?

Are you running any special mouse driver software that might be a factor in this?
Comment 4 Greg K. 2001-10-13 11:37:21 PDT
Reporter, can you still reproduce this using 0.9.5?
Comment 5 John F. Mayer 2001-10-14 11:46:36 PDT
I'll download it soonest, probably tonight. Don't have highspeed out here in the 
sticks, so will take awhile.
Comment 6 John F. Mayer 2001-10-17 22:27:58 PDT
Well, I seem to lose ground with every build. I suppose this is really a 
separate bug, but I'll add it here; I couldn't even download 9.5. Three tries on 
my dialup modem seemed, puzzlingly, to produce no 9.5 installer, so I set the 
radio button at the download site (accessed from the bugzilla home page) to save 
file to disk instead of opening with Stuffit. This time the download took about 
an hour and a half instead of the approx. half hour by the previous method 
(about same download speed), and the file produced was, according to Get Info, 
9.4. Thinking it might really be 9.5 I tried to install anyhow and got a system 
freeze (it's possible I may have overlooked a running app). Since it appeared to 
be the wrong file anyway, I haven't tried again. [Posted with Netscape 4.7]
Comment 7 John F. Mayer 2001-10-24 11:24:55 PDT
Comments From greg@tcp.com  2001-10-13 11:37 -------
> Reporter, can you still reproduce this using 0.9.5?

[Apparently my downloads were okay, but checking "Get Info" on the fresh 
installer indicates incorrectly that it is the 0.9.4 installer. After one 
attempted installation crashed my system I didn't try again until today, after 
going to the ftp index and still getting the 0.9.4 ID on the newly dl'ed file.]

Keeping my fingers crossed, but so far, so good on the scrolling problem with 
the 0.9.5 build.
Comment 8 Greg K. 2001-10-24 18:06:22 PDT
John, although the version on the Installer is wrong, you did, in fact, download 0.9.5.

For everyone's reference, the bug on that issue is Bug 106566.
Comment 9 Greg K. 2001-10-24 18:08:07 PDT
Also, John, if you continue to experience crashes, since TalkBack isn't applicable it will be 
most helpful for you to install MacsBug and collect a stack trace.
Comment 10 Gervase Markham [:gerv] 2001-11-10 09:54:39 PST
Reporter says WORKSFORME.

Gerv
Comment 11 John F. Mayer 2001-11-10 16:09:28 PST
Still Crashesforme. Upgraded to 0.9.5; seemed to crash less often, but have 
discontinued use as can't afford the reboot time. Waiting for the next milestone 
build. The version of Macsbug I have is probably obsolete; I'll have to find a 
recent version. What's a stack trace?
Comment 12 Asa Dotzler [:asa] 2001-11-16 10:41:24 PST
John, when macsbug pops up after a crash please type this:

log 101055 <enter>
sc <enter>
log <enter>

that will log the stack trace to a file (probably on your desktop). please
attach that log to this bug by clicking on this link
http://bugzilla.mozilla.org/attachment.cgi?bugid=101055&action=enter

thanks.
Comment 13 Greg K. 2001-11-24 12:51:16 PST
John, please address Asa's Additional Comment #12 on this bug. Also, please retest using 
0.9.6 now that it's out.
Comment 14 John F. Mayer 2001-11-25 13:24:02 PST
I guess I need further instruction on Macsbug; I tried an older version a few 
years ago (I think I was looking for a way to type my way out of crashes without 
rebooting), and I recall I'm supposed to get a command-line screen when a crash 
occurs. Remember, I'm an artist, with practically no knowledge of coding. 

The version I'm using is 6.6f2c1, whatever that means. I placed Macbugs loose in 
the system folder. I looked in vain for the Macsbug Preferences folder, but, now 
as I write this, lo and behold, it has appeared. Maybe because I tried to run 
the MacsBugApp I found in the new version of MacsBug. Still can't find a 
debugger prefs file, though; is that something I need?

Anyhow, running 0.9.5 I just crashed my system yet again; no Macsbug interface 
appeared. It doesn't usually crash immediately when I scroll, only after I have 
visited a few different links; that may, however, have something to do with the 
length of the visited page, rather than an accumulation of errors. 

One clue: Mozilla hints it is about to crash me by leaving a trail of hand 
droppings down the page. These are not the usual "Click Here" hands, but, 
rather, look like the Hand of Mickey Mouse, with three fingers and three lines.
I seem to recall such a cursor associated with a third party theme I disabled 
some time back...

<INTERRUPTION> An "Aha" moment! I have been using the "Glassworks Granite" theme 
so long I thought it was the default platinum theme. Could that have been the 
source of my problem? I just disabled it for real, and will experiment again. 
Er... heh, heh...    <:oD   </INTERRUPTION>

...but I now see it only in Mozilla and Netscape 6.x.

I will await further instruction on MacsBug (sorry, I'm doing my untutored best) 
before experimenting with 0.9.6. Thanks.
Comment 15 John F. Mayer 2001-11-25 15:03:01 PST
Macsbug follow-up (sorry, I know this isn't the place for a Macsbug tutorial but 
perhaps just a couple of details will suffice):

Okay, Macsbug is working now, but says it needs a pathname to place the log (no 
log seems to be showing up without one, either with the "log 101055" command or 
with the "StdLog" command). The names of either my internal or firewire drives 
don't work. So, what do I use to tell MB where to put the log?

Also, once I'm done with MB, how do I get beyond it, back to my regular Mac 
interface. "Esc" toggles back and forth between the Macsbug console and the 
frozen startup screen. Thanks.
Comment 16 timeless 2001-11-25 22:45:33 PST
stdlog should dump the file onto the desktop, i have one called 'StdLog' on my 
7100. hrm i need to grab a newer mozilla for the mac :)
Comment 17 Greg K. 2001-11-26 11:00:01 PST
Revising Summary and reducing Severity.
Comment 18 Asa Dotzler [:asa] 2001-11-26 17:11:03 PST
John, thanks for your persistence. I'm not sure why the log isn't showing up on
your desktop. "es" will exit the macsbug console and return you to your desktop.
That should make testing this a little less painful. when you get the macsbug
screen and type "sc" do you see a log scroll up the console? the bottom of that
log should be visible. If you can get the last few lines of the log into this
bug that might be helpful. You can find out more on macsbug by reading
http://developer.apple.com/tools/debuggers/MacsBug/Documentation/MacsBugRef_6.2.pdf
but unfortunately I'm no expert either. I'll remove and set it up again on my
mac as soon as I get the machine working again to see if I can get a better idea
about the problem logging. Thanks again for stickin' with it. 
Comment 19 Fabian Guisset 2001-12-07 05:15:39 PST
Oh an btw, it's _very_ possible that an old theme is causing problems. You
should try reverting to classic or modern which are always up to date and less
likely to cause crashes/problems. Thanks :-)
Comment 20 Asa Dotzler [:asa] 2001-12-26 13:15:42 PST
->apps
Comment 21 sairuh (rarely reading bugmail) 2001-12-30 19:15:43 PST
->bryner, but punt as needed...
Comment 22 Gabe da Silveira 2002-02-08 11:25:53 PST
I've had this problem on 0.9.6, 0.9.7, and 0.9.8.  If anything it seems to be 
worse in 0.9.8.  I am running OS 9.1 on a Blue&White G3-300.   I have 
reported 2 talkbalks already.  

I will perform some tests to see if it happens in all 4 scrolling methods 
(i.e. dragging scollbar, clicking scrollbar, clicking arrows, and using arrow 
keys).   

An interesting side effect of this bug is that you can invariably force-quit, 
but the system will lock up again in 1-3 seconds.  Talkbalk dialogs were 
only generated when I restarted, not force quit.

The only major non-standard component that I have installed is the 
Netware client.  Considering that force quitting temporarily alleviates the 
bug (only for a second or two) but then the exact same crash happens in 
the finder, it would make sense that Mozilla is sending some system 
message that puts the system in a state that is incompatible with some 
3rd party element installed in my system.  I'm not a systems programmer, 
so any insight any of you hackers have might help me nail this bug down.
Comment 23 John F. Mayer 2002-02-08 14:56:03 PST
Sorry I haven't added to my earlier postings; I installed Macsbug and
laboriously copied down the resulting code (meaningless to me) by hand, since
Macsbug indicated it could not write the log to a file due to the lack of a
filepath name, or some such. Alas, I lost my laboriously hand-written notes
before I could laboriously type them into this field, but I don't think they
would have been very helpful; I think they just informed me that the log could
not be written to a file. 

However, I must report that, though I had the same problem with Netscapes 6 and
6.1, it appears to have gone away in 6.2; perhaps that is suggestive to those
who understand such things. 6.2 has performed, in fact, flawlessly so far with
the sole exception that the auto-form-fill dialogue crashed me a few times when
I clicked the "Do Not Save This Form Information" button. 

All of which poses the question: does the current Netscape supersede earlier
Mozillas? That is, is there any point in continuing to pursue this particular
bug if the latest Netscape no longer suffers from it? (If that's a stupid
question please accept my apology in advance.)
Comment 24 Brian Ryner (not reading) 2002-02-08 15:35:42 PST
-> pink
Comment 25 Mike Pinkerton (not reading bugmail) 2002-02-11 07:05:15 PST
without a stack trace, i can't help you at all. please provide a macsbug log.
Comment 26 John Hansen 2002-02-21 15:06:13 PST
Just noticed this bug while browsing Google Groups. Highly annoying; it 
crashed after I used it for only 5 minutes. The release I'm using is 0.9.8 
and the build ID is 2002020405, on Mac OS 9.1.
Comment 27 Gabe da Silveira 2002-02-22 11:26:08 PST
Okay, i will try to provide a Macsbug stack trace for this, but can someone 
provide a link to a tutorial about how to go about installing and doing a 
stack trace using Macsbug?  I really want to help with this, but I just don't 
have the time to go researching this stuff right now.

Also,  Crazy9000, do you run the Novell Netware client or run the Kodak 
Colorsync program that comes with Photoshop 6?  I am running on a very 
clean install of OS 9.1 with those 2 extensions being the only 
non-standard ones I can think of.  I suppose it's possible that this is 
actually caused by a more general contingency that a variety of extensions 
might create (I also have a similar problem with opening menus in many 
Microsoft applications such as Outlook and Word).
Comment 28 Mike Pinkerton (not reading bugmail) 2002-02-22 11:32:17 PST
this sounds a lot like another bug that is in netlib limbo (the crash is in the
image cache).
Comment 29 John F. Mayer 2002-02-22 12:13:19 PST
>Also,  Crazy9000, do you run the Novell Netware client or run the Kodak 
>Colorsync program that comes with Photoshop 6?  I am running on a very 
>clean install of OS 9.1 with those 2 extensions being the only 
>non-standard ones I can think of.

I run Photoshop from time to time, but I have neither of those extensions
installed. I do have several Kodak Precision extensions installed, however. 
Comment 30 Simon Fraser 2002-02-22 13:05:30 PST
MacsBug info on <http://www.smfr.org/macsbug.html>
Comment 31 John Hansen 2002-02-22 22:09:00 PST
Gabe,
Since the machine is a college network machine (I use Windows & Linux at home),
I'm not particularly sure what it's running. It may or may not be running
NetWare; I'll have to check next time I can use it. But the computer does not
have Photoshop.

As for it crashing, it seems to do it at random. Internet Explorer was also
installed on the system, and as much as I might dislike it it's perfectly
stable. No scrolling errors with it whatsoever.

Netscape 4 is also installed on the system. Should I try using it next time?
Comment 32 Gabe da Silveira 2002-02-23 12:39:02 PST
Heheh, don't talk about using Netscape 4 here.  On the Mac if you can't 
use Mozilla then use IE 5, because it's pretty much the 2nd best browser 
(of any platform) out there.  Netscape 4 just makes me wanna bang my 
head against the wall (from a design perspective).

Okay, I am ready to do a little testing and provide a stack trace, but the 
question is:

Is just the stdlog enough?  Or do I need to do some combination of the 
'log' command followed by 'sc' or 'sc7'?
Comment 33 Simon Fraser 2002-02-25 11:41:53 PST
stdlog does both sc and sc7 for you. My feeling is that when this crashes, it 
will just lock up the machine, and MacsBug won't be invoked. But you might get 
lucky.
Comment 34 Simon Fraser 2002-02-27 14:25:43 PST
Giving to dcone to replace bug 116129
Comment 35 Simon Fraser 2002-02-27 14:26:07 PST
*** Bug 116129 has been marked as a duplicate of this bug. ***
Comment 36 Simon Fraser 2002-02-27 14:27:01 PST
Created attachment 71754 [details]
MacsBug log for the crash (build 2002020713)
Comment 37 Gabe da Silveira 2002-02-28 08:56:07 PST
Hopefully I will have a macsbug log for you soon.  (un?)fortunately the 
crash seems to have disappeared.  I used Mozilla for about 2 hours 
without a crash.  Wouldn't you figure as soon as I want it to crash it 
doesnt....
Comment 38 Simon Fraser 2002-03-01 16:01:29 PST
This just happened to me again, in the middle of scrolling a long email message
that I was composing (and thus lost). It's a very serious bug.

I submitted a talkback report, incident TB3534081Z, which is useless.

While in MacsBug, I found out a few interesting things:

 07BFAAE0    PPC  FFD1B754  CopyBits+00034
  07BFAAA0    PPC  3F8AA364  NQDCopyBits+00098
  07BFA970    PPC  3F8AA23C  NQDStdBits+0073C
  07BFA910    PPC  00CB466C                         <-- address is in 'Akira'
fragment
  07BFA810    PPC  3F8A9E84  NQDStdBits+00384
  07BFA650    PPC  3F8AA28C  NQDStdBits+0078C
  07BFA5F0    PPC  3F8A92D0  NQDCalcMask+00A44
  07BFA5B0    PPC  3F8A8BB4  NQDCalcMask+00328
  07BFA560    PPC  3F8BF9AC  NQDStretch+005E8
  07BF9F60    PPC  3F8BFD78  NQDStretch+009B4
  07BF9F10    PPC  00BC1904  
  07BF9EA0    PPC  3F5AB548  ARMQSSubmitListImmediate+00174 <- in ATI driver code
  07BF9E30    PPC  3F5ABF74  ARMQSSynchronize+00278         <- in ATI driver code

Comment 39 Kevin McCluskey (gone) 2002-03-19 15:26:17 PST
nsbeta1-. 

peterson: Can you try to get a reproducible test case or series of steps for
this? Thanks. Remove the - if you can get one.
Comment 40 Mike Pinkerton (not reading bugmail) 2002-03-20 07:17:42 PST
i'm speaking for simon here, but i think this can't be nsbeta1-. It's a crash 
that I watch simon hit several times a day on OS9.

requesting re-triage.
Comment 41 dcone (gone) 2002-03-20 07:42:42 PST
Is this the carbon build.. or the OS9 build.. I just need to make sure. 
Comment 42 Gabe da Silveira 2002-03-20 08:14:02 PST
This is the OS 9 build I'm pretty sure.  Also, I don't think that a list of steps 
to reproduce this bug is possible.  The reasons?

It happens randomly.  There is no specific page or set of pages that 
trigger it.  There is no timeframe, it can happen within 30 seconds of 
starting Mozilla or 3 hours later.  It has a delayed crashing effect (ie first 
the program stops responding, then within a few seconds the mouse 
locks up).  You can force quit, but all that does is reset the delay, you get a 
few seconds of computer operation before the same crash happens 
again in whatever application is open after which point force quitting no 
longer works.

Considering that more people aren't having this problem, I have to 
assume it's some combination of specific hardware and software issues.  
I would suggest looking at the talkback builds and trying to compile a list 
of extensions and hardware similarities to test (although my limited 
testing of turning off extensions did not solve the problem).  Another 
interesting point is that a similar bug occurs in Outlook 2001 and MS 
Word 2001, except that it happens when a menu is opened, but it has the 
same delayed effect mouse lockup effect.  

It's possible that the bug isn't even with Mozilla, but some poorly behaved 
3rd party extension or something.  If that is the case, it would be nice if it 
could at least be identified so it could go in the release notes.  At any rate, 
I think it's a serious mistake to target this bug for a future release.  This 
bug renders Mozilla dangerous where it occurs.  I would like to be able to 
recommend Mozilla 1.0 to everyone at my work, but a data-destroying 
crash like this is too serious a liability.  

Is it possible to get some talkbalk builds together for this so we can 
compare hardware and software configs?  I am running a B&W G3, 
perhaps that is a common thread?
Comment 43 Mike Pinkerton (not reading bugmail) 2002-03-20 08:50:40 PST
i think it's the regular os9 build on os9
Comment 44 Chris Petersen 2002-03-20 10:50:44 PST
I will try to reproduce on Mac OS 9.1 with the March 19th build (2002-03-19-08).
Any suggestions on what steps I could try ? 
Comment 45 Gabe da Silveira 2002-03-20 10:55:33 PST
It's happened to me on mozilla.org, slashdot, and a variety of lesser 
known pages of a variety of lengths.  All I can suggest is a lot of scrolling, 
dragging the placeholder seems to have caused more crashes for me, 
but I've had it crash with every scrolling method.
Comment 46 Simon Fraser 2002-03-20 11:02:19 PST
I have a feeling this might be an interation with the ATI drivers. I'm running
on a B&W G3, ATI Rage128 card (16MB), Monitor in 1024x768 in millions.
Gabe/John: what are your hardware specs?
Comment 47 Gabe da Silveira 2002-03-20 11:11:32 PST
Yes.  My specs:

B&W G3-300
128 RAM
ATI Rage128 w/ 16MB VRAM (Card ROM # 113-57401-116, Card Revision 
0, from Apple System Profiler).
1280x1024 Millions of colors

The question is, how can we test this theory?  Can't very well disable the 
graphics card.  I'm going to see if there is a driver update.

BTW, here are the versions of my ATI extensions:

ATI 3d Accelerator 5.0.3
ATI Driver Update 1.8.2
ATI MPP Manager 1.2
ATI Radeon 3d Accelerator 6.1.8
ATI Rage 128 3D Accelerator 6.1.6
ATI Resource Manager 2.8.7
ATI Video Accelerator 4.7.4
Comment 48 Simon Fraser 2002-03-20 14:15:35 PST
peterv sees this too.
Comment 49 Simon Fraser 2002-03-20 14:50:14 PST
This has happened twice so far today; once while on the phone to dcone, and once
when I had a bugzilla entry page with lots of text I had typed. It's serious
data loss. If I didn't have other machines, I would not use NS6 because of this bug.
Comment 50 Chris Petersen 2002-03-20 19:17:30 PST
I can't reproduce this issue with either of these two machines:

iMac (Bondi Blue 233mhz) whichs use a ATI Rage IIc 
Power Mac (Beige G3 266mhz) which uses a ATI RAGE Pro

Could this be related to drivers for the ATIRage128 ?

I think we might have access to a original G4 tower that uses card. Need to check..
Comment 51 Gabe da Silveira 2002-03-21 08:39:01 PST
I have more B&W G3s to test on, but mine is the only one that has had a 
fresh install of OS 9 in the last year.  The rest of them are either still on 8.x 
or have been upgraded, but they are all very quirky machines and don't 
provide a good baseline for testing.

Does anyone know what will happen if I disable the ATI drivers?  I looked 
on the ATI website, and they don't even acknowledge that the RAGE 128 is 
supported on the Mac!  If the display would still work without the ATI 
drivers, then that would be my next test.  Unfortunately I don't have enough 
time at work to give this the attention it deserves, and Mozilla works 
fantabulously on my G4 at home.  Thoughts on disabling the drivers?
Comment 52 Chris Petersen 2002-03-21 10:44:40 PST
I plan to do some testing on machine below which uses a 16 meg ATI Rage128Pro card

Power Mac G4 500mhz (AGP graphics), Mac OS 9.2.1 , 256 RAM, Millions of Colors,
1152 X 870.

Here's what system proflier tells me about which ATI extensions are installed
and enabled:

ATI 3D Accelerator                  5.0.4    
ATI Driver Update                   1.9.5    
ATI MPP Manager                     1.2     
ATI Radeon 3D Accelerator           6.2.6    
ATI Rage 128 3D Accelerator        6.2.5    
ATI Resource Manager                2.9.5    
ATI Video Accelerator               4.8.2    
Comment 53 Simon Fraser 2002-03-21 11:36:35 PST
I have (on a machine that crashes)

File Name                       &#63743; •  Version File size  Last modification date
ATI 3D Accelerator                •  5.0.3    904K       19/10/00 at 12:00:00 pm
ATI Driver Update                 •  1.6.8    1.39 MB    17/10/00 at 12:00:00 pm
ATI MPP Manager                   •  1.2      60K        31/5/00 at 12:00:00 pm
ATI Radeon 3D Accelerator         •  6.1.3    496K       6/10/00 at 12:00:00 pm
ATI Rage 128 3D Accelerator       •  5.9.8    596K       6/10/00 at 12:00:00 pm
ATI Resource Manager              •  2.7.3    244K       20/9/00 at 12:00:00 pm
ATI Video Accelerator             •  4.6.5    160K       6/10/00 at 12:00:00 pm
Comment 54 Peter Van der Beken [:peterv] - away till Aug 1st 2002-03-21 11:58:31 PST
This is a very annoying bug, having to hardboot the machine because I scroll is
painful!

B&W G3-400, 256 RAM, ATI Rage128 (Card ROM # 113-57401-116, Card Revision 0)

ATI 3d Accelerator          5.0.4  3/28/2001
ATI Driver Update           2.0.4  11/9/2001
ATI Graphics Accelerator    5.4.9  9/25/2001
ATI MPP Manager             1.2    5/31/2001
ATI Radeon 3d Accelerator   6.3.5  11/9/2001
ATI Rage 128 3D Accelerator 6.3.5  11/9/2001
ATI Resource Manager        3.0.5  11/9/2001
ATI Video Accelerator       4.8.5  9/25/2001
Comment 55 Gabe da Silveira 2002-03-21 12:09:45 PST
Okay guys, I installed Moz .9.9 and it crashed 4 times in a row within 5 or 6
pages of starting up.  Now I have been using it for over an hour and dozens of
pages with no freezes.  The change I made?

I changed from millions of colors to thousands.  

Read:
http://docs.info.apple.com/article.html?artnum=60395

I was tipped off by the alleged bug fix involving millions of colors on high-res
monitors (I have a high-res Sony 19").  My version numbers are well above the
ones that this update lists, which indicates that maybe the bug was
re-introduced or maybe it was just never fixed adequately.

Anyway, you guys should all try thousands of colors and see if that fixes it.  I
will keep using it and will report back either in a few days or if and when it
crashes.
Comment 56 Gabe da Silveira 2002-03-21 12:57:24 PST
I am as of yet unable to replicate this bug in OS 8.6.  Has anyone experience it
in 8.6?

Also, switching to millions of colors AFTER Mozilla had been started in
Thousands did not allow me to crash it either.  Although I quickly got it crash
after quitting and restarting it in Millions.    This might also indicate that
switching  to thousands after having started Mozilla in millions will not
prevent crashes.  If so, the probelm would also appear to be 'initialized' when
Mozilla starts.

Although this appears to be a driver issue, since it doesn't happen in most
applications it may be preventable on Mozilla's end somehow.  I will see if my
fix also fixes my crashes in Outlook and Word 2001 (although that crash is
related to opening menus).  
Comment 57 David Boroditsky 2002-03-21 14:10:20 PST
Once you launch the program in Thousands of colours, switching to Millions has
no affect on the display of images in the program.

To see this in a a more pronounced way, swithch to 256 colours, launch Mozilla,
view an image in which the 256 colour dithering is obvious. Now switch to
Thousands of colours. Open a new window and display the same image. Mozilla
still displays the image in 256 colours.

I'm using a B&W G3 350 with the aforementioned ATI 128 card, and have been
bitten by this bug under Millions but not yet with Thousands of colours.

David
Comment 58 Simon Fraser 2002-03-21 14:21:48 PST
david: that's a known issue, covered by other bugs. Please don't get off track
in the bug.
Comment 59 Chris Petersen 2002-03-21 14:40:22 PST
I haven't experienced any crashes on the PowerMac G4 yet (which uses the AGP
version of the card) which I have been using for over two hours. This might just
be an issue on older G3 B&W machines.
Comment 60 John F. Mayer 2002-03-24 17:00:54 PST
sfraser@netscape.com:
> I'm running on a B&W G3, ATI Rage128 card (16MB), Monitor in 1024x768 in 
> millions. Gabe/John: what are your hardware specs?

Same hardware; however, resolution varies depending on current requirements.
Comment 61 John F. Mayer 2002-03-24 17:11:28 PST
sfraser@netscape.com:
> ...I would not use NS6 because of this bug.

For whatever it suggests, I have not had this scrolling bug with Netscape 6.2,
which I am now using regularly (Thank God I never have to open IE again), still
with the 350 B&W G3 and ATI graphics card.

[NS 6.2 still crashes occasionally, but far less often and as a result of other
actions]
Comment 62 Simon Fraser 2002-04-09 17:05:13 PDT
There are some new ATI drivers out. Anyone care to test them?
<http://www.ati.com/support/drivers/mac/macos-march-2002-update.html>
Comment 63 David Boroditsky 2002-04-11 08:04:45 PDT
I installed the new drivers and Mozilla still crashes. BTW, this update only
affects retail versions of the ATI Rage128 card, not the ones bundled by Apple
in the B&W G3.
Comment 64 Kevin McCluskey (gone) 2002-06-14 09:34:54 PDT
nsbeta1-. Limited to 350 B&W G3 and ATI graphics card.

This bug needs to be reassigned to an engineer that has this setup. dcone can
not reproduce.
Comment 65 Thomas R. (TRauMa) 2002-06-20 07:38:15 PDT
Sorry, but as this is a well-known problem reduced to a certain setup, shouldn't
it be in the release notes? I can't find anything in the RN for 1.0, so i'm
wondering if this bug is still there.
Comment 66 Simon Fraser 2002-06-24 10:55:46 PDT
This bug is still there. Workaround: set your screen to 'Thousands of colors'
rather than 'Millions'.
Comment 67 Stephen Walker 2002-08-02 08:14:33 PDT
Has anyone else been able to reproduce this bug on Windows machines that have
Radeon video cards? Looks like the bug isn't limited only to Mac systems, some
of the posters at http://www.driverheaven.net/thread.php?id=3952 are complaining
about the 'mozilla bug' in newer driver releases for Windows.
Comment 68 Porter Glendinning 2002-08-18 23:01:04 PDT
Yes. I've got a Radeon 7500 on my Win2K box here at home, and it's started
crashing with no discernable pattern other than it happens while I'm scrolling
-- by mousewheel, dragging the slider, or holding the scrollbar button down. I
can't say I've seen it yet when single clicking in the scrollbar or on the button.

When it hangs the entire OS just locks -- won't even respond to a ctrl-alt-del.
It may or may not be related, but I didn't notice this problem until I upgraded
my ATI driver recently to the most current one:

Driver Build 5.13.01.6118
7.74-020709A-004733C
Posted August 01, 2002

I've also set IntelliPoint to disable its wheel support in Mozilla to see if
that would help, and it hasn't.

I'm using the 1.1b release currently (2002072104), but was seeing this behavior
in nightlies as recently as 20020816.

As a separate note, just this evening I had one of these crashes on one of my
Win2K boxes at work which doesn't have an ATI card (NVIDIA), but it's the first
one I've seen there so it may not have been related.
Comment 69 Porter Glendinning 2002-08-25 13:48:12 PDT
As an addendum, switching the color depth to a lower setting has no effect on
this bug in Win2K. System still hangs completely.
Comment 70 Dean Sellis 2002-08-27 21:42:15 PDT
I have also experienced this bug on a Windows 2000 machine and I can reproduce
it.  Check my bug entry here: http://bugzilla.mozilla.org/show_bug.cgi?id=165081
Comment 71 Steve Dagley 2002-08-28 22:51:04 PDT
Changed summary since this appaears to be specific to ATI video cards/drivers.
Comment 72 Dan Kelmenson 2002-08-29 23:03:06 PDT
Just adding that under Windows XP this happens as well. For me it seems to be
exclusively when scrolling with mouse wheel, but that could just be because that
is how I usually scroll. Same August 1st, 2002 driver build, on a Radeon DDR
64MB VIVO.
Comment 73 Porter Glendinning 2002-08-30 14:40:05 PDT
To throw some more fuel on the fire, I just had one of these crashes fire off
upon clicking a named anchor link in one of the Mozilla Web developer docs
pages. I'd guess that the routines for following an in-page named anchor use the
scrolling mechanics (but that's just a guess).
Comment 74 Ian Neal 2002-08-31 16:39:44 PDT
*** Bug 165081 has been marked as a duplicate of this bug. ***
Comment 75 timeless 2002-09-02 17:26:09 PDT
relnoted 1.0, 1.1, future. if someone finds drivers which work please be sure to
get the release notes updated.
Comment 76 Stephen Walker 2002-09-05 19:12:28 PDT
Anyone at netscape know of any machines that have ati video cards that dcone 
can reproduce this bug on? More and more people are beginning to see this bug.
Comment 77 Simon Fraser 2002-09-06 10:43:19 PDT
It happens on the Blue and White G3s and their stock ATI video cards, under Mac
OS 9.
Comment 78 jeff givens 2002-09-06 14:56:27 PDT
(My bug report, 166683, has ended up here through a chain of assignations)

This has just happened to me again but this time there was no scrolling of any
type involved.

The PC had been siting idle for several minutes. I had a CAD viewer, Windows
explorer and Moz running. I closed the CAD viewer and clicked on the Moz title
bar to bring it to the front. I then clicked the back button. The status bar
indicated that the "back" url was being processed and about 5 seconds later the
machine locked up. Reboot gave the exact same cause, ATI driver stuck in loop.
At no time during the crash sequence (or immediately before) was there any
scrolling, either by mouse wheel, scroll bar/thumb, or keyboard.
Comment 79 John F. Mayer 2002-09-06 17:44:16 PDT
I, too, have been getting lockups on my Mac G3 with ATI with any number of
operations; even froze my system on startup once. Clicking on almost any item on
the menu bar, any change at all in whatever I'm doing, seems to bring on a
freeze almost invariably now. The mail function is all I feel safe using now.
I'm using Opera for browsing; it can import my Mozilla bookmarks but doesn't
seem to retain them from one use to the next. I've switched resolutions from
millions to thousands and created a new user profile; no use. Now using Mozilla
1.1 milestone; the frame no longer displays the build #, it seems. This bug(s)
has made Mozilla almost unusable.
Comment 80 Bart Cassady 2002-09-09 10:22:33 PDT
I have had this behaviour once in a while (once a month).

My configuration:

Mozilla 1.0 (Build ID: 2002053012)
WinNT 4.0 SP6a
True Color
ATI 3D Rage Pro (driver version numbers: 5.1.118, 4.0.0)

When paging down in a web page, I get an instantaneous WinNT blue screen of death.

Note that this is not reproducable at all, as it's only happened 3 times since
I've been using Mozilla (since 0.9.4).  Also note that I use Mozilla almost
exclusively, and do a fair bit of web browsing.
Comment 81 Joel Turner 2002-09-10 22:26:37 PDT
This bug sucks!  Didn't start getting it till i moved from NS 7PR1 to NS 7. 
Total system freeze reproducable always at following address:
http://everquest.allakhazam.com/db/item.html?item=1725

AMD Duron Win2000 ATI Radeon 8500
Comment 82 Stephen Walker 2002-09-12 16:55:10 PDT
Anyone on windows that is seeing this bug should download the new drivers that
were released today. This bug appears to be fixed in the latest driver release.
Comment 83 Dean Sellis 2002-09-13 05:41:09 PDT
I just upgraded to ATI drivers version 5.13.1.6166 for my Radeon 8500 and I can
no longer reproduce this bug.  Been browsing around and scrolling and not a
single problem.  The sites where this was reproducible also display and scroll fine.
Comment 84 parish 2002-09-13 09:58:51 PDT
If you read the Release Notes for this latest version (Catalyst 2.3) they state,
under "Issues Resolved in CATALYST™ Version 02.3":

Hanging issues with Mozilla browser

BTW, I'm running a Radeon 7000 under WinXP with the 6094 (Catalyst 2.1) drivers
and have never seen this bug. I tried Catalyst 2.2 (6118) but they just didn't
work properly at all.
Comment 85 Matt Brubeck (:mbrubeck) 2002-09-13 17:47:42 PDT
See bug 120893 for a possible duplicate of this bug, including additional
reports and comments.
Comment 86 Joel Turner 2002-09-16 01:17:34 PDT
Well .. that new driver fixes it for me... i say we mark this bug as fixed.
Comment 87 John F. Mayer 2002-09-16 09:17:00 PDT
Hold on, Joel. I'm glad you're no longer having a problem, but let's wait until
the bug is fixed for others as well. Just because the driver fixes it on one
platform doesn't mean it's fixed on all. I just installed the June ATI driver
for Mac and am currently waiting to see what happens. 

[OT & BTW, a curious phenomenon just presented itself here: when I hit any
character on my keyboard while outside a field such as this one {to do a
"Command-F," for example} the cursor disappears and does not reappear until I
move the mouse. Doesn't seem to be important enough to merit a bug report of its
own, but thought I'd mention it as a curiosity.]
Comment 88 Daniel Wang 2002-09-17 15:07:53 PDT
documentation bug: 169264
Comment 89 Daniel Wang 2002-09-17 15:08:41 PDT
documentation bug: bug 169264
Comment 90 Mike Kaply [:mkaply] 2002-09-17 21:19:55 PDT
You can add me to the list of people the new driver fixed.

I could consistently get a hang on all versions of Mozilla when clicking on a
named anchor (one that scrolls the window)

After installing the new ATI driver, Mozilla is working better than ever. I am
very happy.
Comment 91 Steve 2002-09-18 05:33:34 PDT
Hi
I too can be addedd to the list that do not have this problem with the
newest ATI any longer.

Just installed wme-radeon-4-13-01-9062-efg on a Radeon VE (7000) on a Windows ME
system and the scrolling now works.
Comment 92 John F. Mayer 2002-09-18 15:32:55 PDT
Still crashes Mac OS 9.2 running Mozilla 1.1 after installing June 2002 ATI
drivers, though MAY only crash when using arrows rather than scroll wheel or
dragging bar. Text with new ATI Mac driver made no mention of Mozilla bug. [I
have also created a new profile and reduced my color setting to thousands, to no
avail]. 

Do not wish to replicate till I get completely backed up. Do not encounter this
bug often anymore since it has been superseded by an equally insufferable bug,
Bookmarks Crash System, which I have not yet posted or checked for on existing
list. Together these bugs are definite browser blockers, though I still use
Mozilla for mail; no problems there lately, for some reason.
Comment 93 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2002-10-02 14:06:04 PDT
*** Bug 163881 has been marked as a duplicate of this bug. ***
Comment 94 Benjamin Smedberg AWAY UNTIL 2-AUG-2016 [:bsmedberg] 2002-10-02 14:08:26 PDT
From bug 163881, comment #5: (mousewheel scrolling hangs windows)

the issue is with ATI's video drivers version 
5.13.01.6118.  Reverting back to version 5.13.01.6094 solves all the problems
given here.
Comment 95 Jo Hermans 2002-10-06 04:44:20 PDT
*** Bug 168625 has been marked as a duplicate of this bug. ***
Comment 96 Jo Hermans 2002-10-06 04:53:51 PDT
from bug 120893 comment 25 :

ATI has released new driver version 5.13.01.6166 (a.k.a. CATALYST 02.3).
In the Release Notes, they explicitly claim that "Hanging issues with Mozilla
browser" are resolved.
I tried this driver with my previous test case and it worked OK.
No more hangs using Mozilla for 3 days.
Comment 97 John F. Mayer 2002-10-10 11:51:59 PDT
I'm assuming you're on a Windows platform. Neither the June Mac ATI driver
update nor the July "Alternate" (whatever that means) have helped the problem
any, and Mozilla is not mentioned in the release notes. 

If anything the problem has gotten worse as, for a time, it only seemed to
affect the browser but is now crashing me while reading mail as well (though
maybe I've just been getting longer letters lately). 

Can anybody recommend a good, free Mac mail reader (I was using Eudora, but it
had other problems, like scrambling my mail; caused a lot of confusion when I
did things like responding to a letter with the mayor's heading which actually
came from Amber at XXXBabes.com.)

Build 2002092903
Comment 98 Jason Bassford 2002-10-17 04:25:49 PDT
> ATI has released new driver version 5.13.01.6166 (a.k.a. CATALYST
> 02.3). In the Release Notes, they explicitly claim that "Hanging issues
> with Mozilla browser" are resolved.

There are fewer crashes (under XP), but I would still crash every once in a
while.  It's better but still not there.  I've reverted back to version 6058
which never crashes.

But - why isn't this bug marked a duplicate of bug 162689 (or, since it's a
lower number and has more comments, also resolved as INVALID).  As per bug
162689 comment 3:

---
-> invalid

a complete hang, crash or BSOD of win2k, winnt or winXP is always a problem with
a device driver running on the CPU level 1 or 2.
Mozilla doesn't install additional device drivers and Mozilla run's on the CPU
Level 3.

NS7.X and/or IE may work but that no reason.

You should try to upgrade/downgrade your display drivers and/or send a note to ATI.
---

What I'll do is reopen bug 162689 and dupe it to this one, then leave the
resolution of this one up to others.
Comment 99 Jason Bassford 2002-10-17 04:26:33 PDT
*** Bug 162689 has been marked as a duplicate of this bug. ***
Comment 100 Matthias Versen [:Matti] 2002-10-17 06:36:04 PDT
jasonb@dante.com: Video drivers depends on the platform. This can't be platform=all.
It's possible that other systems have the same problems.

I'm going to reopen bug 162689 because it's no dupe.
Mozilla CAN crash the system on Mac OS classic and you can't mark it invalid if
you don't know more.
Comment 101 Jason Bassford 2002-10-17 12:43:04 PDT
When I duped the bug it was to this one which (at the time) WAS marked as OS 
ALL - so it made sense to do so.  Now that you've changed the OS to Mac only, 
it makes sense to "undupe" it as you've done...
Comment 102 tiggerfan 2002-11-28 22:09:24 PST
Just to note, while this bug has been fixed in Windows (since it's an ATI driver
problem - Catalyst 2.3 and 2.4 fix it) upgrading to the newest driver fixes it,
but the suggestion in the release notes is to change back to the older drivers
(since that fixed it). I don't know where to post it, but I just wanted to
suggest that maybe should be changed to say upgrade your driver. Oh, and also, I
don't remember what it was, but another program also caused these crashes for me
- so this is not a problem exclusive to Mozilla.
Comment 103 John F. Mayer 2002-11-28 23:01:56 PST
No driver since my B/W G3 was released has been of any help. My pleas to ATI 
have fallen on deaf ears. They suggested I make sure my monitor was plugged into 
the graphics card. I hope Apple doesn't ever make the ATI mistake again. 

I agree, it's probably not just Mozilla (another problem involving Bookmark-
caused crashes has also occurred on Opera after importing my lengthy bookmark 
list from Mozilla). But, apparently, it's up to you clever folks to fix it if 
it's to be fixed, because ATI doesn't give a damn.
Comment 104 Stephan Heffner 2002-11-29 05:25:04 PST
While testing Mozilla 1.2.0 on MacOS 9.x vertical scrolling will crash Mozilla 
1.2 (Netscape 7.0, too).

It's easy to reproduce following these steps:

1. Open http://www.mozilla.org/releases
2. Open document source window
3. Scroll vertically by click, hold and drag the scrollbar. Do it up and down 
until the wait-clock appears :-)

After the system restart a crash report will be generated. I'll attach the 
details file asap after tranferring it to my other machine.

Motivated by the messages about ATI related problems, I've installed the 
October 2002 ATI Retail Update before creating the crash report.

Are there any other possible reasons for the crash? Any other hints or 
workarounds?

Thanks
Stephan
Comment 105 Stephan Heffner 2002-11-29 05:28:12 PST
Created attachment 107762 [details]
Quality Feedback Agent Details for Vertical Scrolling bug on Mac
Comment 106 Jason Bassford 2002-11-29 06:02:16 PST
> this bug has been fixed in Windows (since it's an ATI driver
> problem - Catalyst 2.3 and 2.4 fix it)

This is not true.  Both 2.3 and 2.4 under Windows continue to have the same
problem with crashes - although not as frequently.
Comment 107 John T 2002-12-04 15:10:59 PST
I read the many comments about ATI cards and note that it doesnt seem resolved.
But NOBODY seems to have been running a crash protection program like McAfee
Bombshelter that would show the process where the error actually occurred. I
blamed Windows and MSIE 3 for a long time for crashing even on Microsoft's own
website, and finally found that it was my video driver that was crashing, with a
divide-by-zero error as I recall.

The cure for that problem is to change the video mode! Just switch from using
your video driver to using a plain-vanilla VGA mode. This should work unless
your video driver is essential to having video output.

If the problem is a bug in the video driver, no amount of tinkering with the
browser will solve the problem.
Comment 108 tracy 2002-12-10 16:07:28 PST
I first noticed this bug when I installed OS9 on my B&E G3 recently. I had never
upgraded from 9.01. I immediately had crashes almost every 10 minutes. I
attributed it to a newer version of Mozilla I had just installed, but when I
went back to a previous version, same problem. I read through this report with
interest and I reinstalled my AVI drivers from my 9.01 BU disk image I had.
I haven't had a crash for 2 days now (crossing fingers).

Comment 109 John Austin 2002-12-16 05:17:54 PST
With every new release of Mozilla I am disappointed that this bug has not been 
fixed. I cannot use Mozilla at all because it invariably freezes the computer 
within minutes of starting Mozilla, even if I don't use it. All releases of 
Mozilla I have tried, as well as Netscape 7, suffer from the same problem. 
Switching to thousands of colours circumvents the problem but is unacceptable to 
my work.
The computer is a silver G4 Mac, 800 MHz, 512 MB, running a German version of Mac 
OS 9.2.2. The computer came with an ATI card. I have removed the card and all ATI 
system extensions; I am now using a Formac PCI GA12 graphic card driving a 24 
inch (ratio 1.6 : 1) ProNitron 24/600 monitor at 1536 x 936. The problem 
persists. (Seems like either there is still something from ATI lurking somewhere, 
or else the ProGraphics driver suffers the same problems as ATI.)

Is this problem going to be attended to soon????
Comment 110 Jason Bassford 2002-12-16 05:24:53 PST
FWIW, under Windows XP, the latest ATI drivers (Catalyst 2.5) work for me.  I'm
no longer getting any crashes.  (I did with both 2.3 and 2.4.)  I don't have any
idea if the Mac ATI drivers have been similarly "updated" (even assuming that
the bug is universal to both OSs).
Comment 111 Maarten Afman 2002-12-16 07:48:36 PST
I have had this problem with ATI Catalyst drivers 2.2 2.4 on Windows XP.
Scrolling vertically crashed the system (BSOD) @ driver called 'ati2diag' or
something like that. Crashes were like once or twice a day, but not only in MOZ
(running 1.0b and 1.2a) but also in Word2002.

I have my computer slightly overclocked so I finally reduced the FSB slightly.
I also upgraded tot Catalyst 2.5. 

WORKSFORME now.
Comment 112 Ralph 2003-01-23 07:19:44 PST
FYI: Mozilla 1.3a works fine with my ATI Mobility Driver Version 5.13.1.5016
from 2002-08-01
Comment 113 Dennis Andress 2003-04-22 15:12:10 PDT
If I may chime in here, in the 1.3 release notes this bug is described as "Using
ATI video drivers will lead to random crashes on many sites." 

I've had this problem on my machine; Win2K sp2,3 ATI Radeon 7000 video card
driver 6.14.1.6292 and an earlier version. I gave up trying to fix it after much
effort. Than one day I started Sun's SunOne Studio (aka Forte) which I hadn't
used for a while and duplicated the system crash. Oh happy day! Getting the
latest version of Java, going from 1.4.1_01 to 1.4.1_02 fixed the problem.

Sun's bug list shows some problems with ATI cards locking up Forte when
debugging. They recommend JRE 1.4.1_0 or the yet to be release 1.4.1_03

Hope that helps - Dennis Andress
Comment 114 Jason Bassford 2003-04-23 00:40:07 PDT
In terms of Sun's Java, configuring the following runtime startup parameter also
helps:

-Dsun.java2d.noddraw=true
Comment 115 Balazs Nagy 2003-05-08 15:21:47 PDT
I use Mozilla day by day with my PowerBook G4 1G (ATI Mobility Radeon 9000)
without a glitch. I use Jaguar, though (10.2.6). Maybe 9.2.2 is affected, but
it's not supported (see minimum requirements).  So please make it clear in
release notes that OS X is not affected.
Comment 116 John F. Mayer 2003-05-08 17:56:59 PDT
9.2 (and earlier) WAS supported when I reported the bug originally. Like many other users,  I have not found it convenient to switch to X, so I cannot use Mozilla as long as this bug remains. Whether or not non-X users are to be discarded is, of course, for the Mozilla developers to decide. 

I have not bothered to download the latest milestone build as this remains a "known bug," and it is one that is a major headache for those of us without plenty of time to devote to logging crashes. 
Comment 117 nickgsuperstar 2003-05-18 12:53:01 PDT
Hi folks, 

I just read the release notes for Java J2SE 1.4.1_02 (
http://java.sun.com/j2se/1.4.1/ReleaseNotes.html ) and they fixed:

4749817

A blue screen system crash occurred when attempting to run an application with
ATI graphics.

Following the bug report gives lots of examples, details, and workaround.

I hope this is helpful.  

---nickg
Comment 118 Matthias Versen [:Matti] 2003-06-01 17:42:00 PDT
A crash cayused by the graphic card on WIN NT based system (windows NT/2k/XP)
and on OS X is a bug in the device driver and it must be fixed in the driver.

OS Classic is now not longer suppoirted from Mozilla.org (last Release 1.2) 

I know that ATI release fixed drivers for win32...

-> wontfix

Comment 119 Christoph Vogelbusch 2003-06-21 05:46:18 PDT
I suppose this is the same BUG. When I surf too long Icons start getting black,
then scrollers get corupted last somplete screen gets corrupted. 
This happends everytime then I visit a lot of pages. 

You can't leave this "won't fix" unless you don't want half of the world not
been using mozilla AND THE PROJECTS THAT WILL USE IT. 

1.4 is for some time a final. Wither find a way to solve this or talk ATI into
solving it.
Comment 120 wayne 2003-06-28 10:06:19 PDT
My system does the exact same thing as comment 119. Accordingly, I can't
use Mozilla. There are a lot of ATI users out there for this to be wontfix.
My system is common as dirt; Win ME/ATI Radeon 7500. I'm using the version
4.13.9013 driver also, so it isn't just the version 5 driver.
Comment 121 John F. Mayer 2003-06-28 10:16:56 PDT
As the originator of this bug, it will not be surprising to learn that I agree with 120 et al. This bug makes it impossible for me to use Mozilla or Netscape; I think there are too many affected people to shrug it off. It's easy for me to say, since I am not a coder and cannot contribute to fixing the problem, but I don't think the Mozilla project should be discarding willing users, especially now that AOL/Netscape and Microsoft have made nice, if Internet Explorer is not to have the browser field all to itself. 
Comment 122 Matthias Versen [:Matti] 2003-06-28 14:26:17 PDT
This is "wontfix" because this bug is for MAC OS Classic only.
And 1.2.1 is the last Mozilla Release and there will be no future Release for OS
Classic = wontfix 

Please read a bug before you add a comment. Problems with corrupt graphic is no
crash at all = not this bug, using win32=not this bug

If you crash on windows XP, install the latest ATI driver and if that still
crashes your system ask ATI to fix it.
(They fixed already another crash in their driver)

The problem on win32 in 1.4 RC1/RC2 is known and should be fixed for 1.4 final
(GDI leak).

Comment 123 Felipe Hoffa 2003-08-02 12:19:20 PDT
My notebook is a Sony VAIO bought more than one year ago, and Sony won't update
the ATI drivers (ATI won't do it also, they send me to my "notebook manufacturer").

Is there a workaround for this bug other than getting rid of the notebook (and
not buying a VAIO anymore)? 
Comment 124 bugmozilla 2003-10-09 17:29:55 PDT
Well, i just installed Catalyst 3.8 drivers.. and it STILL randomly
freezes..doesn't matter if i'm switching tabs, or just unminimizing, clicking
back/refocus.. freezes completely at random.

Can anyone else confirm?
[Can Mozilla possible make a workaround, since ATI won't fix it seems.]

I am running Windows XP SP1; all critical updates (yeah.. every week); Dell
Inspiron 8100 (P3/1GHz 512MB RAM ). Their new VPU Recover feature didn't work.

This is absolutely rediculous; esp. that it seemed to be fixed before ( Catalyst
3.5? 3.4?) and they broke it again.

I will never buy an ATI product again. They always have some problem or driver
bug or whatever with whatever programs. There are still rendering bugs in UT2003
that they haven't fixed! I really do NOT understand why everyone is going
gaa-gaa over their products. In my experience, EVERY ATI card i've seen or used
has had some bug with any number of popular games (Unreal Tournament, UT2003,
Half-Life).
Comment 125 Steve Dagley 2003-10-09 18:18:33 PDT
It's bugs like this that make me wish Bugzilla had a flag that would prevent
additional comment from being added to a closed bug.  Since this bug is ancient
history for Mac developers with the demise of pre-OS X system as a supported
platform I'm removing myself from the cc: list.  It's been fun but I'm tired of
getting spammed every time a PC user that doesn't recognize this is a closed Mac
specific bug and doesn't think to log a new one for the problem with ATI cards
on a PC chimes in with "me too".
Comment 126 bugmozilla 2003-10-13 06:25:44 PDT
Sorry for the "spam", 
but maybe you should tell that to those who maintain the Release Notes as the
v1.1 notes say this is a Windows AND MacOS X bug: "Mac OS and Windows: Using ATI
video drivers will lead to random crashes on many sites. Mac OS ATI driver
versions affected: All (?) Windows ATI driver versions affected: 5.13.1.6118
(Mac OS) Workaround: set your screen to 'Thousands of colors' rather than
'Millions'. (Windows) Possible Workaround: Revert to an older driver (6094?)--
Untested (Bug 101055)"
And yes, i could've read that this is "resolved", but there was still a fairly
recent comment.

Anyway, on a more useful note to update my previous post, 
if anyone's interested or if anyone else mistakenly stumbles onto this report
(e.g., by way of Google).
After a _thorough_ cleaning and uninstall of all previous driver installs and
files using Add/Remove Programs control panel AND Driver Cleaner
(http://www.driverheaven.net/cleaner/), then re-installing the Omega ATI drivers
(based on the latest Catalyst 3.8 release) and i don't think i've had a problem
since. It has frozen a couple times, but it has also managed to unfreeze after a
few seconds.
Dunno if taking similar steps is possible or helpful for you Mac Classic users
(if there are even any updated drivers).
Comment 127 bugmozilla 2003-10-13 07:12:47 PDT
This is in the Windows section of the v1.5b Installation Notes too
(http://www.mozilla.org/releases/mozilla1.5b/installation.html). (I thought
mentioning the v1.1 notes was funny.)
I've filed a bug (222000; http://bugzilla.mozilla.org/show_bug.cgi?id=222000),
since i don't have CVS.
Comment 128 Eduardo Diaz 2004-07-20 11:44:09 PDT
Hello I experimented some problems in Satellite pro 4300 Savage S3 MX too, I
update my video drivers with others too.
Comment 129 Andrew Schultz 2005-03-27 18:56:51 PST
*** Bug 101749 has been marked as a duplicate of this bug. ***
Comment 130 John F. Mayer 2005-03-27 20:59:20 PST
What a pleasant surprise to hear from this fondly remembered bug after all these years. Do I get a prize 
for longevity? 

John Mayer
Comment 131 Eyal Rozenberg 2006-01-06 06:24:13 PST
If this is a Mac bug, why is it listed with the Windows requirements?

http://www.mozilla.org/projects/seamonkey/releases/seamonkey1.0b/installation.html#win_requirements
Comment 132 John F. Mayer 2006-01-06 08:53:16 PST
The obvious answer would be, "Because it's NOT a Mac-only bug." I was the original poster of this bug, and I DO happen to have a Mac, but I'm no longer using my 1994 PowerMac 7100/66 (though it's still running) or my G3 (not sure which one this bug showed up on) so I can't comment on the status of this bug with ATI cards. I DO recall their lack of responsiveness to the problem - perhaps "complete disregard" woud be a better term - has caused me to make a point of avoiding ATI products. 

But, to your point, there were a number of reports of this bug on Windows machines as well. I haven't bothered, but I suspect if you look back through the comments you'll find a few of them. 

Where's my longevity prize?

John Mayer
Comment 133 John F. Mayer 2006-01-06 08:57:44 PST
BTW, the current Mozilla works just fine on my Mac Mini and, come to think of it, I believe it was working fine on the G3. So does Foxfire (not sure of the distinctions between the two). I can gleefully scroll up and down and sideways, now. 

John Mayer
Comment 134 korlortar 2008-03-11 18:55:51 PDT
I dare open this long forgotten bug since I'm using a left-overs pc that occasionally gets stuck, mainl while scrolling down with the scroll bars or with the page down key.
My spevs are as low as this on the left-overs pc:
200 MHz Pentium with MMX
An ATI Mach 264 I think with 2 MB of video ram
a non functional sound card in windows environment it works fine in dos
sometimes digital sounds make it crash as well
The windows is 95 with DCOM 95 but usually when not using the network or mozilla the only browser it supports, any old versions of the competitor IE doesn't work
a thing which disables any anti-virus auto update function among other things.
What more? The system is relatively stable while offline, it does wonders with screen savers technology, both windows and norton commander (flying diskettes FTW), I miss those good old days of Norton Commander in dos environment, a friends sends you game files over a modem connection and it simply works...
:)
If any ATI member reads this than take an example from Nvidia who until driver version 66.75 were compatible with every video card they ever released, later they started discarding compatibility till the FX5200 card, as the oldest of the FX series...
As if anyone will really read what I write here.
:) cheers and Peace out. DaVe

Note You need to log in before you can comment on or make changes to this bug.