double click Bookmarks button to open Library (Show All Bookmarks) directly

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
--
enhancement
RESOLVED WONTFIX
4 years ago
5 months ago

People

(Reporter: Timur, Unassigned)

Tracking

({polish, uiwanted})

29 Branch
polish, uiwanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

In order to edit bookmarks, I click Bookmarks button to open bookmarks, then scroll to "Show All Bookmarks" and then click to open a Library. 
Previously, "Show All Bookmarks" appeared on top of the list, and now with new FF versions it's at the bottom, but it's basically the same. 


Actual results:

double clicking  Bookmarks button doesn't do anything now (opens and closes bookmarks)


Expected results:

double click function on Bookmarks button should open Library window directly

Updated

4 years ago
Severity: normal → enhancement
Component: Untriaged → Bookmarks & History
Note discussion in a mozilla.support (sumo) question https://support.mozilla.org/en-US/questions/1003606#answer-583115, and mention of related bugs Bug 999184 , Bug 124485 ,Bug 129480
(Reporter)

Updated

4 years ago
Summary: add double click function on Bookmarks button to open Library window directly → double click Bookmarks button to open Library (Show All Bookmarks) directly

Comment 2

4 years ago
Hi,
I m not able to reproduce it.................
(In reply to Varun from comment #2)
> Hi,
> I m not able to reproduce it.................

I think this is intended to be an enhancement to the current use of the icon, by creating an extra feature namely on double click of that icon open the bookmarks Library. 

<  https://support.mozilla.org/en-US/questions/1003606#answer-583156
> I find current Show YOUR Bookmarks fine, 
>but I simply want to double click Bookmarks button to get to Show ALL Bookmarks, 
>and not to click once, scroll, click again.
(Reporter)

Comment 4

4 years ago
Right. I hope this may be added soon. 
Also, after Library window is open, focus should be in Search Bookmarks field, so that we can start typing right away. 
Now, I have to make many moves just to start searching.

Comment 5

4 years ago
(In reply to Timur from comment #4)
> Right. I hope this may be added soon. 
> Also, after Library window is open, focus should be in Search Bookmarks
> field, so that we can start typing right away. 
> Now, I have to make many moves just to start searching.

This is Bug 284653.
"Show All Bookmarks" appears twice when clicking the Bookmarks icon - the second option and the last one. It also can be opened using it's shortcut: Ctrl+Shift+B.

Clicking twice on every (Australis) icon closes it's pop-up, by design.
(Reporter)

Comment 7

4 years ago
(In reply to Petruta Rasa [QA] [:petruta] from comment #6)
> "Show All Bookmarks" appears twice when clicking the Bookmarks icon - the second option and the last one. 
OK, luckily somehow I have it as the first option so I finally just slide down.

> It also can be opened using it's shortcut: Ctrl+Shift+B.
Using such a shortcut as Ctrl+Shift+B isn't practical for a single hand operation. 
 
> Clicking twice on every (Australis) icon closes it's pop-up, by design.
On the other hand, I understand that introducing double click for this might be a problem if there's a limit that double click closes icon's pop-up.

Could a solution be using Search bar with, let's say, Ctrl+Enter or Shift+Enter to search and open All bookmarks? It would be great and it would also solve that other issue with Bug 284653.

Updated

4 years ago
Keywords: polish, uiwanted

Updated

4 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All

Comment 8

5 months ago
it should be easier to reach the Library, we should have a "Show in Library" context menu... But we won't add more undiscoverable keyboard handling.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.