external/sprd-aosp/platform/system/core not accepting a non-fast-forward change

RESOLVED FIXED

Status

Developer Services
Mercurial: hg.mozilla.org
--
major
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: catlee, Unassigned)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
we're missing commits from upstream. e.g.

dfc314f61b701c4a710b989e9b21300d122dbbc9 exists in the sprdb2g_gonk4.4 branch in 

http://sprdsource.spreadtrum.com:8085/b2g/android/platform/system/core

but not in 

http://git.mozilla.org/?p=external/sprd-aosp/platform/system/core.git;a=shortlog;h=refs/heads/sprdb2g_gonk4.4

commit was made on Tuesday, May 27. Not sure when it was pushed to upstream.git
(Reporter)

Comment 1

4 years ago
perhaps they've reset their repo at some point?

49d2fe42b939255ab35a68b4d7c143d0696a3eb6 (our tip of sprdb2g_gonk4.4) doesn't exist in their repo
(In reply to Chris AtLee [:catlee] from comment #1)
> perhaps they've reset their repo at some point?
> 
> 49d2fe42b939255ab35a68b4d7c143d0696a3eb6 (our tip of sprdb2g_gonk4.4)
> doesn't exist in their repo

We need a contact withing sprd to confirm this. If they have done a non-fastforward, we'll need to pass that info on to our partners in advance of us non-fast forwarding our mirror.
Created attachment 8430911 [details]
fast forward failures

attached is a list of repos from sprd that have had non-fast forward changes 

We'll need to notify our partners, undo the config on our repos, then do the mirror operation.

We need to know _when_ sprd will stop doing that, or very carefully redefine our processes for modify
James, can you check what's happening there? Thanks!
Flags: needinfo?(james.zhang)
Use "git push -f" please.
Flags: needinfo?(james.zhang)
Or you can delete these git repo and git clone mirror again.
(Reporter)

Comment 7

4 years ago
James, is this likely to happen again, or was this an accidental push of non-fastforward changes? Is there anything set up on your side to prevent non-fastforward commits from landing in the repos?
Flags: needinfo?(james.zhang)
We fork a error branch, then we delete it and fork again. And we only push firefox branch to open source repo and you can't see other internal branch.
We mirror mozilla git repo on my side and sometimes we also meet the same issue, we just delete mirror and sync again or use 'git push -f'.
We use gerrit on my side, nobody can push commit directly.
Flags: needinfo?(james.zhang)
(In reply to James Zhang from comment #8)
> We mirror mozilla git repo on my side and sometimes we also meet the same
> issue, we just delete mirror and sync again or use 'git push -f'.

James -- which mozilla git repo are you referring to? You should NEVER see a non-fastforward change on any of the FFOS repositories hosted on git.mozilla.org. All of our production repositories on git.mozilla.org are set to disallow both "receive.denyNonFastForwards" and "receive.denyDeletes". Our understanding is that this practice is common and expected in the android development community.

Is this a temporary situation due to early development stages, or is this your normal development practice?

Which approach we take to resolving this issue does depend on how often it will happen, so any additional insight you can provide us would be appreciated. Our current practice calls for us to send an email to our partners anytime we push a non-fast-forward change, as many of their automated systems also require manual intervention when such a commit is made.
Flags: needinfo?(james.zhang)
(In reply to Hal Wine [:hwine] (use needinfo) from comment #9)
> (In reply to James Zhang from comment #8)
> > We mirror mozilla git repo on my side and sometimes we also meet the same
> > issue, we just delete mirror and sync again or use 'git push -f'.
> 
> James -- which mozilla git repo are you referring to? You should NEVER see a
> non-fastforward change on any of the FFOS repositories hosted on
> git.mozilla.org. All of our production repositories on git.mozilla.org are
> set to disallow both "receive.denyNonFastForwards" and
> "receive.denyDeletes". Our understanding is that this practice is common and
> expected in the android development community.
> 
> Is this a temporary situation due to early development stages, or is this
> your normal development practice?
> 
> Which approach we take to resolving this issue does depend on how often it
> will happen, so any additional insight you can provide us would be
> appreciated. Our current practice calls for us to send an email to our
> partners anytime we push a non-fast-forward change, as many of their
> automated systems also require manual intervention when such a commit is
> made.

I forgot which git repo, maybe one of gaia-l10n. And I delete old git repo, repo sync again, it's OK.
Flags: needinfo?(james.zhang)
automation has done several iterations without problems now. Closing.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
If we have non-fast-forward updates caused by branch error or 'git push -f', please notify mozilla.
Flags: needinfo?(ying.xu)
Flags: needinfo?(sam.hua)
Blocks: 1016157

Comment 14

4 years ago
Hi, Hal Wine.

sorry to tell you
there is another repository need to sync manually.

Because we have created some branches of 6821 ffos very wrong before.
I'm sorry for that we git push -f the repo bootable/recovery in sprd git server again.
Please update the server on your side.thank you very much.

-  <project path="bootable/recovery" name="platform/bootable/recovery" />
+  <project path="bootable/recovery" name="platform/bootable/recovery" revision="sprdb2g_gonk4.0_6821" />
Flags: needinfo?(hwine)
Hi HAL, please help to update.
Flags: needinfo?(kli)
James,

We don't see this repository as having a pending non-fast-forward update. (I was waiting to see if one was coming.)

Can you provide more information including:
 - url on your end
 - branch on your end
 - revision number you believe is non-fast-forwardable

With that I can confirm why we don't see any issue.

Thanks,
--Hal
Flags: needinfo?(hwine)
Flags: needinfo?(james.zhang)
The revision of bootable/recovery is updated to tarako manifest on bug 1022454. So I think we need to pull manifest and repo sync to get the correct revision.
Flags: needinfo?(kli)
Okay, I think there is nothing to be done here -- the repository is fine. Our mirrors have the revision referenced in bug 1022454, as can be seen here:
  http://git.mozilla.org/?p=external/sprd-aosp/platform/bootable/recovery.git;a=summary

If there is an issue, it does not involve nonFastForward changes, so please open a new bug. (Changed summary to clarify this bug was only about the non-fast-forward issue.)

Cancelling all the "need info" requests.
Flags: needinfo?(ying.xu)
Flags: needinfo?(sam.hua)
Flags: needinfo?(james.zhang)
Summary: external/sprd-aosp/platform/system/core not syncing properly → external/sprd-aosp/platform/system/core not accepting a non-fast-forward change
(Assignee)

Updated

4 years ago
Product: Release Engineering → Developer Services
You need to log in before you can comment on or make changes to this bug.