Last Comment Bug 1017875 - (picture-prefon) Pref on the picture element by default
(picture-prefon)
: Pref on the picture element by default
Status: RESOLVED FIXED
: dev-doc-needed
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: P5 normal with 7 votes (vote)
: mozilla38
Assigned To: John Schoenick [:johns]
:
: Andrew Overholt [:overholt]
Mentors:
Depends on: 1017878 srcset picture srcset-prefon 1023519 1045532 1052417 1067345 1076587 1080177 1115061 1139554 1139560 1140769 1141260
Blocks: responsive-images
  Show dependency treegraph
 
Reported: 2014-05-29 15:14 PDT by John Schoenick [:johns]
Modified: 2015-03-10 11:00 PDT (History)
31 users (show)
ryanvm: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
38+
38+


Attachments
Pref on <picture> element and update test (5.61 KB, patch)
2014-12-10 18:54 PST, John Schoenick [:johns]
no flags Details | Diff | Splinter Review

Description User image John Schoenick [:johns] 2014-05-29 15:14:54 PDT
Picture (Bug 870022) and img srcset (Bug 870022) will both be pref'd off on initial landing, this tracks remaining issues blocking pref'ing them on by default.
Comment 1 User image Richard Newman [:rnewman] 2014-09-02 08:14:40 PDT
Very relevant to mobile, so tracking-fennec? and marking for relnote for when this ships.

(Hoping I got the keyword right...)
Comment 2 User image Andrew McCreight [:mccr8] 2014-09-02 08:38:48 PDT
I believe the tracking flag "relnote-firefox" is the proper thing, not the relnote keyword.
Comment 3 User image Sylvestre Ledru [:sylvestre] 2014-09-02 08:59:13 PDT
Indeed. We are discussing about removing this keyword to clear the confusion.


Release Note Request (optional, but appreciated)
[Why is this notable]: Cool new features and the Opera + Chrome have it
[Suggested wording]: I think they deserve two dedicated items:
"HTML5: picture element implemented"
"HTML5: srcset attribute on img"
[Links (documentation, blog post, etc)]: Probably their documentation
Comment 4 User image James Willcox (:snorp) (jwillcox@mozilla.com) 2014-09-04 10:13:25 PDT
Can we turn this on for Nightly right now?
Comment 5 User image John Schoenick [:johns] 2014-09-04 13:13:30 PDT
Part of Bug 1037643 is blocking the tests from landing, which we really should not turn anything on without. The other blockers are minor and have patches, but I've been pulled away from this the past few weeks for some high priority e10s stuff. I should be able to get back to this next week and get things landed so we can flip this on early in the cycle
Comment 6 User image Henri Sivonen (:hsivonen) 2014-09-15 07:05:42 PDT
We shouldn't pref this on before ensuring that the <img src> preloader doesn't preload the wrong stuff. <picture> and srcset are all about loading the right image variant, so also loading the wrong variant is particularly bad considering the goals of the feature. (Bug 1067345.)
Comment 7 User image Brad Lassey [:blassey] (use needinfo?) 2014-10-20 08:25:46 PDT
filter on [mass-p5]
Comment 8 User image John Schoenick [:johns] 2014-12-10 18:54:55 PST
Created attachment 8534781 [details] [diff] [review]
Pref on <picture> element and update test
Comment 13 User image Florian Bender 2015-02-17 13:35:22 PST
Just requested relnote? from Bug 1018389, saw comment 3 afterwards. FTR, "my" relnote? request:

Release Note Request (optional, but appreciated)
[Why is this notable]: responsive images – also see Bug 1018389
[Suggested wording]: Implemented srcset attribute and <picture> element for responsive images
[Links (documentation, blog post, etc)]:

Since this and Bug 1018389 are closely connected, a singular entry in the Release Notes should suffice.
Comment 14 User image Lukas Blakk [:lsblakk] use ?needinfo 2015-02-19 16:27:43 PST
Have added to the Aurora 38 notes as: 

Implemented srcset attribute and <picture> element for responsive images

Note You need to log in before you can comment on or make changes to this bug.