[Flatfish] Cannot get into fastboot mode via hardware keys

RESOLVED FIXED

Status

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: maks, Unassigned)

Tracking

({verifyme})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Flatfish][flatfish-hardware])

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140428193838

Steps to reproduce:

I'd like to get Flatfish tablet into either Uboots Fastboot mode or into the Allwinner SoC specific FEL mode using a hardware key combo on power on.

This is essential for people testing who may accidentally break  something but not have turned on adb on first or have updated dev system/boot images which may potential brick the device and so would need a way to get into fastboot mode to flash a new system/boot img without using "adb reboot fastboot".


Actual results:

There is no documentation on how to do so and when others who already have thier flatfish devices have tried some obvious key combos they have not been able to get into fastboot mode.


Expected results:

The reason that getting into FEL mode maybe a workable alternative is that according to this diagram:  http://linux-sunxi.org/BROM#A31  the A31 SoC using in Flatfish should also be able to bot from sdcard0 if its in FEL before trying to boot from a bad boot or system partition install on the internal NAND flash
(Reporter)

Updated

4 years ago
Component: General → Hardware
(Reporter)

Comment 1

4 years ago
Reading similiar bug reports for the ZTE device, it seems it has a "recovery" partition that the bootloader will boot into using pwr+vol-up so of course thats a third option, though I cant really tell much from just the single patchfile in https://github.com/flatfish-fox/flatfish-uboot its not even clear from that which version on uboot it applies onto ?

Comment 2

4 years ago
"adb reboot fastboot" don't work. You have to use "adb reboot boot-fastboot".
(Reporter)

Comment 3

4 years ago
Thanks Raniere, sorry thats just my typo as I dont yet have my flatfish device.

I've had someone else (Caspy7) on irc who does report that they seem to be able to get it into FEL mode using pwr+vol-up buttons so now I want to build a sdcard image with a custom version of the uboot used for flatfish but i have no idea which uboot version was used as the base for the patch in the github repo: https://github.com/flatfish-fox/flatfish-uboot 
Anyone know ????
Caspy7: do you have anymore input regarding this?
As Caspy7 and Maksim Lin know, I was working on getting a bootable SDCard that will get into Fastboot mode without any user interaction, just pressing vol- (or vol+) and power button to put the tablet into FEL mode.
I was able to build a u-boot version with the proper changes to make it go straight into fastboot mode, but another binary file called SPL (Second Program Loader) is needed too in order to let a bootable SDcard loads this modified version of U-Boot. 
This SPL file should be created as part of the build process, but it's not being built cause it needs some special configuration. All my efforts are heading to make this configuration file, but I'm getting some build errors that I'm trying to fix right now.
I will keep you updated as soon as I get any results.

Meanwhile, I've created a diff patch as Maksim requested me: https://dl.dropboxusercontent.com/u/18328346/sun6i.h.diff
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

4 years ago
Thanks for posting the patch Juan.

I should add that talking on freenode#sunxi-linux with one of the devs there, it seems there is no working SPL for the A31 right now: https://groups.google.com/d/msg/linux-sunxi/MQKxPOxTnpo/jYDDP7-6CNYJ
so I'm doubtful now if we will be able to get this working on our own.

Also to keep a track of things, we've got a issue on GH open about this as well: https://github.com/flatfish-fox/flatfish-uboot/issues/2

Comment 7

4 years ago
Joe, can you please contact our partner developers about this in the most appropriate way (perhaps simply CC or needinfo?)?

Not having the ability to enter a recovery mode is a problem on these high-development devices.

From what I understand, to get hardware buttons working to enter a recovery mode, u-boot must be updated. And for us to experiment with modifying the uboot there is a very high risk of permanently (and truly) bricking the tablet.  So we really would rely on the partner who has the expertise and tools to do this.
Flags: needinfo?(jcheng)
Blocks: 903304
Whiteboard: [Flatfish][flatfish-hardware]
ni? William
Flags: needinfo?(jcheng) → needinfo?(william.wyliang)

Comment 9

4 years ago
We are working to provide the feature already. We plan to provide another boot image which allows the device to be booted into fastboot mode when the user presses the volume key during the boot process. (Note: the chip vendor has already used the volume+power combination to enter the PhoenixSuit recovery mode.)
Flags: needinfo?(william.wyliang)

Comment 10

4 years ago
A new bare boot image which enable the user to use the hardware keys to boot the device into the fastboot mode is now available in the following link.

https://www.dropbox.com/sh/b2py1btcwstqldl/AABblbq_csa1IHQwdvLdfptTa/. The file is located under the recovery-image-for-fastboot/ directory, namely sun6i_boot-fastboot_v2.0.img.

Please follow the instruction described in the README file stored in the same directory in order to burn the bare boot image into Flatfish.

The procedure to enter the fastboot is described as below.

1. Power off the device.
2. Press and HOLD the power key (for about 4~5 seconds) 
3. When the boot logo (Firefox OS Contribution Program) appears, press and HOLD Volume Up key (for about 2 second) until the Fastboot log appears.
4. Now release the keys. The device is now in Fastboot mode.

Eva, please verify the image to see if it has solved the bug.
Flags: needinfo?(eva.chen.fx)

Comment 11

4 years ago
Hi William, tested and worked fine.
Flags: needinfo?(eva.chen.fx)

Comment 12

4 years ago
Thanks. Suggest to mark this bug as fixed.

Comment 13

4 years ago
The process is not working for me. I have already updated with the latest recovery image and currently using the latest nightly.
Flags: needinfo?(william.wyliang)

Comment 14

4 years ago
Verifying as fixed. This should have been marked as such long ago as we've seen it consistently working on users with the new bootloader.

Ashickur, please drop by the #TCP IRC channel to troubleshoot your issue (or even contact me directly). This isn't a good place to troubleshoot.
(Also remember to continue holding the power button the whole time.)
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(william.wyliang)
Resolution: --- → FIXED

Comment 15

4 years ago
(In reply to Caspy7 from comment #14)
> (Also remember to continue holding the power button the whole time.)

Now I got it :), it was not mention there. It will be fine if you mention this in the instruction.

Comment 16

4 years ago
Continuing to hold the power button throughout the process is mentioned in the official instructions on the wiki.

https://wiki.mozilla.org/FirefoxOS/TCP/Flashing_the_Flatfish_bootloader
You need to log in before you can comment on or make changes to this bug.