bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Reorder a tab on tab panel

RESOLVED DUPLICATE of bug 1331154

Status

()

Firefox for Android
General
RESOLVED DUPLICATE of bug 1331154
4 years ago
2 years ago

People

(Reporter: Yuan, Unassigned, Mentored)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [lang=java][exploration required])

Attachments

(1 attachment)

Created attachment 8431856 [details]
Reorder a tab.001.jpg

The full-screen tab panel(bug1014996) offers lots of potentials for managing tabs. Reorder a tab is one of it. 

Press down a tab thumbnail and drag it to targeted position. At the same time, the header on the tab panel turns to a tray for deleting the selected tab.

Next step:
* Visual design
* Animation refinement
* Implementation
No longer blocks: 1014156
Would this also actively at the same time change the order on the tab strip?
(In reply to Aaron Train [:aaronmt] from comment #1)
> Would this also actively at the same time change the order on the tab strip?

Yes, the order of tabs on tab strip and tab panel should be matching all the time.
Mentor: michael.l.comella, mhaigh
Whiteboard: [lang=java][exploration required]
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1331154
You need to log in before you can comment on or make changes to this bug.