Closed Bug 1019003 Opened 6 years ago Closed 6 years ago

Build warning: ‘visibility’ attribute ignored [-Wattributes] in TypedArrayObject.cpp

Categories

(Core :: JavaScript Engine, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla32
Tracking Status
firefox30 --- wontfix
firefox31 --- fixed
firefox32 --- fixed
firefox-esr24 --- fixed

People

(Reporter: bbouvier, Assigned: Waldo)

References

Details

(Whiteboard: [qa-])

Attachments

(2 files, 1 obsolete file)

These ArrayClassPtr are already defined as JS_FRIEND_DATA in jsfriendapi.h, so it doesn't seem needed in TypedArrayObject.cpp.

The shell compiles without any issue when disabling it. The full browser does too (gcc 4.8.2). Do you think it'd need a try build?

In file included from /home/ben/code/moz/builds/wd64/js/src/Unified_cpp_js_src11.cpp:28:0:
/home/ben/code/moz/inbound/js/src/vm/TypedArrayObject.cpp:2105:1251: warning: ‘visibility’ attribute ignored [-Wattributes]
 IMPL_TYPED_ARRAY_JSAPI_CONSTRUCTORS(Float32, float)
Attachment #8432552 - Flags: review?(jwalden+bmo)
Comment on attachment 8432552 [details] [diff] [review]
warning-js-default-visibility.patch

Review of attachment 8432552 [details] [diff] [review]:
-----------------------------------------------------------------

I wouldn't bother tryservering, myself.
Attachment #8432552 - Flags: review?(jwalden+bmo) → review+
Duplicate of this bug: 1018908
https://hg.mozilla.org/mozilla-central/rev/b4376eee6dea
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla32
Attached patch bug1019003.patchSplinter Review
[Aurora/Beta Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 991981
User impact if declined: can't build with Mingw (as stated in bug 1021582, it's used for cross-compilation of the Tor bundle project).
Testing completed (on m-c, etc.): m-i, m-c
Risk to taking this patch (and alternatives if risky): no risk, build passed on all platforms.
String or IDL/UUID changes made by this patch: n/a

[ESR Approval Request Comment]
If this is not a sec:{high,crit} bug, please state case for ESR consideration:
User impact if declined: can't build with Mingw (as stated in bug 1021582, it's used for cross-compilation of the Tor bundle project).
Fix Landed on Version: current Nightly.
Risk to taking this patch (and alternatives if risky): no risk, build passed on all platforms.
String or UUID changes made by this patch: n/a


Apparently, there was a build error caused by this on mingw (see also bug 1021582), so we should uplift that to all versions that received the uplift for bug 991981.

Carrying forward r+ from Waldo.
Attachment #8432552 - Attachment is obsolete: true
Attachment #8435639 - Flags: review+
Attachment #8435639 - Flags: approval-mozilla-esr24?
Attachment #8435639 - Flags: approval-mozilla-beta?
Attachment #8435639 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1021582
Comment on attachment 8435639 [details] [diff] [review]
bug1019003.patch

Too late for beta/release.

Accepting for ESR since the Tor project is using esr (like Debian).
Attachment #8435639 - Flags: approval-mozilla-esr24?
Attachment #8435639 - Flags: approval-mozilla-esr24+
Attachment #8435639 - Flags: approval-mozilla-beta?
Attachment #8435639 - Flags: approval-mozilla-beta-
Attachment #8435639 - Flags: approval-mozilla-aurora?
Attachment #8435639 - Flags: approval-mozilla-aurora+
Ben, should this have tests or be in the test suite?  Thanks!
Flags: in-testsuite?
Assignee: benj → jwalden+bmo
This just missed the ESR 24.6.0 build #2. Can this be worked around in the 24.6.0 cycle so that we don't have to respin?
(In reply to Liz Henry :lizzard from comment #9)
> Ben, should this have tests or be in the test suite?  Thanks!

We can't actually test that, as it's a build warning in the best case, a build failure for cross compilation in the worst case (and that cross compilation build is not included in our CI platform).
Flags: in-testsuite? → in-testsuite-
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.