Closed Bug 1019969 Opened 6 years ago Closed 5 years ago

Thunderbird 18-30b1 gets "Unresponsive script" 45 seconds after launch/startup. OK in 31.0

Categories

(Thunderbird :: Untriaged, defect)

18 Branch
x86_64
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: mozilla-bugzilla, Unassigned)

References

Details

(Keywords: perf, regression, Whiteboard: [regression:TB18])

Attachments

(1 file)

Attached file debuginfo.txt
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:30.0) Gecko/20100101 Firefox/30.0 (Beta/Release)
Build ID: 20140529161749

Steps to reproduce:

start Thunderbird, every version between 18 and 30b1, even in Windows Safe Mode and Thunderbird Safe Mode, reinstalled it several times and tried versions 18,19,20,21,22,23,24,30


Actual results:

doesn't respond, looks like it's crashed, after 45 seconds the message window appears and can be closed with stop script ( "Unresponsive script" error: Script: chrome://messenger/content/mailWindowOverlay.js:1374 )


Expected results:

it should start without the long waiting period. works with 17.0.11esr
I suspect this is one of your addons, and bugzilla has plenty of examples of addons causing slowness[1]. I don't trust thunderbird safe mode.

I'd start by removing (not just disabling) lookout and Folderpane Tools, start Windows in safe mode, then Thunderbird. Please tell us your results.

[1] https://bugzilla.mozilla.org/buglist.cgi?v4=perf&f1=short_desc&o3=substring&list_id=10408878&v3=addon&j2=OR&o1=nowordssubstr&resolution=INVALID&classification=Client%20Software&classification=Components&f4=keywords&query_format=advanced&f3=status_whiteboard&o4=substring&f2=OP&product=MailNews%20Core&product=Thunderbird
Flags: needinfo?(mozilla-bugzilla)
Keywords: perf
thanks for your suggestion, unfortunately removing those two and starting in safe mode again (tried 3 times) didn't resolve the issue
Flags: needinfo?(mozilla-bugzilla)
We have a similar report in bug 939462 but it is not yet determined what causes it. So it doesn't mean it is a duplicate.
See Also: → 939462
yes, looks like the same problem.
was introduced with bug 235956 i guess :(
seems to be gone after an update to 31.0, starting takes about 4 seconds now.
the first click on one of the inboxes after starting takes about 4 seconds, but thats a total of 8 seconds compared to the previous 45 - i would say "resolved"
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
(In reply to Andreas Ziegler from comment #5)
> seems to be gone after an update to 31.0, starting takes about 4 seconds now.
> the first click on one of the inboxes after starting takes about 4 seconds,
> but thats a total of 8 seconds compared to the previous 45 - i would say
> "resolved"

Andreas, that's very strange. But thanks for the update!

(In reply to Andreas Ziegler from comment #4)
> yes, looks like the same problem.
> was introduced with bug 235956 i guess :(

If your issue started in TB18 then it would not be related to bug 235956, which began in TB24.

Unclear which of the bugs from a partial list of TB18 fixed bugs might be the cause of our issue - https://web.archive.org/web/20130112225616/http://www.mozilla.org/en-US/thunderbird/18.0beta/releasenotes/buglist.html and https://bugzilla.mozilla.org/buglist.cgi?f1=short_desc&list_id=11912876&o1=nowordssubstr&resolution=FIXED&classification=Client%20Software&classification=Components&query_format=advanced&f2=OP&target_milestone=Thunderbird%2018.0&product=MailNews%20Core&product=Thunderbird
Keywords: regression
Summary: Thunderbird hangs for 45 seconds upon launch/startup → Thunderbird 18-30b1 gets "Unresponsive script" 45 seconds after launch/startup. OK in 31.0
Whiteboard: [regression:TB18]
Version: 24 → 18
You need to log in before you can comment on or make changes to this bug.