Last Comment Bug 235956 - add number of unread messages next to (collapsed) account name
: add number of unread messages next to (collapsed) account name
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Folder and Message Lists (show other bugs)
: Trunk
: All All
: -- enhancement with 16 votes (vote)
: Thunderbird 24.0
Assigned To: Travis Wood
:
Mentors:
: 135092 262795 277949 296342 323225 370514 399332 (view as bug list)
Depends on: 939462
Blocks:
  Show dependency treegraph
 
Reported: 2004-02-28 10:49 PST by Marek
Modified: 2015-01-24 02:56 PST (History)
26 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Added unread message count to collapsed folders (881 bytes, patch)
2013-05-05 12:13 PDT, Travis Wood
mconley: review+
Details | Diff | Review

Description Marek 2004-02-28 10:49:47 PST
User-Agent:       
Build Identifier: Mozilla Thunderbird 0.5 (20040207)

it would be useful to have a number of unread messages in parentesis next to
account name. it's useful if someone has many accounts and the folder list is
collapsed.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.
Comment 1 Henrik Stevn Nielsen 2004-08-20 05:25:08 PDT
I second this.

Since I have 12 different accounts, it is quite a hassle to have to check each
one manually instead of just skimming over a collapsed list.

(Thunderbird 0.7.3 Windows build)
Comment 2 Martin Gill 2004-10-04 10:17:51 PDT
I third this :)
Comment 3 John Lemon 2004-12-14 22:20:22 PST
In general, the unread count should roll up to parent folders.
Comment 4 Mike Cowperthwaite 2005-01-18 15:04:44 PST
*** Bug 277949 has been marked as a duplicate of this bug. ***
Comment 5 Mike Cowperthwaite 2005-01-18 15:05:39 PST
This is Seamonkey bug 199482.
Comment 6 Mike Cowperthwaite 2005-02-13 12:24:58 PST
*** Bug 250537 has been marked as a duplicate of this bug. ***
Comment 7 Mike Cowperthwaite 2005-02-13 12:31:09 PST
*** Bug 262795 has been marked as a duplicate of this bug. ***
Comment 8 Gervase Markham [:gerv] 2005-09-27 01:51:01 PDT
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
Comment 9 Sebastian Davids 2005-09-27 05:07:23 PDT
There are several duplicates and several people on this bug's cc list.

Just because there's no comment noise we're still waiting for this very useful
feature.
Comment 10 Mike Cowperthwaite 2005-09-27 07:27:17 PDT
Updating comment 5: this is Seamonkey bug 157686.
Comment 11 Wayne Mery (:wsmwk, NI for questions) 2005-10-11 06:05:39 PDT
*** Bug 296342 has been marked as a duplicate of this bug. ***
Comment 12 Dennis 2005-12-29 07:46:32 PST
I am experiencing the same inflated numbers (50,000+) of unread messages. I downloaded the latest version and I'm experiencing the same problem.  This has caused long delays in downloading new mail messages. I tried compacting the folder and it did not help.  Does anyone have a solution?
Comment 13 Mike Cowperthwaite 2006-01-13 08:42:24 PST
*** Bug 323225 has been marked as a duplicate of this bug. ***
Comment 14 Eric Estievenart 2006-12-22 06:11:02 PST
Indeed, really needed to propagate unread count to folded parent folder/account
when you have many accounts / folders in them and they cannot fit your screen.
Comment 15 Mike Cowperthwaite 2007-02-19 15:53:17 PST
*** Bug 370514 has been marked as a duplicate of this bug. ***
Comment 16 Magnus Melin 2007-10-12 09:40:07 PDT
*** Bug 399332 has been marked as a duplicate of this bug. ***
Comment 17 peter luttrell 2007-10-12 10:13:32 PDT
I believe this is a very usefull feature. Any chance we can get it into a release soon?
Comment 18 Rainer 2011-09-02 01:55:57 PDT
Hi I right now (2011) started using thunderbird (version 6.0) and I am exactly looking for the feature described here. If you have several IMAP accounts you really need thunderbird to show if there is new mail in one of the accounts without having manually to open the folder view each of the accounts in sequence.

The grouped folder view is close to but "no cigar" in that you see all your inboxes at one glance but the folders you wants to move a new mail to are still far away because the common folders are listes first. I tried it buts its not a real solution.

Another starting point was to configute thunderbird via userChrome.css so that the color of an imap account with new mail changes:

#folderTree > treechildren::-moz-tree-cell-text(isServer-true, biffState-NewMail) {
           color: red !important;
           font-weight: bold !important;
           }

This would be a good solution, but it only works in biff-way. So if there is new mail and you restart thunderbird, then afterwards there is still new unread mail but its not signaled in the color of the imap account any longer. 

I come from kmail where this feature has long been implemented and I really miss it.

Hope to see a solution in the next releases.

Thanks
Rainer
Comment 19 Andrew McNamara 2011-09-09 14:32:45 PDT
This was something recently requested by me as seen here: 

With what should be an easy codin job for a good coder I don't see why this hasn't been implemented yet when all it is is adding the inbox's unread message count next to the collapsed accounts name

Ex. (0) = No new msgs / (3) = 3 New messages etc. etc. etc.
Comment 20 Andrew McNamara 2011-09-09 16:24:19 PDT
Mistakingly forgot the link to the post I mentioned: http://forums.mozillazine.org/viewtopic.php?f=30&t=2301227
Comment 21 Jonah Bron 2012-05-22 11:54:32 PDT
Agreed, I wish this feature was present.  The unified folders view works pretty well though.
Comment 22 Travis Wood 2013-05-05 12:13:35 PDT
Created attachment 745677 [details] [diff] [review]
Added unread message count to collapsed folders
Comment 23 alta88 2013-05-06 07:43:22 PDT
you need to ask for review from a reviewer, someone like mconley.  (feedback should also be set to someone other than yourself ;)).
Comment 24 :aceman 2013-05-06 08:09:35 PDT
I think the patch also adds the count to any folder that has subfolders having unread messages. Is that really wanted?
I think adding totals summarizing subfolders without marking it is a summary, may confuse users.
Comment 25 Travis Wood 2013-05-08 11:02:41 PDT
Yes, it adds counts to folders that have subfolders having unread messages. However, the counts are only added if the folder is collapsed. It seems more natural to me that collapsed folders indicate the total sum of unread mails.

But the patch does certainly cover more than the bug reporter initially liked to fix.
Comment 26 Mike Conley (:mconley) - (Needinfo me!) 2013-05-25 14:55:01 PDT
Comment on attachment 745677 [details] [diff] [review]
Added unread message count to collapsed folders

Review of attachment 745677 [details] [diff] [review]:
-----------------------------------------------------------------

I like this change. Let's do it. Thanks Travis!
Comment 27 Ryan VanderMeulen [:RyanVM] 2013-05-28 10:18:13 PDT
https://hg.mozilla.org/comm-central/rev/0fdb5c1b0261
Comment 28 Lee_Dailey 2013-08-01 17:08:35 PDT
howdy y'all,

is there going to be a way to test for unread msgs via something like the code posted in comment 18?

i read thru the bug and didn't see any mention of that, so i am asking now. it would help if many of the properties for a normal folder were available at the account name level. especially things like (closed, subfoldersHaveUnreadMessages-true).

take care,
lee
Comment 29 Jim Klimov 2013-09-04 14:20:13 PDT
Hello, I believe this bug was recently fixed, and I wonder if it is related to a regression I see: since long ago and up to TB 17.0.8 my folders with unread messages (and accounts which had some unread messages) were highlighted in bold black and bold blue, respectively. 

Today I've updated to 24.0b2 seeking a fix for another bug, and all folder and account names are now in plain thin black. Individual messages are bold black, as they were.

Quite a mess really - despite having the numbers of unread messages (in the same font), it is not anymore easy to glance and see unread folders - you actually have to read the lines and look for numbers in parentheses.

My TB is connected to a dozen of IMAP accounts, no local accounts at all (if this matters).

I've tried to hack at a userChrome.css, and while I can change the style for individual messages, I can't influence folders. Perhaps the keyword was changed? I saw these two discussed in similar problems' context, but changing them did not fix a thing:

treechildren::-moz-tree-cell-text(hasUnreadMessages-true) { color: #f33 !important }
treechildren::-moz-tree-cell-text(subfoldersHaveUnreadMessages-true) { color: #f33 !important }

So, at the very least, can the fix for the "number of unread" issue be related to, or a cause of, the degradation I am seeing now? Or is it unrelated and another bug should be posted? Really, this should be repaired before the hyped new release ;)
Comment 30 Andrew McNamara 2013-09-04 17:10:40 PDT
This was never a bug as I understand it and never something that was patched / fixed. 

I can look at 20 of my accounts right now that have mail because their blue instead of black and have no (x) next to them for the undread count. This cound has and is only ever found next to things like the inboxx when the account tree is open.

So this is very much still something I'd like to see added. I mean for gods sake, freakin Hotmail has it on their damn mail program.
Comment 31 Jim Klimov 2013-09-04 23:19:41 PDT
@comment 30:

Andrew, which issue do you refer to as unfixed - (not) showing the number of unread messages in collapsed folders and accounts, or (not) highlighting such folders and accounts with bold colored font as I complained yesterday?
And which version of TB do you use?

To be clear, in TB 17.0.8 and all before it i had highlighting for folders and accounts with unread stuff, but counts were only for those folders which directly had unread messages. Collapsed tree items whose children had unread messages were highlighted but did not have number counts (x).

In TB 24.0b2 i have the opposite - numbering works, including collapsed items, but no highlighting in folder tree whatsoever.  To me this is a bad degradation.
Comment 32 Andrew McNamara 2013-09-05 15:15:02 PDT
http://www.dust514corps.com/gallery/1_05_09_13_6_11_53.bmp

Note the collapsed accounts that are blue, thus indicating they have mail but unread count unknown, like the opened account below that just has the new mail cound next to the inbox.

This new mail count inside the () bext to collapsed accounts is what I created a bug post about that I think was mered with this one. Thats the patch / fix I want to see that sooooo many other people want as well that seems to not even be an itch on anyones back to fix.
Comment 33 Andrew McNamara 2013-09-05 16:29:22 PDT
My apologies, someone pointed out via email I didnt specify version.

I have 17.0.8, everytime I check for updates I get a 17.x.x

Apparently what I said wasnt added is in some 24x branch so color me bewildered.
Comment 34 Andrew McNamara 2013-09-06 22:10:44 PDT
So I downloaded and am running the 24 beta version. I now see the message count on collapsed trees. But there's a "bug"... it's also adding the count from the trash bins.

So if you got 12 unread in your inbox and 34 unread in your trash then the count shown on the collapsed tree would be 46.
Comment 35 Magnus Melin 2013-09-07 03:26:43 PDT
Of course, if the mails in the trash are unread (which isn't really that common i'd think).
Comment 36 Andrew McNamara 2013-09-07 05:22:27 PDT
So you mark everything read before you delete it ?

I'm sorry but if this isnt a bug then its a joke lol.

Trash bin should be ignored, if unread messages were deleted then they should be ignored by the unread count on collapsed trees.
Comment 37 Magnus Melin 2013-09-07 10:57:51 PDT
Messages normally get marked read when you delete them. (Retested now on latest trunk and that's true both for pop and imap.) So i don't know why you would have unread in trash except if you manually mark them as unread there.
Comment 38 Andrew McNamara 2013-09-07 11:46:18 PDT
Maybe it has to do with the account tyoe them, the acounts used are those from my cPal / web hosting account. Will try with an AOL account an post back.
Comment 39 Andrew McNamara 2013-09-07 12:36:21 PDT
Thats what it is, non standard account types like AOL, gmail etc.

All mail accounts attached to my diff websites dont mark read before being deleted. That said, it still doesnt make sense to have the unread count from trash tally in the collapsed tree count.
Comment 40 Magnus Melin 2013-09-07 12:43:05 PDT
At least my gmail imap account does mark unread as read when deleting.
Comment 41 Jim Klimov 2013-09-07 12:48:25 PDT
I have unread deleted messages after remove duplicates action (addon?)
I might guess that use of the same imap by other clients (web, mobile) might also leave deleted or spam messages not marked read - done outside TB's control.
Comment 42 Jim Klimov 2013-09-09 01:44:04 PDT
Just in case FYI, I've created a separate bugreport for MY problem - with disappearance of colored bold highlighting of unread folders/accounts here: https://bugzilla.mozilla.org/show_bug.cgi?id=914055
Comment 43 Matthias Schoettle 2013-09-19 13:23:44 PDT
On a Gmail IMAP account it does, however, count Inbox + All Mail, which both refer to the same unread messages. So at least All Mail should be ignored, in my opinion.

In addition, it would be nice to have a preference that allows to disable showing this for users who don't need/want to see it. :)
Comment 44 Magnus Melin 2013-09-19 23:09:03 PDT
Please file ignoring All Mail when counting totals as a new bug.
Comment 45 Mark 2013-09-20 01:12:41 PDT
(In reply to Matthias Schoettle from comment #43)
> On a Gmail IMAP account it does, however, count Inbox + All Mail, which both
> refer to the same unread messages. So at least All Mail should be ignored,
> in my opinion.
> 
> In addition, it would be nice to have a preference that allows to disable
> showing this for users who don't need/want to see it. :)

With filtering rules and actually using the parent folders as a separate mail store to their subordinates, I got a real fright when my unread counts skyrocketed. I want the ability to see the unread messages in the folder (and not the subfolders) - i.e. the old functionality - at least by choice. Make it a global switch and/or make it available in the properties of a parent folder, maybe?
Comment 46 Vincent (caméléon) 2013-09-20 12:43:18 PDT
I have filed bug 918962 for the different problems listed above.
Comment 47 Magnus Melin 2015-01-24 02:56:12 PST
*** Bug 135092 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.