Closed Bug 1020952 Opened 5 years ago Closed 5 years ago

[vertical] context menu does not fit on vertical homescreen properly

Categories

(Firefox OS Graveyard :: Gaia::Homescreen, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.0+)

RESOLVED WORKSFORME
blocking-b2g 2.0+

People

(Reporter: zcampbell, Unassigned)

References

Details

(Whiteboard: [systemsfe])

Attachments

(1 file)

Attached image 2014-06-05-14-26-13.png
STR:
1. Long tap on homescreen space to bring up context menu


Device: Flame
Gaia      d2cfef555dabab415085e548ed44c48a99be5c32
Gecko     https://hg.mozilla.org/mozilla-central/rev/51b428be6213
BuildID   20140604235615
Version   32.0a1
ro.build.version.incremental=eng.cltbld.20140605.031251
ro.build.date=Thu Jun  5 03:13:01 EDT 2014
Looks like we're cutting off one of the two options here in the context menu.
blocking-b2g: --- → 2.0?
Whiteboard: [systemsfe]
Please, if this should be black, see implementation in bug 1020755
Blocks: 1019902
blocking-b2g: 2.0? → 2.0+
Duplicate of this bug: 1021332
I believe this is potentially a platform issue. I'm still having trouble reproducing this one, so if anyone has a solid STR I would appreciate it.
(In reply to Kevin Grandon :kgrandon from comment #4)
> I believe this is potentially a platform issue. I'm still having trouble
> reproducing this one, so if anyone has a solid STR I would appreciate it.

100% reproducible for me on a user build fresh out of the box. I can't reproduce it though on an eng build.
Kevin, I reported this using a tinderbox ui build (see original post).

However I also replicated it with a releng build from pvt, shallow gecko/gaia flashed using the TW-QA tool.

I also did make reset-gaia on top of the releng-built Gecko and I could also replicate it.

All 3 were engineering build.
Working on latest releng build:

Gaia      857129928b6e56a809cee9d5445effb8fa9f1c2c
Gecko     https://hg.mozilla.org/mozilla-central/rev/c8288d0c7a15
BuildID   20140606040202
Version   32.0a1
ro.build.version.incremental=eng.cltbld.20140605.031251
ro.build.date=Thu Jun  5 03:13:01 EDT 2014
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Ok, I think what happened is that we landed a fix two nights ago that was not in the user build from yesterday. This fix was in some shared framework code for gaia, and not in the vertical homescreen. I'll keep an eye on this going forward, but I think we are ok here. Thanks!
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.