If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Tarako][Call Waiting] No ringtone or alert occurs for another incoming call during an existing call

RESOLVED FIXED

Status

Firefox OS
Vendcom
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: rpribble, Assigned: Jason.Liu)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:1.3T+, b2g-v1.3 unaffected, b2g-v1.3T fixed)

Details

(Whiteboard: [tarako-exploratory], URL)

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8435084 [details]
Logcat.txt

Description:
If the user is in an existing call and receives another incoming call with call waiting enabled, the call will appear at the bottom of the screen but no ringtone or alert occurs to notify the user.  The user will not know that another call is being received until the DUT vibrates with the missed call notification.

Repro Steps:
1) Update device to BuildID: 20140602014001
2) Enable call waiting
3) Make a call from the DUT and establish a call connection
4) While connected on the previous call, make a call from another device to the DUT
5) Observe incoming call notification appear at the bottom of the screen on the DUT
   

Actual:
No ringtone or alert occurs. The user will not know that another call has been received until the device vibrates with the missed call notification.

Expected:
Ringtone plays or user hears beeping on the current call to signal that there is another call being received.

Environmental Variables:
Device: Tarako 1.3T
BuildID: 20140602014001
Gaia: 335486c42498fa7a93c21e4d6121199728602ab8
Gecko: 55e4d83019e5
Version: 28.1
Firmware Version: SP6821a-Gonk-4.0-4-29

Notes: Same issue as defined in bug 1000815.

Repro frequency: 100%
See attached: Logcat
blocking-b2g: --- → 1.3T?
Does this occur on 1.3?
Keywords: qawanted
(Reporter)

Comment 2

3 years ago
This issue does not occur on the Buri v1.3 MOZ ril.

v1.3 Environmental Variables:
Device: Buri v1.3 MOZ
BuildID: 20140529024024
Gaia: 5bd226b03a2d63dfe9df204f7c0afb9984e8fd42
Gecko: 42ef074f380f
Version: 28.0
Firmware Version: v1.2-device.cfg

User hears a rapid double beep in the current call to alert them to call waiting.

Note: Left audio on in the video to verify that no ringtone is heard during call waiting.
status-b2g-v1.3: --- → unaffected
(Reporter)

Updated

3 years ago
Keywords: qawanted
hi James, can your team provide some comment on this bug? thanks
Flags: needinfo?(james.zhang)
1.3T+
this should have worked before. could we possibly get regression window? thanks
blocking-b2g: 1.3T? → 1.3T+
Keywords: regression, regressionwindow-wanted
Assignee: nobody → Dafeng.Xu
Flags: needinfo?(james.zhang)
Assignee: Dafeng.Xu → sam.hua
Firmware Version: SP6821a-Gonk-4.0-4-29

Too old, please update pac to 5.12, we have fixed this issue.
Flags: needinfo?(rpribble)
(Reporter)

Comment 6

3 years ago
I rebased my Tarako to ensure that it was up-to-date (think I just input old variables previously, sorry!) and am still seeing the issue occur.

Environmental Variables:
Device: Tarako 1.3T
Build ID: 20140606014002
Gaia: 33025a8b1e458ef48cb8b7fb81bdaba28c86b183
Gecko: 161d4b0448c6
Version: 28.1 (1.3T) 
Firmware Version: SP6821a-Gonk-4.0-5-12

No ringtone or alert occurs. The user will not know that another call has been received until the device vibrates with the missed call notification.

User Agent String: Mozilla/5.0 (Mobile; rv:28.1) Gecko/28.1 Firefox/28.1
Flags: needinfo?(rpribble)
QA Contact: pcheng
This issue occurs on the earliest tinderbox engineering build (4/14) and on earliest nightly build (3/28) we have available. I also checked a build on 5/6 because supposedly the fix for bug 1000815 is included in the build, and issue still occurs. I don't think there is a regression here.
Keywords: regressionwindow-wanted

Updated

3 years ago
Keywords: regression
hi James, can you please check this bug again? base on comment 6, this bug still exist. thanks
Flags: needinfo?(james.zhang)
Ying, please track it. I have asked Peter.Huang to check modem issue.
Our system tester hasn't find this issue, but SQA and mozilla has filed bug.
Assignee: sam.hua → jason.liu
Flags: needinfo?(james.zhang)

Comment 10

3 years ago
Our QA and me both confirm this bug can not be reproduced with the latest build.

the version SP6821a-Gonk-4.0-5-12 is too old.

Please test it with the latest build.

Updated

3 years ago
status-b2g-v1.3T: affected → fixed

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.