[User Story] Support multiple search suggestion providers

RESOLVED DUPLICATE of bug 1098494

Status

Firefox OS
Gaia::Search
P2
normal
RESOLVED DUPLICATE of bug 1098494
4 years ago
3 years ago

People

(Reporter: benfrancis, Unassigned)

Tracking

({feature})

unspecified
feature

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.0 wontfix, b2g-v2.1 affected)

Details

(Whiteboard: [ucid:System206, ft:systemsfe][p=5])

User Story

As a user I want to choose who provides my search suggestions so that I can decide who gets to listen to all my keypresses in the Rocketbar

Interaction spec: https://mozilla.app.box.com/s/bb95jlbdk9l0robxluxc/1/1955330942/17810796514/1

Acceptance Criteria:
1. Choosing a specific search engine in the Settings (with Search Suggestions enabled) updates the provider of search suggestions while you type to match the chosen search engine.
(Reporter)

Description

4 years ago
As a user I want to choose who provides my search suggestions so that I can decide who gets to listen to all my keypresses in the Rocketbar

The search engine option in Settings allows you to choose your search provider, but suggestions are always provided by EverythingMe.

We already have suggestionUrlTemplates set in settings, we should use them!
(Reporter)

Updated

4 years ago
User Story: (updated)
(Reporter)

Updated

4 years ago
Assignee: nobody → bfrancis
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
User Story: (updated)
Whiteboard: [systemsfe][p=5] → [ucid:System206, ft:systemsfe][p=5]
Blocks: 946452
status-b2g-v2.0: --- → wontfix
status-b2g-v2.1: --- → affected
(Reporter)

Comment 1

4 years ago
I won't be working on this for a while
Assignee: bfrancis → nobody
feature-b2g: 2.1 → ---
Nice to have, but not a blocker. Blocking rocketbar-next so we have a concrete set of bugs to focus on.
Blocks: 1054414
No longer blocks: 946452
Priority: -- → P2
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1098494
(Assignee)

Updated

3 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog
You need to log in before you can comment on or make changes to this bug.