[User Story] Support search suggestion based on provider

RESOLVED FIXED in 2.2 S6 (20feb)

Status

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: wmathanaraj, Assigned: daleharvey)

Tracking

({feature})

unspecified
2.2 S6 (20feb)
Other
Other
Dependency tree / graph
Bug Flags:
in-moztrap +

Firefox Tracking Flags

(feature-b2g:2.2+, b2g-v2.0 affected, b2g-v2.0M affected, b2g-v2.1 affected, b2g-v2.2 affected)

Details

(Whiteboard: [systemsfe])

User Story

As a user I want to be given search suggestions based on my current search provider that I have selected so I can be sure where my input is being sent to.

Acceptance criteria:

1. Choosing a specific search engine in the Settings (with Search Suggestions enabled) updates the provider of search suggestions while you type to match the chosen search engine.

2. Be informed that every search press is being communicated to a external server

Attachments

(1 attachment)

Comment hidden (empty)
(Reporter)

Updated

5 years ago
User Story: (updated)
Keywords: feature
OS: All → Other
Hardware: All → Other
feature-b2g: --- → 2.2+
Whiteboard: [systemsfe]
Assignee: nobody → dale
Are we going to break down detailed engineering bugs for this user story? Thanks.
QA Whiteboard: [2.2-feature-qa+]
Does this user story have UX spec?
Flags: needinfo?(cserran)
Based on the information I got, the target milestone for this bug could be 2.2 Sprint 4. Please feel free to change it if I am wrong. Thank you very much.
Target Milestone: --- → 2.2 S4 (23jan)
QA Whiteboard: [2.2-feature-qa+] → [2.2-feature-qa+][COM=Gaia::Search]
Flags: in-moztrap?(hcheng)
According the user story description, I think this functionality does already exist. We can change the search engine in the Settings. I assume this story is about to change search engine directly in Rocketbar just like UX spec page 12 mentioned in Comment 4, right?

If my assumption is correct, I think the description should be updated then.
Flags: needinfo?(wmathanaraj)

Updated

4 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 6

4 years ago
We dont currently support suggestions coming from the search provider

One thing I will need is 1. a list of default supported search engines (currently specced are google, yahoo, bing, ddg), and an dev relations contact for the organisations, I can implement it first without from the looks of it, but before release we will want to make sure in case we need any special API keys etc
Flags: needinfo?(wmathanaraj)
(Assignee)

Updated

4 years ago
Depends on: 1117770
(Assignee)

Comment 7

4 years ago
Needinfo Peter for https://bugzilla.mozilla.org/show_bug.cgi?id=1098494#c6
Flags: needinfo?(pdolanjski)
(In reply to Dale Harvey (:daleharvey) from comment #6)
> We dont currently support suggestions coming from the search provider

Did you mean "Settings->Search->Search Suggestions" does not work currently?
But, it was defined in the 2.0 UX spec, and as the attached screen shot, I can see the FTE reminding for search suggestions.

> 
> One thing I will need is 1. a list of default supported search engines
> (currently specced are google, yahoo, bing, ddg), and an dev relations
> contact for the organisations, I can implement it first without from the
> looks of it, but before release we will want to make sure in case we need
> any special API keys etc

There is another bug (1117970) related to search engine and it is about what I asked in comment #5.
(In reply to Dale Harvey (:daleharvey) from comment #6)
> We dont currently support suggestions coming from the search provider
> 
> One thing I will need is 1. a list of default supported search engines
> (currently specced are google, yahoo, bing, ddg), and an dev relations
> contact for the organisations, I can implement it first without from the
> looks of it, but before release we will want to make sure in case we need
> any special API keys etc

Dale, those are the ones that we'd want.  Mike Connor would be your man.
Flags: needinfo?(pdolanjski) → needinfo?(mconnor)
With the exception of Bing, no keys required.  You should be able to piece this together from the mobile search plugins, let me know if that's not clear.

I'd be happy to review whatever URL you choose, there may be tweaks (i.e. nresults for Yahoo) that are worth applying for the OS context.
Flags: needinfo?(mconnor)
(Assignee)

Updated

4 years ago
Depends on: 1119515
(Assignee)

Comment 11

4 years ago
Cheers Mike, yeh I found all the desktop plugins which is a huge help

Last thing, Eric, we need some visuals for this, the magnifying glass icon and I am guessing the suggestions will be a little more styled? Do you know whos best to ping to get them? the UX spec is https://bugzilla.mozilla.org/show_bug.cgi?id=1098494#c4

Cheers
Flags: needinfo?(epang)
I'd recommend using the mobile versions, as there are some small differences in some cases.  I'll also note that for DDG/Bing/others we use distinct partner codes so we can accurately cover billing.  And Yahoo is... special right now, so please ping me for review on that.
(In reply to Dale Harvey (:daleharvey) from comment #11)
> Cheers Mike, yeh I found all the desktop plugins which is a huge help
> 
> Last thing, Eric, we need some visuals for this, the magnifying glass icon
> and I am guessing the suggestions will be a little more styled? Do you know
> whos best to ping to get them? the UX spec is
> https://bugzilla.mozilla.org/show_bug.cgi?id=1098494#c4
> 
> Cheers

Hey Dale,

You can find the visual spec here on box:
https://mozilla.box.com/s/gpijv051aeivyoxcz72a

and by the way if you are looking for other specs you should be able to find this on this etherpad, hope this helps!
https://etherpad.mozilla.org/SFE-Spec-Locations
 
Let me know if you have any questions, thanks!
Flags: needinfo?(epang)
Note: I think this a duplicate of bug 1021779, feel free to dupe it either way.
(Assignee)

Updated

4 years ago
Duplicate of this bug: 1021779
(Assignee)

Updated

4 years ago
Depends on: 1119820

Updated

4 years ago
Blocks: Woodduck
(Assignee)

Updated

4 years ago
Depends on: 1125131
(Assignee)

Updated

4 years ago
Depends on: 1117970
Target Milestone: 2.2 S4 (23jan) → 2.2 S5 (6feb)

Updated

4 years ago
No longer blocks: Woodduck, Woodduck_Blocker
Target Milestone: 2.2 S5 (6feb) → 2.2 S6 (20feb)
(Assignee)

Comment 17

4 years ago
Closing out meta bug since functionality is landed, now working bug by bug and one non functional follow up (https://bugzilla.mozilla.org/show_bug.cgi?id=1125131)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
No longer depends on: 1132353
Test run to sign off v2.2 Feature Landing

***Test Summary***
4 test cases ran, 2 passed, 2 failed (Bug 1133432 & Bug 1131966)

***Test Run record***
https://moztrap.mozilla.org/runtests/run/6448/env/27835/?pagenumber=1&pagesize=20&sortfield=order&sortdirection=asc&filter-tag=3084

***Build Info***
Build ID               20150215162503
Gaia Revision          ea64caf6d4ab03fc4472eca9f41f20d651d55fa9
Gaia Date              2015-02-13 05:27:43
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/62c80c92b39e
Gecko Version          37.0a2
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150215.195540
Firmware Date          Sun Feb 15 19:55:51 EST 2015
Bootloader             L1TC000118D0
You need to log in before you can comment on or make changes to this bug.