Closed Bug 1022022 Opened 8 years ago Closed 8 years ago

[B2G][Vertical Homescreen] Orientation can be changed after a phone restart by opening and closing the Rocketbar

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 verified, b2g-v2.1 verified)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- verified

People

(Reporter: astole, Assigned: alive)

References

()

Details

(Whiteboard: [p=1][systemsfe])

Attachments

(2 files, 1 obsolete file)

Attached file logcat
After a fresh restart, the device's homescreen orientation can be changed after opening and closing the e.me search bar. If an app is opened, the device's homescreen is locked in portrait orientation and works as expected.

Repro Steps:
1) Update a Flame to BuildID: 20140606040202
2) From a fresh restart or reset, tap on the e.me search bar
3) Close the search bar
4) Rotate the device

Actual:
The homescreen orientation changes from portrait to landscape

Expected:
The homescreen stays locked in portrait orientation

2.0 Environmental Variables:
Device: Flame 2.0 MOZ
BuildID: 20140606040202
Gaia: 857129928b6e56a809cee9d5445effb8fa9f1c2c
Gecko: c8288d0c7a15
Version: 32.0a1
Firmware Version: v10G-2

Repro frequency: 100%, 2/2
See attached: logcat, video
This issue also occurs on 2.0 on Buri. 

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140606040202
Gaia: 857129928b6e56a809cee9d5445effb8fa9f1c2c
Gecko: c8288d0c7a15
Version: 32.0a1
Firmware Version: v1.2-device.cfg
Summary: [B2G][Homescreen]The device's homescreen orientation can be changed after opening and closing the e.me search bar → [B2G][Vertical Homescreen]The device's homescreen orientation can be changed after opening and closing the e.me search bar
Blocks: 1015336
QA Whiteboard: [VH-FL-blocking-]
Summary: [B2G][Vertical Homescreen]The device's homescreen orientation can be changed after opening and closing the e.me search bar → [B2G][Vertical Homescreen] Orientation can be changed after a phone restart by opening and closing the Rocketbar
Whiteboard: [systemsfe]
I thought this was a duplicate of bug 1021468 at first. It was fixed yesterday but you've found an edge case. Good catch!
Attached file Github pull request (obsolete) —
Alive -  got time for a review?

I'm a bit confused here though, I thought having orientation: default in the manifest would accomplish this, locking it was the only thing that seemed to work.
Assignee: nobody → kgrandon
Status: NEW → ASSIGNED
Attachment #8436560 - Flags: review?(alive)
Whiteboard: [systemsfe] → [systemsfe],[p=1]
Target Milestone: --- → 2.0 S3 (6june)
Comment on attachment 8436560 [details] [review]
Github pull request

We should not do this :/ Please fix it in system app.
If you don't know how please assign to me.
Attachment #8436560 - Flags: review?(alive) → review-
Attachment #8436560 - Attachment is obsolete: true
Ok, might be able to look at this tomorrow. Unassigning for now.
Assignee: kgrandon → nobody
Target Milestone: 2.0 S3 (6june) → 2.0 S4 (20june)
QA Whiteboard: [VH-FL-blocking-] → [VH-FL-blocking-][VH-FC-blocking+]
Duplicate of this bug: 1023429
UX - The impact of this bug causes the homescreen to render in horizontally. Is this a blocker from your perspective?
Flags: needinfo?(firefoxos-ux-bugzilla)
The root cause is the search app which lives in searchWindow has no orientation specified.
So opened it causes the orientation be unlocked but nobody reset the orientation when its closed.
Assignee: nobody → alive
Proposed fix: reset orientation when search window is closing.
Attachment #8438244 - Flags: review?(timdream)
Yes, UX would block, for my $.02.
Flags: needinfo?(firefoxos-ux-bugzilla)
Thank you for taking this alive. I think your fix is appropriate.
Marked as 2.0? blocker as bad UX.
blocking-b2g: --- → 2.0?
Attachment #8438244 - Flags: review?(timdream) → review+
Component: Gaia::Homescreen → Gaia::System::Window Mgmt
Whiteboard: [systemsfe],[p=1] → [p=1]
https://github.com/mozilla-b2g/gaia/commit/86174e824af843bd90a9d6ca9a5213dcaf82efe2
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Comment on attachment 8438244 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/20340

This is required for the vertical homescreen. We've done our best effort at testing and believe the tree will remain green with uplift.
Attachment #8438244 - Flags: approval-gaia-v2.0?(bbajaj)
blocking-b2g: 2.0? → 2.0+
Attachment #8438244 - Flags: approval-gaia-v2.0?(bbajaj) → approval-gaia-v2.0+
I flashed my Flame to your commit with a production build and I'm still reproducing the issue. What about you Alive?

Here are more detailed STR:
1) Flash the Flame.
2) Go through FTU.
3) Tap rocketbar.
4) Don't share your position.
5) Tap close on the rocketbar.
6) Rotate the device to landscape mode.

Build Info
Gaia      86174e824af843bd90a9d6ca9a5213dcaf82efe2
Gecko     https://hg.mozilla.org/mozilla-central/rev/9e8e3e903484
BuildID   20140612040203
Version   33.0a1
ro.build.version.incremental=104
ro.build.date=Fri Jun  6 17:35:09 CST 2014
Flags: needinfo?(alive)
Whiteboard: [p=1] → [p=1][systemsfe]
Bug 1024947 has also been filed. Let's use it to catch the regression.
Flags: needinfo?(alive)
See Also: → 1024947
It's okay on master. Bug 1024947 has also been verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.