Closed Bug 1022879 Opened 7 years ago Closed 7 years ago

[B2G][NFC] Deleted contacts are still being sent and received through NFC

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:2.0+, b2g-v2.0 fixed, b2g-v2.1 fixed)

VERIFIED FIXED
2.0 S4 (20june)
blocking-b2g 2.0+
Tracking Status
b2g-v2.0 --- fixed
b2g-v2.1 --- fixed

People

(Reporter: KTucker, Assigned: arcturus)

References

Details

(Whiteboard: [2.0-flame-test-run-1][p=2])

Attachments

(3 files)

Attached file SendingDevice.txt
Description:
Deleted contacts are still being sent and received through NFC. 

Repro Steps:
1)  Updated Flame to Build ID: 20140609040203
2)  Turn on NFC on two test phones.
3)  On phone A, create 5 contacts.
4)  Delete 3 of the contacts that were just created on phone A.
5)  Bumped the two phones together while on the main contact's page.
6)  On phone A, swipe up to send phone B contacts.
7)  Check the contacts received on phone B. 

Actual:
Phone B receives 5 contacts including the deleted contacts. 

Expected:
Deleted contacts are not sent or received through NFC. 

Environmental Variables
Device: Flame v 2.0 Moz
Build ID: 20140609040203
Gecko: https://hg.mozilla.org/mozilla-central/rev/9305a8ec77fe
Gaia: 12af93123c5db55212d51fe235d39f21209a1eaa
Platform Version: 32.0a1
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0

Notes:
Repro frequency: 100%
Link to failed test case: None. Found through exploratory testing. 
See attached: video clip, logcat

Cannot provide logcat from the Open C or Buri since NFC does not work on either device. Attached a Flame logcat but please see this issue: https://bugzilla.mozilla.org/show_bug.cgi?id=1010993
This issue does not reproduce on the Buri 1.4 or Buri 2.0:

2.0 Environmental Variables:
Device: Buri 2.0 MOZ
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e0387ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0


Buri 1.4

1.4 Environmental Variables:
Device: Buri 1.4 MOZ
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: v1.2-device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

The issue cannot be reproduce on the Buri because it is not a NFC capable device.


This issue does not occur on the Flame 1.4, base v10G-2 or base v10f-3:

Flame 1.4

1.4 Environmental Variables:
Device: Flame 1.4
BuildID: 20140530000202
Gaia: fe612fd21389193a8e593aa718831602e5086a62
Gecko: 25011f9a8f26
Version: 30.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0

Flame Base v10G-2

1.3 Environmental Variables:
Device: Flame 1.3
BuildID: 20140520094859
Gaia: a73235d23685e9898f40647cebd83b3fcbfd0117
Gecko: Unknown
Version: 28.0
Firmware Version: v10G-2
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0

Flame Pre-Base v10f-3

1.3 Environmental Variables:
Device: Flame 1.3
BuildID: 20140505215459
Gaia: ec462dc62979dae593b4ad96ac3851ccbafe1813
Gecko: Unknown
Version: 28.0
Firmware Version: v10F-3

The phones vibrate when bumped together but the user cannot send any files using NFC.


This issue does not occur on the Open C 2.0:

Open C 2.0

2.0 Environmental Variables:
Device: Open C 2.0
BuildID: 20140530040207
Gaia: 26d8fcab9b61f46451600f39c51e03
87ef3c4f88
Gecko: e6f113c83095
Version: 32.0a1
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

NFC is not an available option in settings on Open C.
Youtube video can be found here: http://youtu.be/Eg9G8RFDhU8
Alison - Can you triage this & weigh in on the severity of this bug from a NFC perspective?
Flags: needinfo?(ashiue)
I think this bug must to be fixed in 2.0. Furthermore, we should not show shrinking UI on contacts list page.
blocking-b2g: --- → 2.0?
Flags: needinfo?(ashiue)
NFC Product review - must fix for 2.0
blocking-b2g: 2.0? → 2.0+
(In reply to Sandip Kamat from comment #6)
> NFC Product review - must fix for 2.0

Is the 2.0 fix to not send deleted contacts, or not show shrinking UI when viewing the main contacts list, per comment #5?
Flags: needinfo?(skamat)
(In reply to Dietrich Ayala (:dietrich) from comment #7)
> (In reply to Sandip Kamat from comment #6)
> > NFC Product review - must fix for 2.0
> 
> Is the 2.0 fix to not send deleted contacts, or not show shrinking UI when
> viewing the main contacts list, per comment #5?

I was referring to sending deleted contacts. That should not happen, so needs fixed.

Alison, I am not sure what you are referring to in comment #5? I do not see that in the attached video.
Flags: needinfo?(skamat) → needinfo?(ashiue)
Julien, do you know why deleted contacts are still present in this scenario?
Flags: needinfo?(felash)
I don't know how contacts are sent through NFC, so I don't know if the issue would be in the API or in the Contacts app or somewhere else.

Francisco, do you know?
Flags: needinfo?(felash) → needinfo?(francisco)
Hi folks,

totally felt out of my scope, since the component wasn't contacts.

Moving it to the contacts component, and taking care of that 2.0+

Thanks guys!
Component: NFC → Gaia::Contacts
Flags: needinfo?(francisco)
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Whiteboard: [2.0-flame-test-run-1] → [2.0-flame-test-run-1][p=2]
Target Milestone: --- → 2.0 S4 (20june)
We cannot share the whole contact list, nfc is activated only in Details view. My guess will be that we somehow don't call contacts.NFC.stopListening() when removing contact.
After taking a look to the video, I think the problem could be related to the fact that we were not updating before the current contact once selected.

We landed recently bug 1015060, to deal with sending the wrong data, and this looks like a similar problem, not about data itself but the whole selected contact to share.

One thing that comes to my mind seeing the video, is that we shouldn't be able to share any contact (ghost or not) if we are in the contact list, the NFC sharing feature is just available when you are in the contact detail.

Probably we are not detaching the NFC listener when we delete a contact. Will follow that path to tackle this issue.

Thanks folks!
(In reply to Michał Budzyński (:michalbe) from comment #12)
> We cannot share the whole contact list, nfc is activated only in Details
> view. My guess will be that we somehow don't call
> contacts.NFC.stopListening() when removing contact.

Exaclty, cause when we remove a contact whe are in the form, not in detail. So will need to check as well there.
Attached file Pointer to pr 20621
Fixing, when we delete a contact and nfc is present, disable the nfc listener.
Attachment #8441416 - Flags: review?(mbudzynski)
Comment on attachment 8441416 [details] [review]
Pointer to pr 20621

I hate patches where I have nothing to comment on - I feel useless when reviewing them :).
Anyway - great job Francisco, tested on the device (Flame -> Nexus), all the tests passed, r+.
Attachment #8441416 - Flags: review?(mbudzynski) → review+
Landed on master:

https://github.com/arcturus/gaia/commit/cee9baae6bd6fbc7f4eccd5ff5c6b0d60f67e437
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Verified on
Gaia      23e06c3624309db22ad9cb736d89700768b42b36
Gecko     https://hg.mozilla.org/releases/mozilla-aurora/rev/12161a842a8e
BuildID   20140618160200
Version   32.0a2
Status: RESOLVED → VERIFIED
Flags: needinfo?(ashiue)
You need to log in before you can comment on or make changes to this bug.