Closed Bug 1023524 Opened 8 years ago Closed 2 years ago

Windows-specific HiDPI changes

Categories

(Firefox :: General, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 820679

People

(Reporter: Dolske, Unassigned)

References

Details

(Keywords: meta)

Bug 1023511 and bug 1023517 cover a lot of HiDPI theme work that either already exists in the OS X theme (for Retina), or soon will.

But there are other changes that will be needed on Windows, for things that don't exist or don't apply to other platforms.

From a survey of our current UI on Windows, this roughly includes:

 - Page Info section icons
 - Full-screen mode window widgets (extreme upper-right)
 - Application icon in the taskbar
 - Image assets in the installers
   - large panel images in the stub installer
   - regular installer left-side image and icon.

A few things that may be platform bugs, or that I didn't see specifically covered in the Retina work:

 - Twisty arrows in <tree> expanders (eg in bookmarks sidebar)
 - The arrow in menuitems with a submenu is hidpi but really tiny. But I also
   saw this in some native Windows apps. Not sure if this is expected, or just
   a bug with Windows 7's incomplete HiDPI support?

Finally, we should probably have a UX review for any other desired HiDPI theme changes. As a specific example, I noticed that Windows apps tend to frequently use superfine borders (1 physical pixel) in various places (like scrollbars and textfields), whereas most of our Retina UI has retained using 1 CSS pixel (== 2 physical pixels, consistent with other OS X stuff, but not Chrome).
If you need a QA guinea pig I have a HiDPI Windows 8.1 device.
Flags: firefox-backlog+
Depends on: 1188171
Depends on: 1339799
Depends on: 1289061
No longer depends on: 1339799
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: win-hidpi
You need to log in before you can comment on or make changes to this bug.