Closed Bug 1023511 Opened 7 years ago Closed 2 years ago

Bring Windows HiDPI theme support up to parity with existing OS X work.

Categories

(Firefox :: Theme, defect)

x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 820679

People

(Reporter: Dolske, Unassigned)

References

Details

(Keywords: meta)

Our HiDPI support on OS X (Retina) is pretty decent, and so as a first step for our Windows HiDPI support we should get it up to parity with that. Patches from existing bugs can serve as a template (mainly bug 781327 and bug 817366).

Roughly this work covers:

  - main icon sheet (Toolbar.png)
  - Australis tabs and Customization UI
  - doorhanger icons
  - identity/ssl indicators
  - media controls
  - arrowpanel arrow
  - lots of random icons and tiny widgety glyphs

Note that there will soon be ongoing work in the deps of bug 1016548 ("Finish OS X HiDPI support for Firefox front-end"), and so in a few cases there is a bit of overlap because the current OS X implementation is incomplete.

Also note that we need to figure out the implementation plan for HiDPI on Windows (bug 1023488) before diving into this work.
Depends on: australis-tabs-v2
Depends on: 1023600
Depends on: 1023604
Depends on: 1023607
Flags: firefox-backlog+
Depends on: 1147702
Depends on: 1181548
Depends on: 1181541
Depends on: 1181514
Duplicate of this bug: 1166442
Depends on: 1219746
Depends on: 1246126
Depends on: 1258310
No longer depends on: 1246126
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: win-hidpi
You need to log in before you can comment on or make changes to this bug.