Closed Bug 1023939 Opened 6 years ago Closed 6 years ago

"restart to update" from 29.0.1 to 30.0 fails

Categories

(Firefox :: General, defect)

33 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1035400

People

(Reporter: me, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Go to Firefox "About Firefox" dialog and click on "Restart to Update" button


Actual results:

Nothing


Expected results:

Browser should have restarted after 30.0 release installed.
I note that this is the behaviour on Mac 10.9.3 (FF 29.0.1) and also Windows 7 (FF 29.0.1).
OS: Windows 7 → All
This sounds like a temporary problem with the update channel. Do you still reproduce it ?
Flags: needinfo?(me)
Yeah they both seem to have been resolved yesterday - so updates worked for both Win7 and OSX 10.9.3.
Flags: needinfo?(me)
Somebody else is reporting this problem on IRC now.
QA Whiteboard: [bugday-20140616]
Component: Untriaged → Application Update
Product: Firefox → Toolkit
It's still happening for that person.

Robert, do you have an idea?
Flags: needinfo?(robert.strong.bugs)
I don't. If this is about the button in the ui not restarting then an error is likely reported to the error console.
Flags: needinfo?(robert.strong.bugs)
See related Bug 1087489.
I'm now getting this same issue on Win 8.1 x64 FF33.1.1
(In reply to Duro from comment #8)
> I'm now getting this same issue on Win 8.1 x64 FF33.1.1

It didn't appear to be an issue on Mac 10.9.5 FF33.1.1
Version: 29 Branch → 33 Branch
On Win 8.1. x64 FF33.1.1 I was just prompted with an external dialog to update to FF34.0.5 - this seems to have resolved the problem with updating from the About screen
I'm observing the same problem, on the beta channel. Trying to update from 35 to 36. Closed FF entirely, start it back up and problem still exists. Even restarting in safe mode (no addons) has same results. Using Win 8.1 x64.
This appears to be bug 1035400
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1035400
Component: Application Update → General
Product: Toolkit → Firefox
You need to log in before you can comment on or make changes to this bug.