"restart to update" from 29.0.1 to 30.0 fails

RESOLVED DUPLICATE of bug 1035400

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 1035400
4 years ago
3 years ago

People

(Reporter: Duro, Unassigned)

Tracking

33 Branch
x86_64
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140506152807

Steps to reproduce:

Go to Firefox "About Firefox" dialog and click on "Restart to Update" button


Actual results:

Nothing


Expected results:

Browser should have restarted after 30.0 release installed.
(Reporter)

Comment 1

4 years ago
I note that this is the behaviour on Mac 10.9.3 (FF 29.0.1) and also Windows 7 (FF 29.0.1).
OS: Windows 7 → All
This sounds like a temporary problem with the update channel. Do you still reproduce it ?
Flags: needinfo?(me)
(Reporter)

Comment 3

4 years ago
Yeah they both seem to have been resolved yesterday - so updates worked for both Win7 and OSX 10.9.3.
Flags: needinfo?(me)

Comment 4

4 years ago
Somebody else is reporting this problem on IRC now.
QA Whiteboard: [bugday-20140616]
Component: Untriaged → Application Update
Product: Firefox → Toolkit

Comment 5

4 years ago
It's still happening for that person.

Robert, do you have an idea?
Flags: needinfo?(robert.strong.bugs)
I don't. If this is about the button in the ui not restarting then an error is likely reported to the error console.
Flags: needinfo?(robert.strong.bugs)

Comment 7

3 years ago
See related Bug 1087489.
(Reporter)

Comment 8

3 years ago
I'm now getting this same issue on Win 8.1 x64 FF33.1.1
(Reporter)

Comment 9

3 years ago
(In reply to Duro from comment #8)
> I'm now getting this same issue on Win 8.1 x64 FF33.1.1

It didn't appear to be an issue on Mac 10.9.5 FF33.1.1
Version: 29 Branch → 33 Branch
(Reporter)

Comment 10

3 years ago
On Win 8.1. x64 FF33.1.1 I was just prompted with an external dialog to update to FF34.0.5 - this seems to have resolved the problem with updating from the About screen

Comment 11

3 years ago
I'm observing the same problem, on the beta channel. Trying to update from 35 to 36. Closed FF entirely, start it back up and problem still exists. Even restarting in safe mode (no addons) has same results. Using Win 8.1 x64.
This appears to be bug 1035400
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1035400
Component: Application Update → General
Product: Toolkit → Firefox
You need to log in before you can comment on or make changes to this bug.