"restart to update" button not working. Prevents users from manually updating when the full update ui needs to be displayed (e.g. incompatible add-ons).

RESOLVED FIXED in Firefox 36

Status

()

defect
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: warner, Assigned: hectorz)

Tracking

({regression})

31 Branch
Firefox 38
x86
macOS
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite ?

Firefox Tracking Flags

(firefox35 affected, firefox36+ fixed, firefox37 fixed, firefox38 fixed)

Details

Attachments

(1 attachment)

I'm not sure when exactly this started happening, but I've noticed that my FF31 (beta)'s "Restart to Update" button (accessed via menu, Firefox > About Firebox) isn't working. I click on the button, but nothing happens.

I *think* that I was prompted to update about an hour ago (the full-size popup that occurs when a new beta version is available), and I chose "Ask Later" instead of "update now". I'm thinking that this put my browser into a state where the menu-reachable "Restart to Update" button stopped working. The last time this happened, I remember restarting my browser, but that didn't resolve the problem. I'll try to reproduce that now. I think I had to wait until the subsequent version update appeared before it started working again.
Yeah, restarting the browser doesn't fix the problem: the "Restart to Update" button still does nothing. I don't see any relevant error messages in the Browser Console. My (Prefs > Advanced > Update) setting is "check for updates, but let me choose".
This is happening on my FF30.
This is happening on my FF30 release channel, restart to update button does nothing.  Deleting all files in the C:\Users\username\AppData\Local\Mozilla\updates does nothing. Downloading Firefox Setup Stub 31.0.exe and installing, updates successfully.
hello all who's reading.

i had similar problem today. 

Steps what i did to cause this 8i'm unsure that those are right steps what actually causing this )

1) Make sure there is Firefox update available
2) Download that update. If it stat saying "restart to update, don't click it.
3) close Firefox. upper right corner X , kill the process etc
4) Launch some older Aurora build. Lets say august 15th, you can pick
5) Update aurora , when it say's Restart to update the do it
6) Close aurora
7) Start Firefox again
8) go to Help>about Firefox
9) after clicking the "restart to update" u see that the button doesn't have any effect any more.

ps: If those reproducing steps doesn't work , them I'm extremely sorry for spamming.
sorry for spam

what i forgot to tell was that i used same profile for both builds.
Component: General → Application Update
Product: Firefox → Toolkit
I have this issue as well.  I have tried restarting in safe mode, but the update button still doesn't work.  I'm on Windows 7 Enterprise 64-bit, running release channel Firefox 31.

Perhaps this is relevant: if I have the Browser Console window open when I open the About Mozilla Firefox window to see if an update is available, this shows up after the spinner stops:

1409787428946	addons.update-checker	WARN	Update manifest for {BBDA0591-3099-440a-AA10-41764D9DB4DB} did not contain an updates property
Try the following:
Type about:config in the url bar
Click the button to accept
Paste the following in the search bar devtools.errorconsole.enabled
Toggle the value to true (can be done by double clicking or via the context menu)
Restart

Before you click the restart button the next time open Tools -> Web Developer -> Error Console and click the clear button. Leave the console open and click the restart button. Report in this bug anything that is displayed in the error console.
After enabling the error console, restarting, and showing the error console, I get: exactly the same behaviour.  I get the same warning after the spinner stops, but no additional messages when clicking the Restart to Update button.
Could you try installing an add-on that is not listed as NO RESTART
https://addons.mozilla.org/en-US/firefox/extensions/

Open the add-ons manager and click the restart button for the add-on?
Clicking the restart button in the add-ons area restarted the browser, but I was still at Firefox 31 when it came back up. And going to the About box showed the same behaviour as before.

I should note that one thing I am not seeing is any indication of the download happening.  While there is a spinner that runs for a bit, don't you usually see how big the update is, and how far along you are?  Anyway, not seeing that now.
The 'Restart to Update' Button in the about box of Firefox 31.0 does not work.
Please open the context menu on the Firefox application bundle under Applications. Select "Show Package Contents". Navigate to the Contents/MacOS/updates/0/ directory. If present, attach the update.status file to this bug.
I am getting the same while trying to update from Firefox 31.0 to 32.0. On clicking the button "Update to 32.0", it immediately changes to "Restart to Update" (it appeared almost as if it never even downloaded the update). Clicking "Restart to Update" now doesn't evoke any response. I'm running Windows 8 64-bit.
Same issue here; Firefox 33.0 Win8 x64; beta channel.

Was prompted to update but I dismissed the message as the update fails if Firefox is not running as Administrator. Re-ran Firefox as Administrator, went to Help->About as I usually do to update, the Restart to Update button doesn't do anything
Happened also to my update to 33.0.  Last time it happened it was my 30.0 to 31.0
I think now this issue resolved yesterday I was able to update to 33.0 using the "restart to update' button in the about box
Flags: needinfo?(varunaseneviratna)
Bug still exists when updating from 33.1 to 34  (in Windows 7)

No information in 'Error console'
New to bugzilla here.  My restart button also does not work.  Win 7 64-bit Enterprise.  Firefox 33.1.1 to 34.  Please let me know if I can help fix.
Thanks,
Same problem here trying to update ver 33.1.1 on a Win 7 home (x64) platform today.  Also tried safe mode and disabling anti-virus without benefit.  Updated by manually navigating to Mozilla Firefox web page, which detected that I was already using FF, and downloading the update stub.  At that point, all went as expected.  This was the first time I ever encountered this bug despite numerous trouble-free updates in the past.
Same as in comment #19. The difference is that I'm using Windows 7 Pro.
I am using Firefox 33.1.1 on Win7 (x64) Professional. This Problem occurs while I want to upgrade to FF 34. The "Restart to Update" just do nothing.

Close and re-open the Firefox doesn't help.
There is C:\Users\<User>\AppData\Local\Mozilla\updates\E7CF176E110C211B and the files dated in that directory are dated 2014-11-25. IMO, that's the date 33.1.1 was released.

If I remove that directory, and then go into about dialog.. it's starts to check for new updates, and then displays the Restart to update button, but nothing happens.
Looking at the update directory the subdir \E7CF176E110C211B is created however now it's empty.
(In reply to Miha Vrhovnik from comment #23)
> There is C:\Users\<User>\AppData\Local\Mozilla\updates\E7CF176E110C211B and
> the files dated in that directory are dated 2014-11-25. IMO, that's the date
> 33.1.1 was released.
> 
> If I remove that directory, and then go into about dialog.. it's starts to
> check for new updates, and then displays the Restart to update button, but
> nothing happens.
> Looking at the update directory the subdir \E7CF176E110C211B is created
> however now it's empty.

It seems to be the problem of the update server of Mozilla. No any update file is downloaded although the Firefox can detect the update exists. https://bugzilla.mozilla.org/show_bug.cgi?id=1035400#c17 also report that he/she can update again but doesn't said what have been done before.
Same problem here - Win7Pro 64bit, Firefox 33.1, Help > About says there is an update, offers 'Restart to update' button, pressing it does nothing...
Can anyone explain why this bug is still set to 'NEEDINFO'?
What kind of info is needed?
I might be able to check if i can collect this info.......
Firefox 33.1.1 Same problem, clicking on restart to update does nothing.

C:\Users\<User>\AppData\Local\Mozilla\updates\E7CF176E110C211B is there
active-update.xml remains with an empty node <updates />
Generating manually the update url from the app.update.url gives:
https://aus3.mozilla.org/update/3/Firefox/33.1.1/20141113143407/WINNT_x86-msvc/en-US/release/Windows_NT%206.1.1.0%20%28x64%29/default/default/update.xml?force=1
and both URL in the response gives a valid download of a .mar file with the right size.
This is probably not an update server problem.
Same here. FF 33.1.1 to 34 ... can't update as "restart to update" doesn't do anything - nor has anything been downloaded/updated as a manual restart of FF doesn't go to 34 either.
:-(
It updated on me today. Which seems that this really was an server issue? Aka missing update form 33.1.1? to 34.0.x?
For those still having this problem i found a solution, do this,

1) Open appdata, Run=>appdata=>Enter.
2) Delete Local\Mozilla\updates, and rename Local\Mozilla and Roaming\Mozilla to Mozillabak.
3) Start firefox, try to update, CLOSE firefox when it starts downloading.
4) Copy Local\Mozilla\updates folder to someplace else.
5) Rename back Local\Mozillabak and Roaming\Mozillabak to Mozilla
6) Paste back updates folder copied in step 4 to Local\Mozilla\
7) Start firefox and update it should work now
hmm, seven steps to remember.......
than this 1 step is shorter, and works too:
1) visit: https://www.mozilla.org/en-US/firefox/all/

The question remains why there is a button which does not work for what it was designed to do......
(In reply to luuk34 from comment #31)
> hmm, seven steps to remember.......
> than this 1 step is shorter, and works too:
> 1) visit: https://www.mozilla.org/en-US/firefox/all/
> 
> The question remains why there is a button which does not work for what it
> was designed to do......

Most probably due to something corrupt in firefox data or settings....since it works as soon as we eliminate them.
Posted patch PatchSplinter Review
Seems to be a regression from bug 600500.

When some extensions don't have compatible updates for new version of Firefox, clicking the button would open chrome://mozapps/content/update/updates.xul, but do nothing after bug 600500.
Assignee: nobody → bzhao
Status: NEW → ASSIGNED
Attachment #8548764 - Flags: review?(felipc)
Blocks: 600500
Happened on my 34 to 35.  Hasn't happened since my 32 to 33 update so really hit and miss.
Flags: needinfo?(warner-bugzilla)
Comment on attachment 8548764 [details] [diff] [review]
Patch

Review of attachment 8548764 [details] [diff] [review]:
-----------------------------------------------------------------

Looks right to me, but I'll let Robert double check
Attachment #8548764 - Flags: review?(robert.strong.bugs)
Attachment #8548764 - Flags: review?(felipc)
Attachment #8548764 - Flags: feedback+
Comment on attachment 8548764 [details] [diff] [review]
Patch

LGTM and thanks!
Attachment #8548764 - Flags: review?(robert.strong.bugs) → review+
[Tracking Requested - why for this release]:
This prevents users from manually updating when the full update ui needs to be displayed (e.g. incompatible add-ons).
Flags: needinfo?(varunaseneviratna)
Thanks! I pushed this to try and will request checkin later:

https://treeherder.mozilla.org/ui/#/jobs?repo=try&revision=d984aae2e178
https://hg.mozilla.org/integration/fx-team/rev/a9240b1eb2fb

Any way to test this?
Flags: in-testsuite?
Keywords: checkin-needed
Whiteboard: [fixed-in-fx-team]
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #41)
> https://hg.mozilla.org/integration/fx-team/rev/a9240b1eb2fb
> 
> Any way to test this?
Per Bug 1100346 comment #17 tests are being created though I don't know if it is for this scenario. Ideally I'd be given time to work on bug 599574 which would include tests but I have been told other work is a higher priority.
https://hg.mozilla.org/mozilla-central/rev/a9240b1eb2fb
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla38
Duplicate of this bug: 1100346
Keywords: regression
Note: this bug is actually in the Firefox about window code so fixing component
Component: Application Update → General
Product: Toolkit → Firefox
Target Milestone: mozilla38 → ---
Target Milestone: --- → Firefox 38
Comment on attachment 8548764 [details] [diff] [review]
Patch

Approval Request Comment
[Feature/regressing bug #]: Bug 600500
[User impact if declined]: This prevents users from manually updating when the full update ui needs to be displayed (e.g. incompatible add-ons).
[Describe test coverage new/current, TreeHerder]: Manually tested
[Risks and why]: Minimal. The change is for a code path that is currently broken so it definitely shouldn't make things worse and the manual testing shows that it fixes this bug.
[String/UUID change made/needed]: None
Attachment #8548764 - Flags: approval-mozilla-beta?
Attachment #8548764 - Flags: approval-mozilla-aurora?
I experienced the bug myself and it is a pain... Tracking.
Attachment #8548764 - Flags: approval-mozilla-beta?
Attachment #8548764 - Flags: approval-mozilla-beta+
Attachment #8548764 - Flags: approval-mozilla-aurora?
Attachment #8548764 - Flags: approval-mozilla-aurora+
Is it possible to take this in Fx 35.0.1? For users already on Fx 35.0, they will no longer be affected when they upgrade from Fx 35.0.1+ to 36.0.
Hector, can this wait for 36?
We have this bug for a while and 35.0.1 is currently building.
Flags: needinfo?(bzhao)
(In reply to Sylvestre Ledru [:sylvestre] from comment #52)
> Hector, can this wait for 36?
> We have this bug for a while and 35.0.1 is currently building.

This bug will not affect users during a minor version update, release it with Fx 35.0.1 will have the benefit of fixing the bug silently for users currently on Fx 35.0, users on Fx 34 or earlier will still be affected.

So if there're enough users already upgraded to Fx 35.0, I think it's better to take this.
Flags: needinfo?(bzhao)
Since we have this bug since firefox 30, I am not sure to see the rush here. Anything changed?
Flags: needinfo?(bzhao)
(In reply to Sylvestre Ledru [:sylvestre] from comment #54)
> Since we have this bug since firefox 30, I am not sure to see the rush here.
> Anything changed?

It's not urgent, but releasing this fix with a minor version update will reduce the numbers of affected users.

Without it in Fx 35.0.1, users with:
Fx 35.0 or earlier =(affected)=> Fx 35.0.1 =(affected)=> Fx 36.0

With it in Fx 35.0.1, users with:
Fx 35.0 =(same major version, not affected)=> Fx 35.0.1 =(fixed)=> Fx 36.0
Fx 34.0.5 or earlier =(affected)=> Fx 35.0.1 =(fixed)=> Fx 36.0

I understand this bug will not affect every user, so I'm not sure if the improvement is worth the effort of a build 2. Thanks for the consideration.
Flags: needinfo?(bzhao)
Summary: "restart to update" button not working → "restart to update" button not working. Prevents users from manually updating when the full update ui needs to be displayed (e.g. incompatible add-ons).
You need to log in before you can comment on or make changes to this bug.