Disable the in-content preferences for Firefox 32

VERIFIED FIXED in Firefox 32

Status

()

defect
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: jaws, Assigned: jaws)

Tracking

Trunk
Firefox 32
Points:
---
Dependency tree / graph
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox31 unaffected, firefox32 verified, firefox33 wontfix)

Details

(Whiteboard: p=1 s=33.1 [qa!])

Attachments

(1 attachment)

The preferences were enabled by bug 738797 but they weren't ready to ship in 32. We should disable them on Aurora 32.
Flags: firefox-backlog?
Posted patch PatchSplinter Review
https://tbpl.mozilla.org/?tree=Try&rev=cf26f9c4880c
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8438706 - Flags: review?(bmcbride)
Comment on attachment 8438706 [details] [diff] [review]
Patch

Review of attachment 8438706 [details] [diff] [review]:
-----------------------------------------------------------------

Don't ship it!
Attachment #8438706 - Flags: review?(bmcbride) → review+
Comment on attachment 8438706 [details] [diff] [review]
Patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): we are delaying shipping in-content prefs until firefox 33 (see bug 1014201)
User impact if declined: in-content prefs will be shipped to users with 32 and it's not ready in 32
Testing completed (on m-c, etc.): locally, pushed to try, simple pref flip
Risk to taking this patch (and alternatives if risky): none expected
String or IDL/UUID changes made by this patch: none
Attachment #8438706 - Flags: approval-mozilla-aurora?
Flags: firefox-backlog? → firefox-backlog+
Marco, can you please add this bug to the current iteration?
Flags: needinfo?(mmucci)
Attachment #8438706 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Added to Iteration 33.1
Flags: needinfo?(mmucci)
Whiteboard: p=1 [qa+] → p=1 s=33.1 [qa+]
https://hg.mozilla.org/integration/fx-team/rev/bd48de0a468d
Keywords: checkin-needed
Whiteboard: p=1 s=33.1 [qa+] → p=1 s=33.1 [qa+][fixed-in-fx-team]
sorry had to back this change out since it caused test regressions like https://tbpl.mozilla.org/php/getParsedLog.php?id=41942658&tree=Fx-Team
This wasn't even supposed to land on mozilla-central / fx-team.
Whiteboard: p=1 s=33.1 [qa+][fixed-in-fx-team] → p=1 s=33.1 [qa+]
I wasn't sure between status-firefox32:fixed or status-firefox32:disabled, considering that this 'disabled' the feature for 32 but the point of fixing the bug is to disable the feature. Consider me confused.

https://hg.mozilla.org/releases/mozilla-aurora/rev/67c27d331c7f
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #9)
> I wasn't sure between status-firefox32:fixed or status-firefox32:disabled,
> considering that this 'disabled' the feature for 32 but the point of fixing
> the bug is to disable the feature. Consider me confused.

Ok, to finish my conversation with myself, this is the right thing. I have updated bug 738797 to mark as status-firefox32:disabled.
Hi Florin, can a contact be assigned for QA verification.
Flags: needinfo?(florin.mezei)
Target Milestone: --- → Firefox 32
I've verified this on Windows, Mac OS and Linux:
- Aurora from June 18 shows in-content preferences
- Aurora from June 19 shows old preferences window
Custom preferences are kept when moving from a version with new in-content preferences to latest version with old preferences style.
Status: RESOLVED → VERIFIED
Flags: needinfo?(florin.mezei)
QA Contact: camelia.badau
Whiteboard: p=1 s=33.1 [qa+] → p=1 s=33.1 [qa!]
You need to log in before you can comment on or make changes to this bug.