Closed Bug 738797 Opened 8 years ago Closed 6 years ago

Enable the in-content preferences by default

Categories

(Firefox :: Preferences, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 32
Tracking Status
firefox31 --- unaffected
firefox32 --- disabled

People

(Reporter: jaws, Assigned: jaws)

References

(Depends on 1 open bug)

Details

(Whiteboard: p=3 s=it-32c-31a-30b.2 [qa!] )

Attachments

(1 file, 1 obsolete file)

This bug should also enable browser.preferences.instantApply for all platforms.
Assignee: nobody → saylesd1
Status: NEW → ASSIGNED
If we choose to set document.documentElement.instantApply = true (as part of bug 733473 and mentioned in https://bugzilla.mozilla.org/show_bug.cgi?id=733473#c49), then we won't need to enable the pref here.
Assignee: saylesd1 → nobody
Actually, it looks like the instantApply pref does need to be enabled.  Otherwise, subdialogs won't save their changes after you click OK.  See bug 566444 comment #6 and #7.
Depends on: 872957
Whiteboard: p=0
No longer depends on: 872957
Depends on: 989287
No longer depends on: 989287
No longer blocks: fxdesktopbacklog
Flags: firefox-backlog+
Whiteboard: p=0 → p=1
Attached patch Patch (obsolete) — Splinter Review
I think we are now ready to enable the in-content preferences by default. Bug 993339 seems to be the last bug that was on file that resulted in incomplete behavior by the in-content preferences, and that bug is now fixed. The remaining bugs deal with styling issues and subtle tweaks to the new design.

Enabling it early in the 32 cycle will allow us to get wider testing and more attention towards shipping in the release channel.
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Attachment #8416968 - Flags: review?(bmcbride)
Comment on attachment 8416968 [details] [diff] [review]
Patch

Review of attachment 8416968 [details] [diff] [review]:
-----------------------------------------------------------------

Holy rusted metal, Batman!
Attachment #8416968 - Flags: review?(bmcbride) → review+
Backed out for timing out browser_experiments.js, browser_datareporting_notification.js, and browser_offlineQuotaNotification.js.

https://hg.mozilla.org/integration/fx-team/rev/f7b600b772be
Whiteboard: p=1 [fixed-in-fx-team] → p=1
Blocks: 1005811
Attached patch Patch v1.1Splinter Review
Had to fix browser_offlineQuotaNotifications to not run the test when in-content prefs are enabled. It already had a todo, but the todo started the test and then never cleaned up after itself. Bug 881576 is already on file to get this test working with in-content prefs.
Attachment #8416968 - Attachment is obsolete: true
Attachment #8418358 - Flags: review+
Backed out again because my try push didn't foresee a test timeout, will need to investigate more.

https://hg.mozilla.org/integration/fx-team/rev/0f055fd37e18
Whiteboard: p=3 [fixed-in-fx-team] → p=3
Whiteboard: p=3 → p=3 s=it-32c-31a-30b.2
Whiteboard: p=3 s=it-32c-31a-30b.2 → p=3 s=it-32c-31a-30b.2 [qa?]
Whiteboard: p=3 s=it-32c-31a-30b.2 [qa?] → p=3 s=it-32c-31a-30b.2 [qa+]
https://hg.mozilla.org/integration/fx-team/rev/25fa9e0e5b06
Whiteboard: p=3 s=it-32c-31a-30b.2 [qa+] → p=3 s=it-32c-31a-30b.2 [qa+] [fixed-in-fx-team]
Please fix Bug 908534 before shipping this!


(New preferences looks like the normal web page page.
 I think this is possibility phishing. )
Depends on: 1010618
sorry had to back this out in https://tbpl.mozilla.org/?tree=Fx-Team&rev=9ec1824900eb since one of this 2 patches seems to caused frequent memory leaks like:

https://tbpl.mozilla.org/php/getParsedLog.php?id=39711492&tree=Fx-Team

which is in retrigger frequent to permanent
Whiteboard: p=3 s=it-32c-31a-30b.2 [qa+] [fixed-in-fx-team] → p=3 s=it-32c-31a-30b.2 [qa+]
Try push: https://tbpl.mozilla.org/?tree=Try&rev=466ff66e63c2

Relanded with the leak fixed: https://hg.mozilla.org/integration/fx-team/rev/5513627d6190
Whiteboard: p=3 s=it-32c-31a-30b.2 [qa+] → p=3 s=it-32c-31a-30b.2 [qa+] [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/5513627d6190
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: p=3 s=it-32c-31a-30b.2 [qa+] [fixed-in-fx-team] → p=3 s=it-32c-31a-30b.2 [qa+]
Target Milestone: --- → Firefox 32
Sorry for spaming resolved bug but this one https://bugzilla.mozilla.org/show_bug.cgi?id=795764 suppose be also fixed, I was hit with circumstances of this bug today on Latest Nightly, took me one hour to find workaround and after this I plan to fill new bug but it is already filled, but looks like forgotten.

Confirmed also here: http://forums.mozillazine.org/viewtopic.php?f=23&t=2834651
Depends on: 1012453
Depends on: 1012474
No longer depends on: 1012474
QA Contact: camelia.badau
Verified fixed on Windows 7 64bit, Windows 8 32bit, Ubuntu 13.10 32bit and Mac OSX 10.8.5 using latest Nightly 32.0a1 (buildID: 20140519030202).
Status: RESOLVED → VERIFIED
Whiteboard: p=3 s=it-32c-31a-30b.2 [qa+] → p=3 s=it-32c-31a-30b.2 [qa!]
Depends on: 1023967
Depends on: 1043586
Depends on: 1127737
Depends on: 1393448
You need to log in before you can comment on or make changes to this bug.