e10s windows in firefox-gtk3 v33 display elements in a quarter (1/4th) of the window

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
Last year

People

(Reporter: kxra, Unassigned)

Tracking

33 Branch
x86_64
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(e10s-)

Details

Attachments

(1 attachment)

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:33.0) Gecko/20100101 Firefox/33.0 (Beta/Release)
Build ID: 20140612121001

Steps to reproduce:

Open e10s window (see screenshot for side-by-side of e10s vs normal)


Actual results:

everything takes up only a quarter of the window, but the mouse/cursor maps to the elements as if they filled the entire window


Expected results:

should look the same as non-e10s window
Reporter

Updated

5 years ago
Blocks: core-e10s, e10s, gtk3
In addition to the size issue, the screenshot on the right seems to show graphics have been scaled by a factor of 2, interpolating from the resolution at which they were drawn.
Reporter

Comment 2

5 years ago
that's due to the fact that I have a HiDPI screen (Yoga 2 pro), and potentially that is the thing that is not working properly in the e10s window
Component: Untriaged → Layout
Product: Firefox → Core

Updated

5 years ago
Blocks: 1034064

Updated

5 years ago
No longer blocks: 1034064
Reporter

Comment 3

5 years ago
In the main (not gtk3) firefox 33, e10s windows simply don't show anything at all. The cursor changes according to whether it is hovering above text, a link, etc, but the window is empty.
Reporter, do you still see this? The latest trunk (nightly) gtk3 works fine for me with e10s, it starts as quarter of the window but it's reshaped immediately after start.
Flags: needinfo?(kxra)
Status: UNCONFIRMED → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(kxra)
You need to log in before you can comment on or make changes to this bug.