Closed Bug 1026116 Opened 5 years ago Closed 5 years ago

[B2G][2.0][Flame][Vertical Homescreen] Overscrolling is not enabled.

Categories

(Firefox OS Graveyard :: Gaia, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v2.0 verified, b2g-v2.1 unaffected)

VERIFIED FIXED
2.0 S4 (20june)
Tracking Status
b2g-v2.0 --- verified
b2g-v2.1 --- unaffected

People

(Reporter: ychung, Assigned: botond)

References

()

Details

(Whiteboard: [2.0-flame-test-run-2][systemsfe])

Attachments

(2 files)

Description:
The icons and search bar do not overscroll when the user flicks up/down twice to enable flywheel scrolling. The overscrolling option on the developer menu is NOT enabled on v.2.0

Pre-requisite: Have multiple (about 30) icons on the homescreen.

Repro Steps:
1) Update a Buri to 20140616063005.
2) Flick up twice to enable flyweel scrolling.
3) Flick down twice to enable flyweel scrolling.
4) Verify that the icons and search bar overscroll. 

Actual:
The search bar at the top of homescreen and the icons at the bottom do NOT overscroll.

Expected:
The search bar and icons at the top and bottom of the screen overscroll when the user enable flywheel scrolling.

Environmental Variables:
Device: Flame 2.0
Build ID: 20140616000203
Gaia: a6988c15b361938bea5976c846c147ecdc1121c0
Gecko: 52a276202888
Version: 32.0a2 (2.0) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0 

Notes: Overscrolling on the developer menu is not enabled by default on v.2.0. However, it IS enabled by default on v.2.1.

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/13073/ 
https://moztrap.mozilla.org/manage/case/13074/
See attached: logcat, YouTube link
(Logcat is used on Open C. See https://bugzilla.mozilla.org/show_bug.cgi?id=1010993)

----------------------------------------------------------------------------------------------------
The issue does NOT occur on Flame v.2.1:

Environmental Variables:
Device: Flame 2.1 - Master
Build ID: 20140616040202
Gaia: dfc4703bb81d1fa4f2087a1a6124b47a80a5d1de
Gecko: 80431d4fd0da
Version: 33.0a1 (2.1 - Master) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:33.0) Gecko/33.0 Firefox/33.0

Note: On v.2.1, overscrolling is enabled on the devleoper meny by default.

------------------------------------------------------------------------------------------------------
This issue DOES occur on Open C v.2.0:

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140612000201
Gaia: 2bb66630315299ca947e40fcec23c9f7ea012111
Gecko: 670d69879f0e
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------------------------------------------
This issue DOES occur on Buri v.2.0:

Environmental Variables:
Device: Buri 2.0
Build ID: 20140616063005
Gaia: a6988c15b361938bea5976c846c147ecdc1121c0
Gecko: f2413cf1965e
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Can UX clarify that this is definitely a bug & not expected behavior?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage?][VH-FL-blocking?][VH-FC-blocking?]
Flags: needinfo?(firefoxos-ux-bugzilla)
Whiteboard: [2.0-flame-test-run-2]
Flagging Rob on overscroll behavior (though we'll be reviewing this soon).
Flags: needinfo?(firefoxos-ux-bugzilla) → needinfo?(rmacdonald)
And I'll actually flag Gord on this one. Thanks!
Flags: needinfo?(rmacdonald) → needinfo?(gbrander)
You need to leave a comment with your 1.4 environmental variables and the reason why this issue does not occur on 1.4. Also, the 1.4 tracking flag should have been left alone and not changed to unaffected since this is not a regression. The feature didn't exist on 1.4.
QA Whiteboard: [QAnalyst-Triage?][VH-FL-blocking?][VH-FC-blocking?] → [QAnalyst-Triage-][VH-FL-blocking?][VH-FC-blocking?]
Flags: needinfo?(ktucker)
Flags: needinfo?(ychung)
This feature did not exist prior to v.2.0. Unable to verify v.1.4, v.1.3.

This issue DOES occur on Open C v.2.0. The icons and search bar do not overscroll when the user flicks up/down twice to enable flywheel scrolling. 

Environmental Variables:
Device: Open_C 2.0
Build ID: 20140612000201
Gaia: 2bb66630315299ca947e40fcec23c9f7ea012111
Gecko: 670d69879f0e
Version: 32.0a2 (2.0)
Firmware Version: P821A10V1.0.0B06_LOG_DL
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
-----------------------------------------------------------------------------------------------------
This issue DOES occur on Buri v.2.0. The icons and search bar do not overscroll when the user flicks up/down twice to enable flywheel scrolling. 

Environmental Variables:
Device: Buri 2.0
Build ID: 20140616063005
Gaia: a6988c15b361938bea5976c846c147ecdc1121c0
Gecko: f2413cf1965e
Version: 32.0a2 (2.0) 
Firmware Version: v1.2device.cfg
User Agent: Mozilla/5.0 (Mobile; rv:32.0) Gecko/32.0 Firefox/32.0
QA Whiteboard: [QAnalyst-Triage-][VH-FL-blocking?][VH-FC-blocking?] → [QAnalyst-Triage?][VH-FL-blocking?][VH-FC-blocking?]
Flags: needinfo?(ktucker)
Flags: needinfo?(ychung)
This sounds like a bug. I do not have these devices to repro, but overscroll should be enabled.
Flags: needinfo?(gbrander)
As per 2.0 vertical homescreen specs, it is a bug (https://bug989848.bugzilla.mozilla.org/attachment.cgi?id=8424225)

Regression window wanted on 2.0 branch.
QA Whiteboard: [QAnalyst-Triage?][VH-FL-blocking?][VH-FC-blocking?] → [QAnalyst-Triage?][VH-FL-blocking+][VH-FC-blocking+]
Marked as 2.0? blocker since it's a regression.
blocking-b2g: --- → 2.0?
Whiteboard: [2.0-flame-test-run-2] → [2.0-flame-test-run-2][systemsfe]
QA Whiteboard: [QAnalyst-Triage?][VH-FL-blocking+][VH-FC-blocking+] → [QAnalyst-Triage?][VH-FL-blocking-][VH-FC-blocking+]
Blocks: 1015336
No longer blocks: vertical-homescreen
Component: Gaia::Homescreen → Panning and Zooming
Product: Firefox OS → Core
The gaia patch to enable the pref (see bug 1020045 comment 12) isn't in 2.0. Somebody should uplift that.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: apz-overscroll
No longer blocks: 1015336
blocking-b2g: 2.0? → ---
QA Whiteboard: [QAnalyst-Triage?][VH-FL-blocking-][VH-FC-blocking+] → [QAnalyst-Triage?]
Apparently I can't set approval-gaia-v2.0 on patches that are in bugs that are not in the Gaia component. So we might as well put this bug to good use.
Component: Panning and Zooming → Gaia
Product: Core → Firefox OS
Comment on attachment 8441350 [details] [review]
PR that needs uplifting to 2.0

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): new feature
[User impact] if declined: overscroll will not be enabled in 2.0
[Testing completed]: it's enabled on master
[Risk to taking this patch] (and alternatives if risky): low risk, enables a feature that we can easily disable if needed
[String changes made]: none
Attachment #8441350 - Flags: approval-gaia-v2.0?
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #9)
> The gaia patch to enable the pref (see bug 1020045 comment 12) isn't in 2.0.
> Somebody should uplift that.

I did not ask for uplift because I was under the impression that the value in gecko/b2g/chrome/content/settings.js [1], which was flipped in the Gecko patch (which was uplifted), overrides the value in gaia/build/config/common-settings.json. I guess I was wrong. I'm still rather confused about the proliferation of places where the pref value is specified...

I'm not sure how to request uplift of a Gaia patch, but I'm happy to do so if someone points me to how.

[1] http://dxr.mozilla.org/mozilla-central/source/b2g/chrome/content/settings.js#653
(In reply to Botond Ballo [:botond] (away until July 5) from comment #13)
> I'm not sure how to request uplift of a Gaia patch, but I'm happy to do so
> if someone points me to how.

Ah, you've just done it (and now I see how!) - thanks!
Going to reopen this to track an uplift of the overscrolling patch.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Flags: needinfo?(jlorenzo)
Keywords: verifyme
Comment on attachment 8441350 [details] [review]
PR that needs uplifting to 2.0

Johan can you please help with verification once this lands 2.0? Thanks for the help!
Attachment #8441350 - Flags: approval-gaia-v2.0? → approval-gaia-v2.0+
Please include the environmental variables for the Flame 1.4 and state why the issue did not reproduce even if the feature did not exist.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage-]
Flags: needinfo?(ktucker) → needinfo?(ychung)
This feature did not exist prior to v.2.0. Unable to Reproduce on v.1.4:

Environmental Variables:
Device: Flame 1.4
Build ID: 20140616000202
Gaia: 164644d91290708a71436dfdf4301e33b92e2c77
Gecko: 2949e8bef869
Version: 30.0 (1.4) 
Firmware Version: v121-2
User Agent: Mozilla/5.0 (Mobile; rv:30.0) Gecko/30.0 Firefox/30.0
Flags: needinfo?(ychung) → needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage-] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][lead-review+]
Actually RyanVM said we can also just set checkin-needed on the bug, which might be clearer in this case.
Status: RESOLVED → REOPENED
Keywords: checkin-needed
Resolution: FIXED → ---
Looks like Vivien merged the PR already.
v2.0: https://github.com/mozilla-b2g/gaia/commit/2766e53ec6d4e268128adac6066345f18dcd871b
Assignee: nobody → botond
Status: REOPENED → RESOLVED
Closed: 5 years ago5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → 2.0 S4 (20june)
(In reply to Ryan VanderMeulen [:RyanVM UTC-4][PTO June 19-22] from comment #21)
> Looks like Vivien merged the PR already.
> v2.0:
> https://github.com/mozilla-b2g/gaia/commit/
> 2766e53ec6d4e268128adac6066345f18dcd871b

Ugh, I'm clearly not caffeinated enough yet today. That was the master landing from bug 1020045.
v2.0: https://github.com/mozilla-b2g/gaia/commit/8e883abdfe32bbbc3934513b4f7cbc0dd7ae3c49
Overscroll is now on 2.0.
Status: RESOLVED → VERIFIED
Flags: needinfo?(jlorenzo)
You need to log in before you can comment on or make changes to this bug.