Add eBay logo to search plugin so about:newtab can use it

VERIFIED FIXED in Firefox 31

Status

()

Firefox
Search
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: adw, Assigned: adw)

Tracking

Trunk
Firefox 33
Points:
1
Bug Flags:
firefox-backlog +

Firefox Tracking Flags

(firefox30 unaffected, firefox31+ verified, firefox32+ verified, firefox33+ verified)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Joanne, in bug 1006203 comment 17 you wrote:

(In reply to Joanne Nagel from bug 1006203 comment #17)
> Just found the email from eBay that approved the images that Boriss had
> setup.

Joanne, Borris, does that refer to the images that Boriss posted to bug 962490 comment 34?  If so, I'll land those.
(Assignee)

Comment 1

4 years ago
Joanne, please see comment 0.
Flags: needinfo?(jnagel)
(Assignee)

Comment 2

4 years ago
Borris, please see comment 0.
Flags: needinfo?(jboriss)

Comment 3

4 years ago
Has this been resolved or do you still  need something from me?
Flags: needinfo?(jnagel)
(In reply to Joanne Nagel from comment #3)
> Has this been resolved or do you still  need something from me?

If Joanne is happy with the images in bug 1006203 comment #17, then we should feel free to use that.
Flags: needinfo?(jboriss)
(Assignee)

Comment 5

4 years ago
Created attachment 8446000 [details] [diff] [review]
patch

For the record, we verified over email that the answer to comment 0 is Yes.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Attachment #8446000 - Flags: review?(MattN+bmo)
(Assignee)

Updated

4 years ago
Iteration: --- → 33.2
Points: --- → 1
QA Whiteboard: [qa+]
status-firefox30: --- → unaffected
status-firefox31: --- → affected
status-firefox32: --- → affected
tracking-firefox31: --- → ?
tracking-firefox32: --- → ?
tracking-firefox33: --- → ?
(Assignee)

Comment 6

4 years ago
Marco, could we add this to the current iteration, please?
Flags: needinfo?(mmucci)
Comment on attachment 8446000 [details] [diff] [review]
patch

I verified the image and data format.
Attachment #8446000 - Flags: review?(MattN+bmo) → review+
(Assignee)

Updated

4 years ago
Flags: firefox-backlog+
Added to Iteration 33.2
Flags: needinfo?(mmucci)
https://hg.mozilla.org/mozilla-central/rev/b39fe6bc207b
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 33
(Assignee)

Comment 11

4 years ago
Comment on attachment 8446000 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 962490 added a search field to about:newtab and landed on 31.  The logo of the currently selected search engine, if available, appears to the left of the search field.

User impact if declined:
When eBay is the currently selected engine, its logo will not appear.  about:newtab gracefully handles missing logos, though.

Testing completed (on m-c, etc.):
manual testing, automated testing on m-c

Risk to taking this patch (and alternatives if risky):
very low

String or IDL/UUID changes made by this patch:
none
Attachment #8446000 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 12

4 years ago
Created attachment 8446629 [details] [diff] [review]
Beta patch

Bug 1002777 landed on 32 and changed eBay.xml, which made the m-c/Aurora patch not apply cleanly to Beta.

[Approval Request Comment]
Bug caused by (feature/regressing bug #):
Bug 962490 added a search field to about:newtab and landed on 31.  The logo of the currently selected search engine, if available, appears to the left of the search field.

User impact if declined:
When eBay is the currently selected engine, its logo will not appear.  about:newtab gracefully handles missing logos, though.

Testing completed (on m-c, etc.):
manual testing, automated testing on m-c

Risk to taking this patch (and alternatives if risky):
very low

String or IDL/UUID changes made by this patch:
none
Attachment #8446629 - Flags: approval-mozilla-beta?
status-firefox33: --- → fixed
tracking-firefox31: ? → +
tracking-firefox32: ? → +
tracking-firefox33: ? → +
Attachment #8446000 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Attachment #8446629 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Verified that the eBay logo is correctly displayed on Firefox 31 beta 6, Aurora 32.0a2 and Nightly 33.0a1 2014-06-29 on about:newtab page under Win 7 64-bit, Ubutnu 12.10 32-bit and Mac OSX 10.9.3
Status: RESOLVED → VERIFIED
QA Whiteboard: [qa+] → [qa!]
status-firefox31: fixed → verified
status-firefox32: fixed → verified
status-firefox33: fixed → verified
You need to log in before you can comment on or make changes to this bug.