TB 31 beta 1 - Scrollbar partially hidden behind Lightnings Todays pane

RESOLVED FIXED in 3.3

Status

defect
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: Mikeyy, Assigned: Paenglab)

Tracking

Lightning 3.3
x86_64
Windows 7
Dependency tree / graph

Details

Attachments

(2 attachments)

TB 31 beta 1 - croatian locale
Lightning 3.3b1

Message pane scroolbar is partially hidder behind Lightnings todays pane.
Attached picture which explains it better.
Blocks: TB31found
Oh, it doesn't affect just scroolbar. It affects whole hight of todays pane and every elements left from it. Not really sure if it's calendar or Thunderbird bug.
Could you try this without a theme? Does it work with en-US?
The thick splitter looks like a manifest problem in lightning. I'll check this this evening with TB 31b and Lightning 3.3b.
I see no problem here with different Lightning locales. But I don't see a HR candidate. From where do you use this? Please can you attach this here, then I can check it here?
Flags: needinfo?(mihovil.stanic)
Lightning is an all-locales package and includes hr, so just use the Croatian Thunderbird from http://www.mozilla.org/en-US/thunderbird/all-beta.html and the combined Lightning from the Development Channel in https://addons.mozilla.org/en-US/thunderbird/addon/lightning/
Flags: needinfo?(mihovil.stanic)
Component: Untriaged → General
Product: Thunderbird → Calendar
Target Milestone: --- → 3.3
Version: 31 → Lightning 3.3
This happens only with LWThemes enabled.

This patch lifts the selector's specifiity to apply after the selector for XP (http://mxr.mozilla.org/comm-central/source/calendar/lightning/themes/windows/lightning.css#21) on Vista/W7/W8.

I checked OS X and Linux and it's only a Win specific bug.
Assignee: nobody → richard.marti
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #8441567 - Flags: review?(philipp)
Attachment #8441567 - Flags: approval-calendar-beta?(philipp)
Attachment #8441567 - Flags: approval-calendar-aurora?(philipp)
Comment on attachment 8441567 [details] [diff] [review]
noLWThemeSplitter.patch

Review of attachment 8441567 [details] [diff] [review]:
-----------------------------------------------------------------

Richard, thanks for the quick patch. r/a=philipp
Attachment #8441567 - Flags: review?(philipp)
Attachment #8441567 - Flags: review+
Attachment #8441567 - Flags: approval-calendar-beta?(philipp)
Attachment #8441567 - Flags: approval-calendar-beta+
Attachment #8441567 - Flags: approval-calendar-aurora?(philipp)
Attachment #8441567 - Flags: approval-calendar-aurora+
Keywords: checkin-needed
As Richard said, it only shows with theme enabled.
Todays pane stays in same place, but it actually "expands" few pixels on the left which covers UI elements.
Duplicate of this bug: 1027104
Summary: TB 31 beta 1 - Scroolbar partially hidden behind Lightnings Todays pane → TB 31 beta 1 - Scrollbar partially hidden behind Lightnings Todays pane
You need to log in before you can comment on or make changes to this bug.