Closed Bug 1026394 Opened 8 years ago Closed 8 years ago

TB 31 - On new message compose windows, contacts autocomplete isn't working properly

Categories

(Thunderbird :: Message Compose Window, defect)

31 Branch
x86_64
Windows 7
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 966053

People

(Reporter: Mikeyy, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

TB 31 beta 1

LDIF contact example, extracted from my addressbook:
dn: cn=Tester Lastname, Tester Test,mail=testing@domain.com
objectclass: top
objectclass: person
objectclass: organizationalPerson
objectclass: inetOrgPerson
objectclass: mozillaAbPersonAlpha
givenName: Tester Test
sn: Tester Lastname
cn: Tester Lastname, Tester Test
mail: testing@domain.com
modifytimestamp: 0


Reproduce:
1. Compose new message
2. Enter "tester" in first To: field
3. You will get autocomplete suggestion for "tester Lastname, Tester Test <testing@domain.com>"
4. Press ENTER

Expected: Contact will be in first To: field
Result: Contact was splitted into 2 contacts, first one being contact last name, and second one his first name + email address.
If I try to send email now, I get error saying:
"Invalid RFC821 mailbox specification.. Check mail receiver "tester Lastname" and try again."

Picture attached.
Blocks: TB31found
I forget who was working on the autocomplete issues, but this sounds similar to the one we had for normal autocomplete.
This should be a dupe of bug 966053.
Keywords: regression
Absolutely this is a serious issue and needs swift resolution. (I'm seeing something like this myself) But blocker in bugzilla means blocks developer work, so is a bit too strong for this issue.
Severity: blocker → major
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 966053
You need to log in before you can comment on or make changes to this bug.