FF29 can't login into bugzilla.novell.com

RESOLVED DUPLICATE of bug 1025703

Status

()

Toolkit
Password Manager
RESOLVED DUPLICATE of bug 1025703
3 years ago
3 years ago

People

(Reporter: promeneur, Unassigned)

Tracking

30 Branch
Points:
---

Firefox Tracking Flags

(firefox30 affected, firefox33 affected)

Details

(URL)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 2014050900

Steps to reproduce:

opensuse 13.1 x86_64
ff 29.0.1
there is no id and pwd recorded for bugzilla.novell.com in ff wallet

i go to bugzilla.novell.com
then
i fill the id and pwd
then
again site displays the template to fill id and pwd

same experiment with chromium => no pb
Hi,

thanks for taking time to report a problem.

Does this happen only on the mentioned website (bugzilla.novell.com) or you have the same problem with other sites while doing the login?

Also, could you please try if it happens in Safe Mode (Help → Restart with addons disabled)?
And with a clean profile? (here's how to create one → http://kb.mozillazine.org/Profile_Manager)

This will tell us if the problem is caused by an extension or some kind of setting.

Thanks,
Francesca
Flags: needinfo?(epistemepromeneur)
(Reporter)

Comment 2

3 years ago
i restart ff in safe mode
then
i go to bugzilla.novell.com
i manualy fill the id and pwd
then
i login with success
then
i restart FF
then
i go to bugzilla.novell.com
i type the first symbol of the id
then
ff suggest to me the id
then
i select the suggestion
then
ff fill the pwd
then
i login with success !

more : during login in safe mode id and password was recorded without ff asking for me if i want to record them !

then
i delete the recorded id and pwd
then
i go to bugzilla.novell.com
then
i manualy fill the id and pwd
then
i login with success !
this time id and pwd was not recorded

very strange
Flags: needinfo?(epistemepromeneur)
(Reporter)

Comment 3

3 years ago
it's not exactly same pb but it looks like 
- partly to https://bugzilla.mozilla.org/show_bug.cgi?id=1025793
because login fails (before the attempt in safe mode . now it never fails)
- partly to https://bugzilla.mozilla.org/show_bug.cgi?id=1025789
because id and pwd are not recorded except in safe mode
Hi,

as version 30 is out and it's the new stable version of firefox, could you please try if it happens also with that? You can download it here → https://download.mozilla.org/?product=firefox-30.0-SSL&os=linux64&lang=en-US

Thanks!

Francesca
Flags: needinfo?(epistemepromeneur)
(Reporter)

Comment 5

3 years ago
ff 30.0

i go to bugzilla.novell.com
then
i fill id and pwd
then
ff asks for me if i want to record them
then
i confirm
then
i login with success

i check that id and pwd are recorded by ff ; it's ok .

i logout
then
i quit and relaunch ff
then
i go to bugzilla.novell.com
then
ff does not fill the id and pwd

i must type the first symbol of the id then ff suggests the id then i confirm then ff fills the pwd
then
i login with success

sumup :
- 2 improvments : id and pwd are recorded and i login with success
- one pb : ff does not fill the id and pwd
Flags: needinfo?(epistemepromeneur)
Version: 29 Branch → 30 Branch
(Reporter)

Comment 6

3 years ago
if i login into forums.opensuse.org
then
no pb . ff fills id and pwd

the security for forums.opensuse.org and bugzilla.novell.com are implemented by the same 

https://login.attachmategroup.com/nidp/idff/sso?id=6&sid=0&option=credential&sid=0
Ok, I created a profile on bugzilla.novell.com to test this and my results are the same of the reporter (with Firefox 30 and latest Nightly Firefox/33.0 ID:20140623030201 on Linux x86_64).

The first time I login on bugzilla.novell.com, Firefox asks me if I want to store the password, and it successfully stores it (I verified it's present in about:preferences → Security → Saved Password).
The second time I try to login on bugzilla.novell.com - and I would expect to find the form already filled with id and password - the form is empty and it's populated only after I type the first letter of the id and accept the suggestion for the id in the dropdown. At this point, the password field also is populated with the right data.

As pointed out by the reporter, other sites sharing the same single-sign-on system, like forums.opensuse.org, have the normal behaviour (ie: the id and password fields are correctly filled without any input from the user). According to the password manager in firefox, the SSO used is: https://login.attachmategroup.com.

All of this has been tested also in Safe Mode and with a clean profile, with the same results.

I'm confirming this and moving it to Toolkit::Password Manager, which is hopefully the right component :).

I don't know how to further debug this, but as I have created an account there, feel free to let me know if you need more information and/or testing.
Status: UNCONFIRMED → NEW
status-firefox30: --- → affected
status-firefox33: --- → affected
Component: Untriaged → Password Manager
Ever confirmed: true
Product: Firefox → Toolkit
The login <form> has autocomplete=off when visited from bugzilla which is what the logging[1] showed as the reason for not filling. When the login page is visited from the forums, autocomplete=off is not present, the theme is different and the query parameters are different too. It seems like they don't want passwords auto-filled on bugzilla so they intentionally set autocomplete=off. Things seem to be working as designed. I'll dupe this to a bug to ignore autocomplete=off when filling in the password.

[1] https://wiki.mozilla.org/Firefox:Password_Manager_Debugging
Status: NEW → RESOLVED
Last Resolved: 3 years ago
OS: Linux → All
Hardware: x86_64 → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1025703
You need to log in before you can comment on or make changes to this bug.